Jump to content
Sign in to follow this  
Feit

Проблема с D-link 500T

Recommended Posts

Доброй ночи уважаемые! Проблема у меня... Надеюсь на Вашу помощь.

Итак, немного истории...

Простите за небольшой флуд, просто хочу Вас ввести в курс дела... Надоел мне Винд и решил я перейти на Linux. Достал дистрибутив Mandrake Linux 10.0, установил вроде без проблем, но вот с настройкой выхода в и-нет возникли проблемы, провайдер у меня Стрим, модем тоже ихний был (Netronix MN01) конектился к компу он по USB, дров на Линукс я не нашел, но прочитав множество статей и тем в форумах решил я себе взять Ethernet модем, а остановился я на D-Link 500T. Так вот ближе к делу, модем я настроил без проблем, т.е. в Винде он нормально работал... А вот с Линуксом начались проблемы...

В интернет то он выходит, пингует практически все нужные мне сайты, но открывет лишь "избранные", всмысле допустим yandex открывает , linux.ru нет. Загрузка страницы начинается, если начинается, по прошествии примерно пол минуты, причем загрузка произходит достаточно медленно. Браузер у меня Opera 8. Настраивал из KDeveloped (помойму, если ошибаюсь простите пожалуста), сетевая у меня Marvell вот та инфа которую выдавала сия прога:

Производитель: Marevell

Шина: PCI

Идентификатор шины: 11ab:4320:1043:811a

Расположение шины: 0:а:0

Описание: 88Е80001 Gigabit Lan PCI Controller

Модуль: sk98lin

Класс носителя: NETWORK_ETHERNET

Да, и еще, при загрузке выдает eth0 [FAILED], при выкл. тоже самое, идут ошибки связанные с eth0.

Подскажите пожалуста, если кто сможет. Crying or Very Sad Я уже в отчаянии...

Весьма признателен. Заранее благодарен. Прошу не отказать.

Share this post


Link to post
Share on other sites

Docmaster писал(а) пт, 30 декабря 2005 18:53

Модем через eth0 работает, а у eth0 ошибки. Стоит попробовать настроить через drakconnect.

Да, но вопрос как? Не подскажет никто? Да модем работает, но с неимоверной задержкой!!! Простите повторюсь. После ввода в браузере адреса, загрузки яндекса приходится ждать около пол минуты, но скорость закачки в пределах нормы (пытался скачать файл), некоторые адреса просто не загружаются, допустим www.google.com и многие другие сайты... Подскажите пожалуста!!!! Sad Может сетевая не так настроена?

Share this post


Link to post
Share on other sites

А с DNS-сервером вашим все в порядке?

Это я к тому что:

Цитата:

загрузки яндекса приходится ждать около пол минуты, но скорость закачки в пределах нормы (пытался скачать файл), некоторые адреса просто не загружаются, допустим www.google.com и многие другие сайты...

Share this post


Link to post
Share on other sites

Приветствую, товарищи! Вот почти та же проблема, но я даже не могу вылезти на какой-либо сайт. Mandrake 10, DSL 500T. Под виндой всё прекрасно. Под Linux - долго-долго ищет сайт, потом "connecting to..." и дальше я не дождался. Когда настраиваю ADSL в конфигураторе, утверждает (опять же после долгого ожидания), что "система подключена к Интернету", но это ничего не меняет. При загрузке служба ppp виснет, приходится переходить в интерактивную загрузку, пропускать её вручную, потом удалять соединение из конфигуратора. Уф. Вроде всё выложил.

Share this post


Link to post
Share on other sites

1. Вы пользуетесь программным PPPoE клиентом или модем сам делает PPPoE? (соответственно, режимы "bridge" и "router" в настройках модема). Я бы советовал второй вариант. Проблем сразу станет меньше.

Прочитать про настройку вашего модема в режиме маршутизатора можно вот по этой ссылке:

http://www.dlink.ru/technical/faq_xdsl_37.php

Дополнение: Выше описаны настройки для московского провайдера Стрим. Загляните вот по этой ссылке, где описаны настройки для других провайдеров: http://www.dlink.ru/technical/expl_.php

Соответственно, настраиваете сетевой интерфейс, указав в качестве маршрута по умолчанию (default gateway) ip-адрес вашего модема. А также добавьте в /etc/resolv.conf строку 'nameserver X.X.X.X' (без кавычек), где X.X.X.X - ip вдрес DNS сервера вашего провайдера.

Потом настраиваете модем, как описано выше и наслаждаетесь жизнью Smile

Если проблемы останутся, то

2. Покажите вывод команд:

ifconfig

route

cat /etc/resolv.conf | grep nameserver

Попробуем разобраться Smile

P.S. Если возникнут проблемы с настройкой самого модема, пожалуйста, обращайтесь на форум, где эти вопросы обсуждаются, а не сюда.

Share this post


Link to post
Share on other sites

Dr.Spectre писал(а) вт, 24 января 2006 17:44

модем раздает адреса через dhcp?

если да то включите получение адреса сетевой картой по dhcp.

У меня похожий модем (DSL-500G), он по умолчанию - не раздает, насколько я помню. Думаю, что в модели 502Т (это пу существу та же железка) мало что изменилось.

Раздачу адресов по DHCP надо самостоятельно включать а настройках, так что, думаю, проблема не в этом, а в том, что вопрошающий пользуется программным pppoe, с настройкой которого какие-то проблемы.

Share this post


Link to post
Share on other sites

Цитата:

Потом настраиваете модем, как описано выше и наслаждаетесь жизнью Smile

Большое спасибо, кое-что стало ясно. Smile Надо пинать нашего провинциального провайдера насчёт адресов DNS и прочих настроек. Завтра же этим займусь. Дело в том, что в нашей глубинке ADSL-провайдер только один и его услуги пока далеки от совершенства. Sad Они даже понятия не имеют о Linux. Sad

Если информация от провайдера пользы не принесёт, буду спрашивать ещё. Smile

Цитата:

P.S. Если возникнут проблемы с настройкой самого модема, пожалуйста, обращайтесь на форум, где эти вопросы обсуждаются, а не сюда.

Нет, думаю, что дело не в модеме. В виндах же он работает вполне.

Но перенаправление понял Smile воспользуюсь, если понадобится.

Насчёт DHCP - насколько я понял, модем даёт адреса и более того - в виндах включенный DHCP является необходимым условием его работы.

Share this post


Link to post
Share on other sites

Ура!!!

White_Mouse, Dr.Spectre, большое спасибо! Smile

На сайте провайдера не было и намёка на адреса DNS. Долго лазал по инету, наконец нашёл сайт, который позволяет определять DNS по имени сайта, ссылку не помню, в виндах осталась (как догадываетесь, пишу наконец из Линукса). Ввёл туда сайт провайдера, мне вывалилась пара DNS-адресов, которые я радостно ввёл в конфигуратор - и оно свершилось!

Оказывается, всё было совсем не так страшно.

ЗЫ небольшой оффтоп: а ещё мне сегодня покорился TV-тюнер в Линуксе Wink

Share this post


Link to post
Share on other sites

ВО !

у меня тоже DSL 500t . и имеет место быть такая же проблема с открытием страниц , то откроем то нет , и тоже не все ,все открывает только Konqueror в mandriva 2007 . а прикол вот в чем , вчера поставил на второй комп suse 10,2 , на нем все работает отлично , в чем дело в дистрибутивах ?

сетевые на обоих компах от nf4 , одинаковые , модем один

Share this post


Link to post
Share on other sites

Цитата:

ВО !

у меня тоже DSL 500t . и имеет место быть такая же проблема с открытием страниц , то откроем то нет , и тоже не все ,все открывает только Konqueror в mandriva 2007 . а прикол вот в чем , вчера поставил на второй комп suse 10,2 , на нем все работает отлично , в чем дело в дистрибутивах ?

сетевые на обоих компах от nf4 , одинаковые , модем один

таже самая проблема..

вылечилось установкой в настройках сети DNS серверов провайдера а не модем как DNS

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...