Jump to content
Sign in to follow this  
Rashpil

Помогите плз настроить wi-fi (+)

Recommended Posts

помогите плз настроить wi-fi, есть адаптер Wi-Fi

D-Link USB и точка доступа.

Не могу связать, кинте кто нить доку или подскажите плз. как его настроить, никогда такого опыта в Linux не имел Sad

Живу сейчас под OpenSuse 10.2

заранее благодарен,

Share this post


Link to post
Share on other sites

Там в главном меню есть ссылки на всю документацию, в том числе написано как настроить соединение WiFi. Если что-то конкретное не получается - пишите, что именно. Пока вопрос слишком общий.

Share this post


Link to post
Share on other sites

оборудование определилось,прописал все: IP - точки, IP - шлюза, WEP и пр.

Прописал название девайса и WEP в network utilites

не хочет сабака конектиться и все тут Sad даже и не знаю что думать Sad

Помогите плз.

Share this post


Link to post
Share on other sites

Говорю же: подробнее описывайте.

система понимает, что к ней подключено ваше сетевое устройство? В Yast вы его видите в сетевых устройствах?

Аппаратный выключатель на нем какой-нибудь есть?

Share this post


Link to post
Share on other sites

в USB определяется как:

91: udi = '/org/freedesktop/Hal/devices/usb_device_7d1_3c03_noserial'

usb_device.num_interfaces = 1 (0x1)

usb_device.device_class = 0 (0x0)

usb_device.device_revision_bcd = 1 (0x1)

usb_device.version_bcd = 512 (0x200)

linux.sysfs_path_device = '/sys/devices/pci0000:00/0000:00:0b.1/usb2/2-1'

info.bus = 'usb_device'

usb_device.device_subclass = 0 (0x0)

usb_device.speed_bcd = 294912 (0x48000)

usb_device.can_wake_up = false

usb_device.bus_number = 2 (0x2)

usb_device.configuration_value = 1 (0x1)

usb_device.vendor = 'D-Link System'

usb_device.product = '802.11 bg WLAN'

info.udi = '/org/freedesktop/Hal/devices/usb_device_7d1_3c03_noserial'

usb_device.max_power = 300 (0x12c)

linux.subsystem = 'usb'

usb_device.device_protocol = 0 (0x0)

info.vendor = 'D-Link System'

usb_device.num_configurations = 1 (0x1)

info.product = '802.11 bg WLAN'

linux.hotplug_type = 2 (0x2)

linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:0b.1/usb2/2-1'

usb_device.vendor_id = 2001 (0x7d1)

usb_device.num_ports = 0 (0x0)

usb_device.is_self_powered = false

usb_device.linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:0b.1/usb2/2-1'

usb_device.product_id = 15363 (0x3c03)

info.parent = '/org/freedesktop/Hal/devices/usb_device_0_0_0000_00_0b_1'

info.linux.driver = 'usb'

usb_device.linux.device_number = 2 (0x2)

В сетевых интерфейсах:

69: None 00.0: 1070a WLAN

[Created at net.118]

UDI: /org/freedesktop/Hal/devices/net_00_17_9a_77_8f_dc

Unique ID: AYEt.QXn1l67RSa1

Parent ID: FKGF.LIdAwp7aR84

SysFS ID: /class/net/wlan0

SysFS Device Link: /devices/pci0000:00/0000:00:0b.1/usb2/2-1/2-1:1.0

Hardware Class: network interface

Model: "WLAN network interface"

Driver: "rt73usb"

Driver Modules: "rt73usb"

Device File: wlan0

HW Address: 00:17:9a:77:8f:dc

Config Status: cfg=no, avail=yes, need=no, active=unknown

Attached to: #59 (Unclassified device)

Share this post


Link to post
Share on other sites

Rashpil писал(а) Mon, 19 March 2007 21:00

не хочет сабака конектиться и все тут Sad даже и не знаю что думать Sad

Помогите плз.

что пишет в логах при попытке "когда собака не коннектится"

Share this post


Link to post
Share on other sites

Mar 21 00:21:19 linux-zro4 kernel: wlan0: cannot create symlink to default key

Mar 21 00:21:19 linux-zro4 kernel: wlan0: Initial auth_alg=0

Mar 21 00:21:19 linux-zro4 kernel: wlan0: authenticate with AP 00:00:00:00:00:00

Mar 21 00:21:19 linux-zro4 zmd: NetworkStatus (WARN): Network has been disconnected

Mar 21 00:21:19 linux-zro4 zmd: NetworkStatus (WARN): Network has been disconnected

Mar 21 00:21:19 linux-zro4 zmd: NetworkStatus (WARN): Network has been disconnected

Mar 21 00:21:19 linux-zro4 zmd: NetworkStatus (WARN): Network has been disconnected

Mar 21 00:21:19 linux-zro4 kernel: wlan0: authenticate with AP 00:00:00:00:00:00

Mar 21 00:21:19 linux-zro4 kernel: wlan0: authenticate with AP 00:00:00:00:00:00

Mar 21 00:21:19 linux-zro4 kernel: wlan0: authentication with AP 00:00:00:00:00:00 timed out

Mar 21 00:25:44 linux-zro4 kernel: wlan0: Initial auth_alg=0

Mar 21 00:25:44 linux-zro4 kernel: wlan0: authenticate with AP 00:00:00:00:00:00

Mar 21 00:25:44 linux-zro4 kernel: wlan0: authenticate with AP 00:00:00:00:00:00

Mar 21 00:25:45 linux-zro4 kernel: wlan0: authenticate with AP 00:00:00:00:00:00

Mar 21 00:25:45 linux-zro4 kernel: wlan0: authentication with AP 00:00:00:00:00:00 timed out

Share this post


Link to post
Share on other sites

Судя по последнему логу, точну доступа всё-таки не видно. Проверьте правильность настроек wi-fi(SSID, ключи, если есть и т.д.). Как это делается в графике, не знаю, я использую команду iwconfig в консоли под рутом. Работающее подключение должно выглядеть примерно так:

[root@damned ~]# iwconfig 
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11b  ESSID:"AP-SSID"  Nickname:"Nickname"
          Mode:Managed  Frequency:2.412 GHz  Access Point: 00:02:6F:33:B2:4C   
          Bit Rate=11 Mb/s   
          Encryption key:off
          Link Quality:0/100  Signal level:-72 dBm  Noise level:-256 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

sit0      no wireless extensions.

Обратите внимание, что в поле Access Point должен отображаться mac-адрес Вашей точки доступа.

Share this post


Link to post
Share on other sites

Если в графике, то настраивается это в Yast, а в КДЕ есть программа Network Manager (в Yast в разделе про сетевые устройства надо включить управление соединениями через нее, там есть выбор: страндартный метод с ifup или через NEtwork Manager). В ней все вполне очевидно.

Share this post


Link to post
Share on other sites

К сожалению так ничего и не заработало, ни при настройке через YaST, ни через прогу которая подтягивает виндовские дрова:(

Начинаю отчаиваться:(

по поводу mac адреса тоже глушняк прописать не смог:(

честно говоря с консолью имею некоторые проблемы, могу пользоваться на уровне средненького пользователя (не все знаю и помню). из хеллпа к команде iwconfig ничего не понял Sad

Если не трудно кому нить написать поэтапно для "идиотов", что то типа инструкции сделайте плз.

Я думаю это поможет многим, кто столкнулся или столкнется с настройкой Wi-Fi.

С уважением,

Ю.

Share this post


Link to post
Share on other sites

Ну сколько же можно инструкций, позвольте?

У вас в дистрибутиве есть инструкция: Меню запуска -> Далее либо в избранном, либо в Программах Пункт "Справка". Там написано, как настраивать. Отдельные руководства к iwconfig и к ndiswrapper...

Судя по тому, что вы уже рассказали, устройство нормально работает и драйвер для него нашелся, просто вы что-то не так делаете!

Короче, перед тем как просить инструкцию для идиотов убедитесь, что вы хоть что-то сами сделали, кроме пятиминутного тыкания мышкой в Yast и сидения в этом форуме.

Для начала попробуйте озадачить себя следующими вопросами:

1. Вы уверены, что сама точка настроена правильно и она вообще вас может пустить в сеть???

2. Пробовали другим устройством подцепиться к точке доступа?

3. Вы уверены, что точно знаете, с какими натройками ваша точка работает, и что именно эти настройки вы вводите в Yast?

4. Вы читали справку, указанную выше (раздел про WiFi из руководства по системе в целом)?

5. Настраивая соединение в Yast ставите там "традиционный метод с ifup" или пользуетесь "Network Manager"? Попробуйте другой способ.

Share this post


Link to post
Share on other sites

Добрыое время суток!!!

У меня PCi WiFi D-Link DWl-510G

Дык вот.....как проверить что он у меня конкретно и корректно работает?

ifcjnfig пишет что-то типа device not found.

а iwconfig в скриншоте....

как ещё можно проверить?

Но в KNetworkManager у меня стоит название SSID и определяется устройство RaLink RT2561/RT61 rev.B 802.11g (wlan0). И на самой сетевухе горит один диод из двух.Наличие сети не может определить(хотя она должна быть....у меня Мас и он с виндозой коннектится легко)

Просто для начала хочется выяснить корректно ли стоит железо....а потом копать настройки.....

Подробнее в скриншоте....index.php?t=getfile&id=390&private=0

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...