Jump to content
Sign in to follow this  
DenisM

Samsung R40+ Проблемы с установкой Linux

Recommended Posts

Купил бук(R40Plus xy02), попытался поставить на него линукс, ASP 11.2 даже не хочет запускать установку в графическом режиме. Mandriva 2007 ставится, но как дело доходит до настройки видео, не хочет ставить стандартный драйвер, работает только без икса. С Кубунту, убунту и эдубунту такая же проблема, лив-сд даже не загружаются. FedoraCore и SuSe не ставятся. Скачал драйвер на видео (интегрированное в SB600, видео Ati Radeon Xpress 1250), в мандриве через MC указал, запустил установку (файл с расширением *.RUN), вроде все ставится, потом ошибка какая-то, startx ничего не дает. Звук есть, все работает, кроме икса. Подскажите как решить проблему, или я может что то не так делаю?

Share this post


Link to post
Share on other sites

DenisM писал(а) Tue, 07 August 2007 13:20

Купил бук(R40Plus xy02), попытался поставить на него линукс, ASP 11.2 даже не хочет запускать установку в графическом режиме. Mandriva 2007 ставится, но как дело доходит до настройки видео, не хочет ставить стандартный драйвер, работает только без икса. С Кубунту, убунту и эдубунту такая же проблема, лив-сд даже не загружаются. FedoraCore и SuSe не ставятся. Скачал драйвер на видео (интегрированное в SB600, видео Ati Radeon Xpress 1250), в мандриве через MC указал, запустил установку (файл с расширением *.RUN), вроде все ставится, потом ошибка какая-то, startx ничего не дает. Звук есть, все работает, кроме икса. Подскажите как решить проблему, или я может что то не так делаю?

1. Вроде все как ставится, или точно ставится?

2. Приведите ошибки, который выдаёт startx.

3. Видяха какая?

Share this post


Link to post
Share on other sites

Ставится точно, только иксы не ставит, вернее не может видеоподсистему сконфигурировать, драйвер не находит.

Видео интегрированное, в чип AtiRadeon Xpress 1250 (RS600). Драйвер на видео скачал с офф сайта "ati-driver-installer-8.39.4-x86.x86_64.run"

Share this post


Link to post
Share on other sites

DenisM писал(а) Tue, 07 August 2007 22:12

Ставится точно, только иксы не ставит, вернее не может видеоподсистему сконфигурировать, драйвер не находит.

Видео интегрированное, в чип AtiRadeon Xpress 1250 (RS600). Драйвер на видео скачал с офф сайта "ati-driver-installer-8.39.4-x86.x86_64.run"

У Вас ОС 64-битная, почему Вы ставите драйвера для аим 64-битные?

Share this post


Link to post
Share on other sites

После запуска STARTX выдает следующее:

Fatal server error:

no screens found

X10: fatal I0 error 104 (Connection reset by peer) on X server ":0.0"

after 0 requests (0 known processed) with 0 events remaining

Share this post


Link to post
Share on other sites

DenisM писал(а) Thu, 09 August 2007 13:05

После запуска STARTX выдает следующее:

Fatal server error:

no screens found

X10: fatal I0 error 104 (Connection reset by peer) on X server ":0.0"

after 0 requests (0 known processed) with 0 events remaining

И всё? Маловато будет.

Share this post


Link to post
Share on other sites

Здравствуйте. У меня аналогичная проблема. Ноут такой-же.

При установке Убунты 7,04 пишет "Failed to start the X server..."

"...

(EE) VESA(0): No matching modes

(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:

no screens found

X10: fatal I0 error 104 (Connection reset by peer) on X server ":0.0"

after 0 requests (0 known processed) with 0 events remaining"

Вот лог.

Share this post


Link to post
Share on other sites

WarKhort писал(а) Thu, 09 August 2007 15:36

Здравствуйте. У меня аналогичная проблема. Ноут такой-же.

При установке Убунты 7,04 пишет "Failed to start the X server..."

"...

(EE) VESA(0): No matching modes

(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:

no screens found

X10: fatal I0 error 104 (Connection reset by peer) on X server ":0.0"

after 0 requests (0 known processed) with 0 events remaining"

Вот лог.

Вы устанавливаете АТИшные дрова, а пользуетесь vesa?

Вы уж тогда укажите в xorg.conf, что у вас ати, а не веса.

И потом ошибки в студию.

Share this post


Link to post
Share on other sites

Эта ошибка возникает при стандартной установке.

Установить дрова не получается, - при выполнении "bash ati-driver-installer-8.36.5-x86.x86_64.run --buildpkg Ubuntu/feisty" пишет:

Generating package: Ubuntu/feisty

./packages/Ubuntu/ati-packager.sh: 175: dpkg-architecture: not found

Error: unsupported architecture

Removing temporary directory: fglrx-install.QA8270

Дрова последние с оф. сайта - ati-driver-installer-8.39.4-x86.x86_64.run

Вот лог Х сервера с выбранными атишными дровами.

Share this post


Link to post
Share on other sites

WarKhort писал(а) Fri, 10 August 2007 09:56

Эта ошибка возникает при стандартной установке.

Установить дрова не получается, - при выполнении "bash ati-driver-installer-8.36.5-x86.x86_64.run --buildpkg Ubuntu/feisty" пишет:

Generating package: Ubuntu/feisty

./packages/Ubuntu/ati-packager.sh: 175: dpkg-architecture: not found

Error: unsupported architecture

Removing temporary directory: fglrx-install.QA8270

Дрова последние с оф. сайта - ati-driver-installer-8.39.4-x86.x86_64.run

Вот лог Х сервера с выбранными атишными дровами.

Ну и всё. Ясно же сказано, архетиктура не поддерживается.

Не для дебиана.

Share this post


Link to post
Share on other sites

Так эта проблема не только в убунту/кубунту, мандрива 2007 и АСП 11.2 тоже такая же трабла. АСП так вообще в графическом режиме ставится не хочет. Полюбому как то проблему решить можно, только вот как.

Кто нибуть может подробно, пошагово описать процесс установки драйвера в линуксе? плисс )))

Share this post


Link to post
Share on other sites

WarKhort писал(а) Fri, 10 August 2007 10:12

Так что, об Линуксе можно забыть? Crying or Very Sad

Подскажите, что ещё можно попробовать?

Попробуйте FC7, мандриву 2007LC (только не спринг)...

Любой современный rpm based дисирибутив.

Share this post


Link to post
Share on other sites

DenisM писал(а) Fri, 10 August 2007 10:26

Так эта проблема не только в убунту/кубунту, мандрива 2007 и АСП 11.2 тоже такая же трабла. АСП так вообще в графическом режиме ставится не хочет. Полюбому как то проблему решить можно, только вот как.

Кто нибуть может подробно, пошагово описать процесс установки драйвера в линуксе? плисс )))

Какая такая проблема, не можете установить драйвера АТИ?

Ну тогда ошибки в студию...

Share this post


Link to post
Share on other sites

Так дело в том что я не очень то в линуксе лабаю, может ошибки в процессе установки, незнаю.

Ставлю так:

Запускаю линукс

Захожу под рутом

Набираю MC, иду в папку /home/user/share/ati_driver/...

ENTER, запускаю ati-driver-installer-8.39.4-x86.x86_64.run

Отвечаю на пару вопросов.

В конце установки запускается их страничка, там лицензия и тп.

Если нажимаю выход, вылазит ошибка установки и все закрывается.

Share this post


Link to post
Share on other sites

DenisM писал(а) Fri, 10 August 2007 11:25

Так дело в том что я не очень то в линуксе лабаю, может ошибки в процессе установки, незнаю.

Ставлю так:

Запускаю линукс

Захожу под рутом

Набираю MC, иду в папку /home/user/share/ati_driver/...

ENTER, запускаю ati-driver-installer-8.39.4-x86.x86_64.run

Отвечаю на пару вопросов.

В конце установки запускается их страничка, там лицензия и тп.

Если нажимаю выход, вылазит ошибка установки и все закрывается.

А ошибку привести?

Share this post


Link to post
Share on other sites

Установка начинается со следующего:

You are running a x86 machine with glibe-2.1

Operating System: Mandrake Linux 2007.0

Потом выбираю:

Install driver 8.39.4 on X.Org 7.1 and later releases

В конце установки всплывает:

Would you like to a Web browser?

Если ответишь YES то попадаешь на хтмл страницу мануала, если NO то всплывает:

There were errors during installation.

Details can be found in.

/usr/share/ati/fglrx-install.log

Содержимое этого лога:

[Message] Kernel Module: Trying to install a precompiled kernel module.

[Message] Kernel Module: Precompiled kernel module version mismatched.

[Error] Kernel Module: No kernel module build environment - please consult readme.

Share this post


Link to post
Share on other sites

DenisM писал(а) Fri, 10 August 2007 14:18

Установка начинается со следующего:

You are running a x86 machine with glibe-2.1

Operating System: Mandrake Linux 2007.0

Потом выбираю:

Install driver 8.39.4 on X.Org 7.1 and later releases

В конце установки всплывает:

Would you like to a Web browser?

Если ответишь YES то попадаешь на хтмл страницу мануала, если NO то всплывает:

There were errors during installation.

Details can be found in.

/usr/share/ati/fglrx-install.log

Содержимое этого лога:

[Message] Kernel Module: Trying to install a precompiled kernel module.

[Message] Kernel Module: Precompiled kernel module version mismatched.

[Error] Kernel Module: No kernel module build environment - please consult readme.

Precompiled kernel module version mismatched.

Вот и ошибка.

Нужно заново перекомпилить и переустановить ядро.

У Вас сырцы ядра полные , или стрип?

Если стрип - поставьте полные и попробуйте ещё раз установть дрова.

Share this post


Link to post
Share on other sites

))) всего то...перекомпилировать ядро))) я неделю назад узнал что такое линукс...))) как можно перекомпилировать ядро, что для этого нужно, напишите пожалуйста последовательно, что за чем

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...