Jump to content
Sign in to follow this  
beetle2001

MonoDevelop 2.0

Recommended Posts

Всем привет!

Вчера поставил MonoDevelop 2.0 на Ubuntu 8.1(interpid)Собирал с исходников, которые взял с официального сайта, долго устанавливал зависимости но вроде все без ошибок стало.

Запускаю MonoDevelop - на панели задач появляется соответствующая задача и возле указателя мыши появляется соответствующий значок. Это длится 5-10 секунд и после этого все исчезает и больше ничего не происходит.

Может я какие-то компоненты недоустановил?

Я собираюсь поставить все компоненты с этой страницы:

http://ftp.novell.com/pub/mono/sources-stable/

Кто-нибудь подскажет куда копать?

Share this post


Link to post
Share on other sites

sudo aptitude install monodevelop - вытянет только Monodevelop 1.0, а мне надо именно 2.0, у первой версии визуального дебагера нет и прочих вкусностей, на официальном сайте пишут что 2.0 пока из бинарников недоступен

Share this post


Link to post
Share on other sites

кстати не могу понять, почему нельзя все зависимости и нужные компоненты сложить в одно место или на диск какой-нить хотя бы и по человечески выложить, а то куча всего нужна и ищи её где хочешь)

Share this post


Link to post
Share on other sites

вот что имеем если запустить со строки:

beetle@beetle:~$ monodevelop

WARNING: Cannot find Mozilla directory containing libgtkembedmoz.so. Some Addins may not be able to function. Please set MOZILLA_FIVE_HOME to your Mozilla directory.

** (/usr/local/lib/monodevelop/bin/MonoDevelop.exe:5869): WARNING **: The following assembly referenced from /usr/local/lib/monodevelop/bin/MonoDevelop.Core.dll could not be loaded:

Assembly: Mono.Addins.Setup (assemblyref_index=7)

Version: 0.3.0.0

Public Key: 0738eb9f132ed756

The assembly was not found in the Global Assembly Cache, a path listed in the MONO_PATH environment variable, or in the location of the executing assembly (/usr/local/lib/monodevelop/bin/).

** (/usr/local/lib/monodevelop/bin/MonoDevelop.exe:5869): WARNING **: Could not load file or assembly 'Mono.Addins.Setup, Version=0.3.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756' or one of its dependencies.

** (/usr/local/lib/monodevelop/bin/MonoDevelop.exe:5869): WARNING **: The following assembly referenced from /usr/local/lib/monodevelop/bin/MonoDevelop.exe could not be loaded:

Assembly: Mono.Addins (assemblyref_index=3)

Version: 0.3.0.0

Public Key: 0738eb9f132ed756

The assembly was not found in the Global Assembly Cache, a path listed in the MONO_PATH environment variable, or in the location of the executing assembly (/usr/local/lib/monodevelop/bin/).

** (/usr/local/lib/monodevelop/bin/MonoDevelop.exe:5869): WARNING **: Could not load file or assembly 'Mono.Addins, Version=0.3.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756' or one of its dependencies.

** (/usr/local/lib/monodevelop/bin/MonoDevelop.exe:5869): WARNING **: Missing method get_Registry in assembly /usr/local/lib/monodevelop/bin/MonoDevelop.exe, type Mono.Addins.AddinManager

Unhandled Exception: System.IO.FileNotFoundException: Could not load file or assembly 'Mono.Addins, Version=0.3.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756' or one of its dependencies.

File name: 'Mono.Addins, Version=0.3.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756'

то что сборки не хватает я вижу)) только вот как определить где и что нужно скачать? ))

Share this post


Link to post
Share on other sites

вобщем, всем спасибо за внимание, поставил но намучался. Проблема была в том что по умолчанию установлена моно версии 1, а для MonoDevelop 2 нужен моно более новой версии. Получается что я ставил более новую версию моно поверх старой, чего делать нельзя. В этом и была проблема. Надо снести первую версию и потом только ставить вторую либо ставить вторую версию но так чтоб не смешать обе версии и потом запускать MonoDevelop 2 под новую версию моно.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...