Jump to content

Maxxon

Members
  • Content Count

    19
  • Joined

  • Last visited

    Never
  1. Привет! Имеется некий (по заверениям, мультиплатформенный) веб софт на Java, в который девелоперы умудрились захардкодить некие пути через "C:\". Учитывая то, что на данный момент нет source code, но есть необходимость запустить этот софт под linux, какие могут быть пути решения? Надо как-то обмануть, иначе tomcat у меня просто не стартует
  2. Привет На мой взгляд, есть четыре варианта: 1. Если есть доступ к UPDATE серверу и там работает rsync сервер, то можно включить (или увеличить дебаг-левел) логгинг операций и анализировать лог после отдачи файлов на сервере, без помощи клиента. 2. Если используется протокол ssh для синхронизации, значит можно после выполнения апдейта на клиенте подготовить скрипт (shell или, даже лучше, на TCL, например, используя expect скрипт), который будет долбить update сервер с целью положить туда нотификацию о статусе апдейта, используя ssh, scp или sftp протоколы. 3. Создать общий location, скажем ftp на другом, доступном и клиенту и серверу, и класть нотификации туда или использовать почтовую рассылку. 4. Использовать SOAP или другие протоколы, обеспечивающие гарантированную доставку данных.
  3. Привет всем! Я тут задался вопросом имплементации FTP failover solution для стабильной работы хранилища данных объемом примерно 1-1,5 Тбайт в условиях не всегда стабильной сети (большая нагрузка на сеть, за день трафик чуть ли не терабайтами) при наличии, скажем, двух-трех отдельных нод. Пошарившись по сети (например http://www.opennet.ru/prog/sml/148.shtml) обнаружил n-ое количество софта для этого, но по сути их можно сгруппировать в одно: отказоустойчивый кластер с общим storage или с сетевой файловой системой или проксирование с балансировкой нод опять же с зеркалированием. Посему очень хотелось бы узнать ваше мнение: кому какие приходилось имплементировать, какие впечатления, что кто может порекомендовать... В принципе, проксирование с предварительной проверкой нод оптимально, но может ли кто-нибудь порекомендовать стабильный solution (не скрипт)?
  4. Инсталлер мне сам предложил установить оба пакета, что и видно: maxxon:~ # rpm -qa | grep nvidia x11-video-nvidiaG01-100.14.19-4 nvidia-gfxG01-kmp-default-100.14.19_2.6.22.5_30-1.1 maxxon:~ # lsmod | grep nvidia nvidia 7050692 24 i2c_core 43648 2 nvidia,i2c_i801 А вот xorg.conf: ============================================================ ==== Section "ServerLayout" Identifier "Layout[all]" Screen "Screen[0]" 0 0 InputDevice "Keyboard[0]" "CoreKeyboard" InputDevice "Mouse[1]" "CorePointer" Option "Clone" "off" Option "Xinerama" "off" EndSection Section "Files" InputDevices "/dev/gpmdata" InputDevices "/dev/input/mice" FontPath "/usr/share/fonts/misc:unscaled" FontPath "/usr/share/fonts/local" FontPath "/usr/share/fonts/75dpi:unscaled" FontPath "/usr/share/fonts/100dpi:unscaled" FontPath "/usr/share/fonts/Type1" FontPath "/usr/share/fonts/URW" FontPath "/usr/share/fonts/Speedo" FontPath "/usr/share/fonts/PEX" FontPath "/usr/share/fonts/cyrillic" FontPath "/usr/share/fonts/latin2/misc:unscaled" FontPath "/usr/share/fonts/latin2/75dpi:unscaled" FontPath "/usr/share/fonts/latin2/100dpi:unscaled" FontPath "/usr/share/fonts/latin2/Type1" FontPath "/usr/share/fonts/latin7/75dpi:unscaled" FontPath "/usr/share/fonts/baekmuk:unscaled" FontPath "/usr/share/fonts/japanese:unscaled" FontPath "/usr/share/fonts/kwintv" FontPath "/usr/share/fonts/truetype" FontPath "/usr/share/fonts/uni:unscaled" FontPath "/usr/share/fonts/CID" FontPath "/usr/share/fonts/ucs/misc:unscaled" FontPath "/usr/share/fonts/ucs/75dpi:unscaled" FontPath "/usr/share/fonts/ucs/100dpi:unscaled" FontPath "/usr/share/fonts/hellas/misc:unscaled" FontPath "/usr/share/fonts/hellas/75dpi:unscaled" FontPath "/usr/share/fonts/hellas/100dpi:unscaled" FontPath "/usr/share/fonts/hellas/Type1" FontPath "/usr/share/fonts/misc/sgi:unscaled" FontPath "/usr/share/fonts/xtest" FontPath "/opt/kde3/share/fonts" EndSection Section "Module" Load "glx" Load "type1" Load "extmod" Load "dbe" Load "freetype" EndSection Section "ServerFlags" Option "AllowMouseOpenFail" "on" EndSection Section "InputDevice" Identifier "Keyboard[0]" Driver "kbd" Option "Protocol" "Standard" Option "XkbLayout" "us,ru" Option "XkbModel" "microsoftpro" Option "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll" Option "XkbRules" "xfree86" Option "XkbVariant" ",winkeys" EndSection Section "InputDevice" Identifier "Mouse[1]" Driver "mouse" Option "Buttons" "5" Option "Device" "/dev/input/mice" Option "Name" "ImPS/2 Generic Wheel Mouse" Option "Protocol" "explorerps/2" Option "Vendor" "Sysp" Option "ZAxisMapping" "4 5" EndSection Section "Modes" Identifier "Modes[0]" ModeLine "1280x1024" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync EndSection Section "Monitor" Identifier "Monitor[0]" VendorName "VSC" ModelName "VIEWSONIC VA902" UseModes "Modes[0]" DisplaySize 376 301 HorizSync 30.0 - 82.0 VertRefresh 43.0 - 85.0 Option "CalcAlgorithm" "XServerPool" Option "DPMS" EndSection Section "Device" Identifier "Device[0]" Driver "nvidia" VendorName "NVidia" BoardName "Geforce 7100 GS (NV44)" Screen 0 EndSection Section "Screen" Identifier "Screen[0]" Device "Device[0]" Monitor "Monitor[0]" DefaultDepth 24 Option "AllowGLXWithComposite" "True" Option "RenderAccel" "True" Option "AddARGBGLXVisuals" "True" SubSection "Display" Depth 15 Modes "1280x1024" "1024x768" "800x600" EndSubSection SubSection "Display" Depth 16 Modes "1280x1024" "1024x768" "800x600" EndSubSection SubSection "Display" Depth 24 Modes "1280x1024" "1024x768" "800x600" EndSubSection SubSection "Display" Depth 8 Modes "1280x1024" "1024x768" "800x600" EndSubSection EndSection Section "Extensions" Option "Composite" "Enable" EndSection ============================================================ ==== Запустил sax2 с ключом -r. Чекбокс "Acivate 3D accelleration" выставлен. Блин, неужели заработало? Подскажите, пожалуйста, как проверить (если не запускать игрушки, конечно)?
  5. Да, попробовал из репозитория. К сожалению, ничего нового не произошло. Инсталлятор перезаписал тот модуль, который у меня уже был - версия та же. Я запустил nvidia-config с тем параметрами, что указаны на этой странице чтобы подключить Compiz, однако и это не помогло...
  6. Товарищи! Если среди вас такие, кто сталкивался с проблемой установки драйверов для [NVidia GeForce 7100GS] под Сусю? В OpenSuSE 10.2 x86_64 драйвер вставал без проблем и конфигурился Sax2 без вопросов. Вчера поставил 10.3 x86_64, качнул последний драйверок с nvidia.com, поставил. Sax2 мне теперь говорит, что нет поддержки 3D (я так понял, что вообще), хотя в 10.2 все работало, да и в виндах даже... [sax2 can not offer the activation of the 3d subsystem because your card/driver doesn't support 3d] На каком-то форуме видел сообщение, что проблема в новом Xorg, который интегрирован в 10.3. Стоит ли откатывать его? Или кто-то уже решил подобную проблему другим путем (я не говорю, про отказ от дистрибутива, кончено же)?
  7. Приветствую всех! Может мне кто-нибудь подсказать приличный парсер bat-файлов? Есть необходимость перенести кучку bat файлов на Linux... Руками полнстью править слишком много времени уходит...
  8. Привет! У меня такая же видяха и ось. Поставил вот отсюда: http://www.nvidia.ru/object/linux_display_amd64_100.14.03_ru .html 1) Установить сырцы, make и gcc, если они еще не установлены. 2) Загрузиться в консоль (см. /etc/inittab) (3 уровень) 3) sh NVIDIA-Linux-x86_64-1.0-9746-pkg2.run -q 4) sax2 -r -m 0=nvidia (0 - это цифра) Далее ребут и... все работает
  9. Думаю, надо задать такой вопрос на форуме xine.org kaffeine - это лишь оболочка, основа - xine Увы, не сталкивался с такой проблемой.
  10. Привет всем! Знает ли кто-нибудь что надо указать в конфиге vsftpd, чтобы при аплоаде на FTP файла с определенными permissions, эти permissions сохранялись в загруженном файле? Может кто-нибудь видел статью, касательно этой проблемы?
  11. Забыл сказать: для управления этими LDAP-серверами используется машина на базе WindowsXP, так как на ней работают процессы, которые не могут быть запущены под Линуксом.... Это меня как раз и останавливает... Либо надо ставить серверный Windows либо искать другие пути. Какие еще могут быть варианты? Я пробовал проксю DeleGate, но к ней не прикрутить мониторинг LDAP (по крайней мере, у меня не получлось )
  12. Очень просто. Сразу после коннекта к db в php скрипте надо писать: $query = "SET NAMES кодировка"; $result = MYSQL_QUERY($query); для работы с нужной кодировкой Ну и в теге head <head> <meta http-equiv='Content-Type' content='text/html; charset=windows-1251'> <meta http-equiv='Content-Language' content='ru'> </head> для корректного отображения на клиентской стороне. В my.cnf должна быть прописана нужная кодировка в секции [mysqld] сервера: default-character-set=кодировка (файл с кодировкой должен быть скомпилирован при сборке)
  13. В локальной сети есть несколько серверов LDAP. Между собой данные реплицируются. Есть отдельный сервер, на который надо поставить прокси-LDAP для того, чтобы запросы шли на любой работающий в данный момент, так как иногда один из них падает. Иными словами, есть задача объединить эти несколько LDAP-серверов в кластер с помощью прокси. С помощью чего лучше всего реализовать данную процедуру и где мне найти информацию о таких примерах?
  14. В конторе установлена машина на Mandriva 2006, которая выполняет роль шлюза. На ней стоит Squid, iptables, shorewall. NAT сделан с помощью конфигуратора в X. Два Ethernet интерфейса: внешний - XXX.XXX.XXX.XXX и 192.168.0.1 - внутренний, к которому подключена остальная сеть. Интернет через проксю работает нормально. На днях бухгалтерам установили программу типа Банк-Клиент. Она на локальной машине с Windows запускает свой прокси-сервер на порту 4040 и через него пытается связаться с банком по адресу YYY.YYY.YYY.YYY на порт 1400. Соответственно, shorewall не пускает. В банке требуюут, чтобы порт 1400 на сервер был открыт (полагаю, в обе стороны). Несколько дней уже бьюсь с этим shorewall и никак не удается открыть этот порт . Через конфигуратор иксов - не открывается, хотя он пишет, что порт открыт. Через WebMin при поытке добавить новое правило, shorewall не запускается. При ручном добавлении правила в /etc/shorewall/rules авила принимает, но порт все равно закрыт в обе стороны. Пробовал ACCEPT на $FW с net и loc - не проходит (хотя ssh открыт именно так). Пробовал через DNAT на конкретный статический адрес во внутренней сети - не проходит. Смотрю iptables, а он вообще пустой - все правила ему дает shorewall. Есть тут специалисты по shorewall, кто сможет мне подсказать данные правила, чтобы открыть 1400 порт хотя бы для всех в обе стороны?
×
×
  • Create New...