Jump to content

Avrigus

Members
  • Content Count

    47
  • Joined

  • Last visited

    Never

About Avrigus

  • Rank
    Advanced Member

Contact Methods

  • Website URL
    http://n/a
  • ICQ
    121447166

Profile Information

  • Location
    Тюменская обл. г. Нижневартовск
  • Interests
    UNIX
  1. респект, параметр net.ipv4.conf.all.forwarding=1 в /etc/sysctl.conf решил проблему. нашел в списке параметров sysctl.
  2. Привет всем имеется etch r0, не могу настроить форвардинг в этой оси, конфиг файл (/etc/networking/options) в котором он включался в предыдущих версиях (woody, sarge) отсутствует. порыл в инете, там сказано раскоментировать строку net.ipv4.conf.default.forwarding=1, в файле /etc/sysctl.conf. но это действие не помогло, после перезагрузки содержание файла /proc/sys/net/ipv4/ip_forward по прежнему 0. можно конечно сунуть в какой-нибудь init-скрипт echo 1 > /proc/sys/net/ipv4/ip_forward, но, думаю все согласятся что это граничит с извращением, хотелось бы включить форвардинг средствами конфиг файлов оси. Может кто сталкивался с этой проблемой, помогите плз.
  3. Доброго времени суток Собираю kde 3.5.4, все собирается и работает нормально за исключением пакета локализации. Сам пакет собирается но изменение настроек с русского на английский не действует. при выборе языка, русский в меню присутствует но после выбора русского ничего не меняется, в списке выбранных языков остается все тот же анлийский. Может кто сталкивался? или кто знает что необходимо для корректной установки kde-i18n? debian 3.1 kde 3.5.4
  4. Приветствую всех не удается подключить дополнительный swap-раздел на новом жеском диске. создал на нем раздел, при создании обозначил тип раздела swap. прописал в /etc/fstab: /dev/hdb1 none swap sw 0 0. при выполнении swapon -a выводит ошибку: # swapon -a swapon: /dev/hdb1: Invalid argument что не так делаю, подскажите плз.
  5. привет всем есть проблема с настройкой openafs 1.4.0. Проблема возникает в самом конце настройки при создании раздела. Настраивал по доке с сайта gentoo.org (http://www.gentoo.org/doc/ru/openafs.xml). в соответствии с докой раздел создается командой: /usr/afs/bin/vos create <server name> <partition name> root.afs -cell <cell name> -noauth вот результат выполнения этой комнады у меня: # vos create afs.home.net /vicepa root.afs -cell home -noauth vos : partition /vicepa does not exist on the server Если кто сталкивался, помогите плз. Заранее спасибо kernel 2.6.13 openafs 1.4.0 debian sarge
  6. Приветствую всех Есть проблемка, не компилится самый простой пример из книги. Код следующий #include <qapplication.h> #include <qlabel.h> int main(int argc, char *argv[]) { QApplication app(argc, argv); QLabel *label = new QLabel("Hello, Qt!", 0); app.setMainWidget(label); label->show(); return app.exec(); } при компиляции выходит это: avrigus@evil-toy:~/devel/qt$ qmake -project avrigus@evil-toy:~/devel/qt$ ls qt.cpp qt.pro avrigus@evil-toy:~/devel/qt$ qmake qt.pro avrigus@evil-toy:~/devel/qt$ ls Makefile qt.cpp qt.pro avrigus@evil-toy:~/devel/qt$ make g++ -c -pipe -Wall -W -O2 -DQT_NO_DEBUG -I/usr/share/qt3/mkspecs/default -I. -I. -I/usr/include/qt3 -o qt.o qt.cpp g++ -o qt qt.o -L/usr/X11R6/lib -lXext -lX11 -lm qt.o(.text+0x2a): In function `main': : undefined reference to `QApplication::QApplication[in-charge](int&, char**)' qt.o(.text+0x50): In function `main': : undefined reference to `QString::QString[in-charge](char const*)' qt.o(.text+0x6e): In function `main': : undefined reference to `QLabel::QLabel[in-charge](QString const&, QWidget*, char const*, unsigned)' qt.o(.text+0x84): In function `main': : undefined reference to `QString::shared_null' qt.o(.text+0x8e): In function `main': : undefined reference to `QStringData::deleteSelf()' qt.o(.text+0x9a): In function `main': : undefined reference to `QApplication::setMainWidget(QWidget*)' qt.o(.text+0xad): In function `main': : undefined reference to `QApplication::exec()' qt.o(.text+0xb7): In function `main': : undefined reference to `QApplication::~QApplication [in-charge]()' qt.o(.text+0xe0): In function `main': : undefined reference to `QString::shared_null' qt.o(.text+0xea): In function `main': : undefined reference to `QStringData::deleteSelf()' qt.o(.text+0x104): In function `main': : undefined reference to `QApplication::~QApplication [in-charge]()' qt.o(.gnu.linkonce.r._ZTV6QGList+0xc): undefined reference to `QGList::clear()' qt.o(.gnu.linkonce.r._ZTV6QGList+0x10): undefined reference to `QGList::~QGList [in-charge]()' qt.o(.gnu.linkonce.r._ZTV6QGList+0x14): undefined reference to `QGList::~QGList [in-charge deleting]()' qt.o(.gnu.linkonce.r._ZTV6QGList+0x18): undefined reference to `QPtrCollection::newItem(void*)' qt.o(.gnu.linkonce.r._ZTV6QGList+0x20): undefined reference to `QGList::compareItems(void*, void*)' qt.o(.gnu.linkonce.r._ZTV6QGList+0x24): undefined reference to `QGList::read(QDataStream&, void*&)' qt.o(.gnu.linkonce.r._ZTV6QGList+0x28): undefined reference to `QGList::write(QDataStream&, void*) const' qt.o(.gnu.linkonce.r._ZTI6QGList+0x8): undefined reference to `typeinfo for QPtrCollection' collect2: ld returned 1 exit status make: *** [qt] Ошибка 1 Подскажите в чем проблема. QT 3.3.4 из дистрибутива Debian 3.1, g++ 3.3.5 из дистриба, gcc 3.3.5 из дистриба. Ядро 2.6.8
  7. Приветствую Есть проблемка, рисую в дизайнере форму, сохраняю, qmake, make. make не проходит, ругается ld - не может найти -lqt. Как лечить? Qt компилял сам в /usr.
  8. Привет всем Помогите разобраться с сабжем, никак не могу настроить. Какие модули ядра (2.6.11.2) отвечают за модем? Раньше был мотор v3 проблем не знал, с этим прямо замучался.
  9. Приветствую Помогите разобраться, скачал патч к ядру, с качал hibernate. Собрал ядро, судя по логам все ок, ядро фунциклирует. Настроил на FileWriter. остановка проходит нормально, но при восстановлении глухо виснет в самом начале, сразу как ядро передает управление suspend2. Жесткий диск вращается довольно тихо и я не уверен, но, кажется он при этом полностью отрубается. По логам ничего сказать нельзя, т.к. туда ничего не успевает падать. При завершении ошибок в логе не наблюдается. Конфиг системы следующий: kernel 2.6.16.5 + соответствующий патч suspend2 debian 3.1 Hibernate Script 1.12 MB Intel i865GBF 512 RAM (Dual Channel) CPU 2.6GHz (With Hyper Threading) HDD ST3120026AS Serial ATA 133 (драйвер взят из раздела ядра SCSI Device Support и диск виден как /dev/sda) Sound - Creative Live! KBD - USB Genius (with USB Hub) Mouse - Genius PS/2 TV Tuner PCI на BT848 Video i865G Может что-то стоит отключать конфигом? Помогите, может кто сталкивался.
  10. клавиатура genius slims tar pro kkb2050hs. Решение искать конечно пробывал но не особо настойчиво, посмотрел что было в дистрибе (debian 3.1), поставил hotkeys, судя по всему он работает только с определенными моделями клавиатур, да и потом с xmodmap все получилось, меня это вполне устраивает, надо только заставить ее работать еще и на ядре 2.6.8. Впрочем у нее еще есть скролл, который не хочет работать даже на ядре 2.4.27
  11. доброго времени суток есть проблема, приобрел мультимедийную клаву, попытался настроить через xmodmap, на ядре 2.4.27 все получилось, но 2.6.8 не воспринимает мультимедийные педали, проверял через xev - ведет себя так, как будто я ничего и не нажимал. Полагаю есть какойто параметр в ядре или параметр загрузки модуля, помогите разобраться.
  12. да, конечно описаны, я же говорю что сам dns функционирует исправно, в прошлом сообщении приводил тест с nslookup
  13. приветствую всех есть проблема, имеется dhcp и dns сервер, нужно что бы при выдаче ip адреса автоматически обновлялись прямая и обратная зоны dns. Пошарив на opennet.ru нашел документацию к настройке, настроил в соответствии с ней: /etc/bind/named.conf key DHCP_UPDATER { algorithm HMAC-MD5.SIG-ALG.REG.INT; secret "<ключ>"; }; zone "home.net" IN { type master; file "/etc/bind/db.home.net"; allow-update { key DHCP_UPDATER; }; }; zone "0.16.172.in-addr.arpa" IN { type master; file "/etc/bind/db.16.172"; allow-update { key DHCP_UPDATER; }; }; -------------------------------------------------- /etc/dhcp3 option domain-name "home.net"; option domain-name-servers dvar.home.net; option subnet-mask 255.255.255.0; option broadcast-address 172.16.0.255; ddns-update-style interim; use-host-decl-names true; default-lease-time 604800; max-lease-time 1814400; key DHCP_UPDATER { algorithm HMAC-MD5.SIG-ALG.REG.INT; secret <ключ>; }; subnet 172.16.0.0 netmask 255.255.255.0 { range 172.16.0.5 172.16.0.10; option routers 172.16.0.2; } zone home.net { primary 127.0.0.1; key DHCP_UPDATER; } zone 16.172.in-addr.arpa { primary 127.0.0.1; key DHCP_UPDATER; } --------------------------- далее проверяю: # nsupdate > server 172.16.0.2 > key DHCP_UPDATER <ключ> > zone home.net > update add virtual 86400 A 172.16.0.2 > send update failed: NOTZONE в это же самое время в логи падает: Jan 05 16:15:13.262 update: info: client 172.16.0.2#32792: updating zone 'home.net/IN': update failed: update RR is outside zone (NOTZONE) то же самое происходит и с обратной зоной Сами по себе зоны работают: # nslookup > server Default server: 172.16.0.2 Address: 172.16.0.2#53 > jabber.home.net Server: 172.16.0.2 Address: 172.16.0.2#53 jabber.home.net canonical name = dvar.home.net. Name: dvar.home.net Address: 172.16.0.2 > 172.16.0.2 Server: 172.16.0.2 Address: 172.16.0.2#53 2.0.16.172.in-addr.arpa name = dvar.home.net. Помогите плз, уже не знаю куда копать debian sarge 3.0 r0 kernel 2.6.8 isc-dhcpd-V3.0.1 bind 9.2.4
  14. Приветствую всех Почему то не монтируется iso образ на ядре 2.6.8, из мана по mount взял строку mount /tmp/fdimage /mnt -t msdos -o loop=/dev/loop3,blocksize=1024 вбиваю в шеле # mount hl2_cd1.iso /mnt -t iso9660 -o loop=/dev/loop4 на что он мне отвечает mount: wrong fs type, bad option, bad superblock on /dev/loop4, missing codepage or other error In some cases useful info is found in syslog - try dmesg | tail or so смотрю в /var/log/messages Jan 8 18:08:28 evil-toy kernel: Unable to identify CD-ROM format. модуль loop загружен, если монтировать реальный компакт диск то проблем нет. Помогите. kernel 2.6.8 mount-2.12p debian sarge 3.1 r0
  15. Приветствую всех Есть проблема с сабжем Имеется поток #1, при подключении потока #2 начинаются проблемы, информация о потоке (на вэб модуле) #1 игнорируется и вместо нее отображается информация о потоке #2. поток #1 и поток #2 имеют разные плейлисты, но тем не менее вместо потока #1 проигрывается поток #2. поток #2 я подключал в через конфиг файл ices2.xml, который находится в аттаче. конфиг icecast я оставил по умолчанию.
×
×
  • Create New...