Jump to content

cresta

Members
  • Content Count

    92
  • Joined

  • Last visited

    Never

Everything posted by cresta

  1. Разобрался: chmod на lp0 помог
  2. Попробуйте зайти рутом и очистить минимально необходимое для запуска юзером место. В крайнем случае удалить юзера. В линуксе нет никакого предупреждения о недостатке места, поэтому при переполнении раздела просто негде создавать рабочие директории. В особо тяжёлых случаях при копировании файлов на раздел тупо перетираются другие файлы.
  3. Добрый день. Нужна помощь с принтером. Принтер установил с родными дровами. Никаких проблем. Распечатал пробную страницу, пару документов. На следующий день принтер наотрез отказался печатать. Задания отправляются на принтер и сидят в очереди печати. Пробовал удалить и установить снова - та же ерунда. Сканер сканирует, а принтер не печатает. Сам мфу исправен, из винды прекрасно печатает. Как его заставить печатать?
  4. debootstrap Пример создания тут: http://www.opennet.ru/tips/info/1512.shtml
  5. Собственно как это сделать? 32-битное окружение в 64-битной системе... Всё, что я нашёл - для дебиана, в мандриве таких команд, которыми строятся окружения в дебиан просто нет. Может где есть ссылки
  6. Действительно, скопировал ядро и образ на 32-битный раздел? запустилась 64-битная система Видимо по этой же причине после установки 64-битной при загрузке 32-х пыталось загрузиться ядро от 64 Спасибо за помощь!
  7. lilo.conf для 32-бит: # File generated by DrakX/drakboot # WARNING: do not forget to run lilo after modifying this file default="linux-32" boot=/dev/sda install=menu prompt nowarn timeout=100 message=/boot/message image=/boot/vmlinuz label="linux-32" root="UUID=448762d0-cfc0-11dd-9029-73462a196d5c" initrd=/boot/initrd.img append="resume=/dev/sda5 splash=silent mem=4096M" vga=791 image=/boot/vmlinuz label="linux-nonfb" root="UUID=448762d0-cfc0-11dd-9029-73462a196d5c" initrd=/boot/initrd.img append="resume=/dev/sda5 splash=silent mem=4096M" vga=791 image=/boot/vmlinuz label="failsafe" root="UUID=448762d0-cfc0-11dd-9029-73462a196d5c" initrd=/boot/initrd.img append="failsafe" other=/dev/sda1 label="windows" image=/boot/vmlinuz label="linux-64" root=/dev/sda8 initrd=/boot/initrd.img append="resume=/dev/sda9 splash=silent mem=4096M" vga=794 содержимое директории boot на /dev/sda8: boot.0800 boot.backup.sda config config-2.6.24.4-server-1mnb gfxmenu initrd-2.6.24.4-server-1mnb.img initrd.img initrd-server.img kernel.h kernel.h-2.6.24.4-server-1mnb map message message-text System.map System.map-2.6.24.4-server-1mnb vmlinuz vmlinuz-2.6.24.4-server-1mnb vmlinuz-server initrd.img и initrd-server.img - ссылки на initrd-2.6.24.4-server-1mnb.img vmlinuz и vmlinuz-server - ссылки на vmlinuz-2.6.24.4-server-1mnb Пробовал самостоятельно указывать рут-раздел, образ и ядро, пробовал использовать соответствующую секцию из lilo.conf для 64-битной системы, результат один: выводит 6 раз сообщение request_module: runaway loop modprobe binfmt-464c и замерзает.
  8. В общем, как я понял, дело в загрузчике. 64-битная система при установке загрузчика вписала для 32-битной не то ядро, которое нужно: kernel-server-2.6.24.4-1mnb - Linux Kernel for server use with i686 & 64GB RAM Я это ядро устанавливал, пытаясь задействовать более чем 3Гб ОЗУ По логам загрузки грузилось это ядро. После запуска с диска Resque System утилиты восстановления загрузчика 32-битная система грузится теперь нормально. Вот только 64-битная теперь пропала Как теперь восстановить загрузку 64? Копирование секций из lilo.conf (как из 32 в 64, так и наоборот) ничего не дает. 64 бита не грузятся, застревая на сообщении request_module: runaway loop modprobe binfmt-464c Сделать из 32 битной системы chroot на /mnt/sda8 и запустить lilo тоже не удается, тамошний конфигуратор lilo 64-битный и не запускается из 32-х В общем со всех сторон засада В принципе возможно заставить lilo корректно грузить 32 и 64-разрядные системы одновременно?
  9. В обоих системах сделано так, что есть только одна точка монтирования для "/". И swap. Для 32-битной системы к / монтируется sda6, swap на sda5 Для 64-битной системы к / монтируется sda8, swap на sda9 В логах загрузки сообщается, что (например для сетевой карты) устройство не может быть запущено на установленном драйвере r8169
  10. Здравствуйте! Установлено: /dev/sda1 - winxp /dev/sda6 - mandriva 2008 (32bit) установил на /dev/sda8 mandriva 2008 (64bit) После этого 32-битная версия практически перестала функционировать. Система загружается, но из устройств работает только видеокарта и мышь. Звуковая карта не работает, сетевая карта не работает, клавиатура не работает, usb-устройства не работают, кнопка выключения питания не работает, 1394 не работает. Сама 64-битная система установилась без проблем и функционирует нормально, а 32-битная повреждена при установке 64-битной. Каким образом пересеклись /dev/sda6 и /dev/sda8, честно говоря я даже не представляю. Можно ли поправить 32-битную систему? Или проще пристрелить и поставить заново?
  11. В настройках eth0 указал первый dns адрес dns-сервера провайдера. Сейчас пишу из мозиллы Спасибо! А всё-таки интересно, как konqueror и другие утилиты справляются, если dns-сервер модема не работает? У них что, другие источники, чем у мозиллы и оперы?
  12. Почитал ссылку и: Сделал себе статический адрес, добавил его в список Lan-клиентов как статический, также указал его в DMZ модема. В настройках DHCP(!) имена серверов DNS прописать вручную Где эти настройки DHCP? В настройках модема ничего такого не нашёл. И какие имена нужно прописывать?
  13. Вот ещё одно наблюдение: мозилла и опера при наборе в адресной строке http://217.23.133.20 благополучно открывают страницу linux.ru. А дальше, по ссылкам - ни в какую не хотят
  14. Что-то я совсем ничего не понимаю... Интернет оказывается у меня работает, но только если пользоваться в качестве браузера Konqueror'ом Мозилла и Опера ничего не видят . В настройках на всякий случай поглядел - никаких прокси не задействовано. Что за приколы такие? На данный момент у меня из сетевых подключений есть только eth0, pppoe я удалил. Вот все настройки интерфейса eth0: 1. Автоматический IP (BOOTP/DHCP) 2. Опция "Получать серверы DNS от DHCP" активирована 3. Клиент DHCP - dhclient 4. Таймаут не оговорен 5. Опция "Получать серверы YP от DHCP" активирована То есть все настройки те, которые предложены по умолчанию утилитой drakconnect P.S. filezilla, kget, ktorrent тоже работают...
  15. Так он и настроен роутером. До этого было бридж. Логин-пароль вписаны. vci/vpi тоже. При запуске системы всплывает сообщение, что сеть поднята и адрес машины 192.168.1.5, шлюз 192.168.1.1
  16. Добрый день! Проблема с интернетом. Есть сеть: 3 виндовые машины и 1 линукс. Есть модем. Изначально адреса всех машин были статические, модем был настроен как bridge. Всё работало (в т.ч. интернет). Затем модем был переведен в режим pppoe и адреса виндовых машин сменены на динамические. После этого интернет присутствует только на виндовых машинах. На линуксе интернета нет. Пробовал перестроить линукс-машину со статического адреса на динамический - ничего не дало. Локальную сеть вижу, а интернета нет. Пробовал удалить соединение по локальной сети и создать подключение через pppoe - интренета по-прежнему нет. Перепробовал все способы организации сети, перечисленные в drakconnect - глухо Что делать? Нужна помощь. Спасибо. P.S. Mandriva 2008. P.P.S. Из винды, установленной в виртуальной машине (хост - линукс), интернет тоже есть
  17. да я давно уже кроме пакетов дистрибутива ничего не использую. В дистрибе Мандривы 2008 есть и qt3 и qt4, но ни та, ни другая не ставятся,т.к. в системе установлена libpng-devel-1.2.25-2mdv2008.1, а требуется более старая, чем 1.2.25 Однажды я уже пытался удалять новые версии и ставить более старые - еле восстановил потом систему
  18. Как бороться с этой проблемой? Хочу установить qt хоть третий, хоть четвертый - без разницы. Но уперся в несовместимость версий установленных пакетов. Применение force и т.п. ни к чему хорошему не приведет. Что делается в общем случае при возникновении подобных граблей? Или это извечная фирменная нерешаемая проблема линукса?
  19. У вас дистрибутив One. Требуемый пакет есть в дистрибутиве 2008 Spring Free. Или скачайте пакеты libbinutils2 и binutils
  20. Пробовал создавать другого пользователя - та же картина. Зависает видимо на стадии, когда ещё до конкретного пользователя дело не доходит
  21. Хотел посмотреть на kde4. Установил Mandriva 2009. После установки не заходит под пользователем: Загружаюсь, в verbose mode после сообщения, что включена кириллица самой кириллицы не видать, только квадратики. Далее белый экран и курсор. Более ничего. В безопасном single user заходит, как рут стартую X, и далее без проблем, всё отлично. Но только под рутом. Под обычным пользователем кроме белого экрана ничего. При загрузке в verbose mode никаких ошибок не выводится. Может дело в кодировке? То, что вместо кириллицы квадратики? Подскажите, как можно это поправить? P.S. Пробовал переустановить заново - результат тот же
  22. Про sda1 - это естественно опечатка. Система на sda6. А последовательность действий, которая привела к невозможности входа в систему, полностью, шаг за шагом, описана в первом сообщении темы. Под рутом я не сижу, и зашел только когда стало невозможно зайти под пользователем
  23. sdb6 - это не моя система. Систему я пару часов назад переустановил заново. Она находится на sda1. Практически голая, поэтому всего 3Гб. sdb6 - это раздел подключенного другого винта. Вот для этого sdb6 dh показывает одно, а df показывает другое. Почему? Да и вообще главный вопрос этой темы - почему пользовательские файлы оказались в корне раздела? Там вообще никаких файлов быть не должно. Как такое могло произойти?
  24. Ребята, о каком df или du речь? Я не могу ничего сделать, система неработоспособная. Была. Сейчас я переустановил всё заново. Данные полученные разными способами, разные. Вот например подключил винт Нужно на sdb6 (60Гб, примонтировал на /mnt/ext2.) залить инфу. Проверяю: du -H -s /mnt/ext2 выдает 34G /mnt/ext2 Далее другой способ df -h выдает Файловая система Разм Исп Дост Исп% смонтирована на /dev/sda6 17G 3,3G 13G 21% / /dev/sda1 15G 15G 0 100% /mnt/win_c /dev/sda8 25G 8,1G 17G 33% /mnt/win_e /dev/sdb1 26G 18G 8,1G 68% /mnt/ext0 /dev/sdb6 57G 57G 0 100% /mnt/ext2 Кому верить? P.S. Да и почему перед каждой операцией копирования нужно проверять свободное место? Если не влезает, то почему нет предупреждения?
×
×
  • Create New...