Jump to content

vadhome

Members
  • Content Count

    2
  • Joined

  • Last visited

    Never
  1. Под Линуксами радио работает на ура... Использую sc_trans и sc_serv с http://www.shoutcast.com + консольный микшер aumix CODE [root@radio sc_trans_040]# cat /opt/sc_trans_040/sc_trans.conf PlaylistFile=/opt/sc_trans_040/example.lst ; ServerIP/ServerPort are the target server to send to ServerIP=localhost ServerPort=8000 ; Password is the password on the sc_serv you're sending to. Password=123896 StreamTitle=LuxFM StreamURL=http://www.lux.fm Genre=Pop LogFile=sc_trans.log ; Shuffle the playlist Shuffle=1 Bitrate=96000 SampleRate=44100 Channels=1 ; Quality is from 1-10. 1 is best, 10 is fastest. Quality=1 CrossfadeMode=0 ; Length is ms. CrossfadeLength=8000 UseID3=0 ; Public determines whether or not this station will show up in the directory Public=0 Это - конфиг источника сигнала.. Далее плейлист.. CODE [root@radio sc_trans_040]# cat /opt/sc_trans_040/example.lst DSP:/dev/dsp DSP:/dev/dsp и.. сервер CODE [root@radio sc_trans_040]# cat /opt/shoutcast-1-9-5-linux-glibc6/sc_serv.conf MaxUser=32 Password=123896 PortBase=8000 LogFile=sc_serv.log RealTime=0 ScreenLog=0 ShowLastSongs=10 W3CEnable=Yes W3CLog=sc_w3c.log SrcIP=127.0.0.1 DestIP=10.1.10.8 Yport=80 NameLookups=0 AutoDumpUsers=0 AutoDumpSourceTime=30 TitleFormat=Linet Radio: %s PublicServer=never AllowRelay=Yes AllowPublicRelay=No MetaInterval=32768 Далее в аумиксе выставляю, что считается источником на карте (микрофон, Line-In или что-то ещё), сохраняю конфиг аумикса и всьо
  2. установил shoutcast sc_trans. c mp3 всё замечательно работает, но вото только стоит мне брать звук с звуковой карты происходит такая беда <09/24/07@22:11:23> [MAIN] PID: 2958 <09/24/07@22:11:23> [MAIN] Loaded config from sc_trans.conf <09/24/07@22:11:23> [MAIN] Loading playlist (example.lst) <09/24/07@22:11:23> [MAIN] Found (1) entries in playlist <09/24/07@22:11:23> [MAIN] Playlist decoder thread starting <09/24/07@22:11:23> [MAIN] Streaming thread starting <09/24/07@22:11:23> [DECODE] DSP (/dev/dsp) opened (16,2,44100) <09/24/07@22:11:23> [CONFIG] WARNING: No InputSamplerate defined, assuming 44100! <09/24/07@22:11:23> [CONFIG] WARNING: No InputChannels defined, assuming 2! <09/24/07@22:11:23> [sTREAM] Creating stream socket <09/24/07@22:11:23> [sTREAM] Connected to host server <09/24/07@22:11:23> [sTREAM] Host server gave success (OK2) <09/24/07@22:11:23> [sTREAM] Stream to 192.168.102.18 established <09/24/07@22:11:23> [sTREAM] Sending stream information <09/24/07@22:11:25> [MAIN] Title Updated И тишина. Как бы сигнал принимает. а звук не идёт или идёт какойто шум и плавно переходит в тишину. Помогите PS Карта C-Media PCI CMI8738 6 канальная
×
×
  • Create New...