Jump to content
Sign in to follow this  
wils0n

debian: ERROR while getting interface flags: No such device

Recommended Posts

Уважаемые линуксознатели.

Помогите пожалуйста, сам я не догоняю в силу неграмотности. В общем, поставил Debian 3.0 c ядром 2.2.20 потом апгрейдил с помощью apt-get до Debian 3.1. Всё бы хорошо, но только autofs не захотел запускаться, так как ядро не поддерживало autofs, точнее не хватало модуля autofs4. Ну я, не долго думая, решил перекомпилировать ядро до 2.4.20 (не спрашивайте почему такие древние версии ядер, просто так надо в силу некоторых причин). В общем, ядро скомпилировал, только теперь сетевуха не находится.

В общем, как только комп загружается до конца, то с помощью

> modprobe 3c59x
> ifconfig eth0 192.168.100.122 netmask 255.255.255.0 up

привожу сетевуху в себя. Но при следующей загрузке история повторяется. Что делать?

В /etc/network/interfaces стоит всё на auto'мате и dhcp. Вот надо, чтоб также и осталось. Так IP должен определятся именно через DHCP.

Благодарю.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...