Перейти к содержимому
ytf

failed to start virtualbox linux kernel module

Рекомендуемые сообщения

У меня подобная ситуация была при обновлении пакетов с virtualbox 5.1 на 5.2.  Суть в том что в ядре остается драйвер 5.1 и он не работает с программой 5.2. Версия 5.2 не может "вставить" свой модуль в ядро. Причиной обновления стало то, что даже после установки guest extension virtualbox 5.1 эмулятор с виртуальной машиной windows XP отказывался запускать машину и выдавал ошибку связанную с USB контроллером 2.0. В версии 5.2 такая ошибка при установке гостевых расширений 5.2 отсутствует. В версии 5.1 она лечится или заменой USB2.0 на USB1.0 или полным отключением USB  в виртуальной машине. В моем случае "лечилось" все даунгрейдом до версии 5.1 и полным отключением USB. Попробуйте sudo dpkg -P virtualbox или sudo apt-get purge virtualbox, а затем установите снова. Возможно у вас был vbox 5.2, попробуйте установить пакет версии 5.1   sudo dpkg -i   name.deb.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

У меня появилось подобное уведомление для Vbox 5.1, при загрузке. Система Debian 9.4 x64. Ядро 4.9 ххх . Решение было установить VirtualBox 5.2.16 , с полным удалением 5.1. Ошибка исчезла. Так же исчезла ошибка с USB 2.0 что была на 5.2.0 и не давала стартовать виртуальной машине с включенным USB 2.0 (из-за чего я сидел на 5.1)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас

×