Jump to content
Sign in to follow this  
[Debian]Odmin

Сетевая загрузка

Recommended Posts

Проблема возникла

В общем настроил DHCP , TFTP, загружает ядро...и..выдает :

Using IPI Shortcut mode

ACPI:(supports S0 S1 S4 S5)

RAMDISK: Could't find valid RAM disk image starting at 0.

VFS:Cannot open root devise "<NULL>" or unknown-block(104,7)please append a correct "root=" boot option /Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block

что не так...пожалйсто подскажите!

Share this post


Link to post
Share on other sites

Прошу заметить что у меня проблемы нес TFTP и BOOTP загрузкой...

Проблема заключаеться в том что в файле конфигурации т.е. :

/var/lib/tftpboot/pxelinux.conf/default в этом файле есть записи вида

LABEL linux

kernel debian-installer/i386/linux

append vga=normal initrd=debian-installer/i386/initrd.gz --

так вот..при добавлении в строку еще и root=(IP)далее директорию корневой файлоой системы

он выдает уже не VFS:Cannot open root devise "<NULL>" or unknown-block(104,7)please append a correct "root=" boot option Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block

а то что мы указываем в добавленой строке т.е. :

VFS:Cannot open root devise "(IP)далее директорию корневой файлоой системы" or unknown-block(0,0)please append a correct "root=" boot option /Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block

Share this post


Link to post
Share on other sites

RAMDISK: Could't find valid RAM disk image starting at 0.

Похоже в файле конфига указан неправильный путь к имиджу.

PS и уберите пож картинку в подписи - либо уменьшите ее до приличия.

Share this post


Link to post
Share on other sites

С этим я уже разобрался...просто в конфиге не был указан параметр что нужно грузить через NFS ..

Ща возникла проблема с тем...что не могу понять как сделать так чтобы ядро грузило не файлы установки ( т.е. бездисковая станция предлогает установку ) а загружало корневую систему....

Share this post


Link to post
Share on other sites

да я понимаю....

Дело том что когда я ему прописываю свое ядро

при загрузке бездисковой станции он пишет что не может загрузить этот образ....

Share this post


Link to post
Share on other sites

Цитата:

IP-Conf:No Network devices available.

c этим я разобрался...просто не включил поддержку драйверов...

Но вот

VFS:Cannot open root device "nfs" or unknown -block (o,255)

Так и вылазит...

Share this post


Link to post
Share on other sites

в общем ща такая тема

ADDRCONF(NETDEV_UP):eth0: link is not ready

IP-Config: Complete:

device=eth0, addr=192.168.19.90, mask=255.255.255.0, gw=192.168.19.1,

host=www, domain=, nis-domain=aha.com,

bootserver=192.168.19.17, rootserver=192.168.19.17, rootpath=

Looking up port of RPC 100003/2 on 192.168.19.17

portmap:server 192.168.19.17 not responding, time out

Root-NFS:Unable to get nfsd port number from server, using default

Looking up port of RPC 100005/1 on 192.168.19.17

portmap:server 192.168.19.17 not responding, time out

Root-NFS: unable to get mountd port number from server, using default

mount: server 192.168.19.17 not responding , time out

Root-NFS: server returned error -5 while mounting /boot_from_net/net_root

VFS: Unable to mount root fs via NFS, trying floppy

э..что это?)))

Share this post


Link to post
Share on other sites

>>в общем ща такая тема

>>ADDRCONF(NETDEV_UP):eth0: link is not ready

>>IP-Config: Complete:

>>device=eth0, addr=192.168.19.90, mask=255.255.255.0, >>gw=192.168.19.1,

>>host=www, domain=, nis-domain=aha.com,

>>bootserver=192.168.19.17, rootserver=192.168.19.17, rootpath=

>>Looking up port of RPC 100003/2 on 192.168.19.17

>>portmap:server 192.168.19.17 not responding, time out

>>Root-NFS:Unable to get nfsd port number from server, using >>default

>>Looking up port of RPC 100005/1 on 192.168.19.17

>>portmap:server 192.168.19.17 not responding, time out

>>Root-NFS: unable to get mountd port number from server, using >>default

>>mount: server 192.168.19.17 not responding , time out

>>Root-NFS: server returned error -5 while mounting >>/boot_from_net/net_root

>>VFS: Unable to mount root fs via NFS, trying floppy

>>э..что это?)))

привет, всем))))

можно узнать как была решена эта проблема??? а то уже неделю мучаюсь никак не могу понять, что не так))))

Share this post


Link to post
Share on other sites

Looking up port of RPC 100003/2 on 192.168.0.1

rpcbind: server 192.168.0.1 not responding, timed out

Root-NFS: Unabled to get nfsd port number from server, using default

Looking up port of RPC 100005/1 on 192.168.0.1

mount: server 192.168.0.1 not responding, timing out

Root-NFS: Unabled to get mountd port number from server, using default

mount: server 192.168.0.1 not responding, timed out

Root-NFS: Server returned error -5 while mounting /opt/ltsp/i386

VFS: Unabled to mount root fs via NFS, trying floppy.

вот что у меня выводит, единственное отличие в том. что у меня вместо portmap написано rpcbind.

а так все проверл не по разу: портмап запущен, нужные сервисы там зарегистрированы, вот))))

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...