Перейти к содержимому

LinuxPotter

Members
  • Публикации

    4
  • Зарегистрирован

  • Посещение

    Никогда

О LinuxPotter

  • Звание
    Newbie

Contact Methods

  • ICQ
    217390307

Profile Information

  • Location
    Украина, Киев
  • Interests
    Программирование и линух
  1. Проблема с установкой openoffice

    Не поможет. Пишет же Missing keyword - ошибка в портажах поковырял openoffice-2.0.1.ebuild помогло - добавил в KEYWORDS "~amd64" после чего: # ebuild /usr/portage/app-office/openoffice/openoffice-2.0.1.ebuild digest а после этого # echo "app-office/openoffice ~amd64" >> /etc/portage/package.keywords # echo "app-office/openoffice" >> /etc/portage/package.unmask # emerge openoffice Всё нормально. Но снова же. Скомпилилось 13\14 пакетов. А потом при компиляции собственно openoffice вылетает следующая ошибка: /usr/lib/gcc/x86_64-pc-linux-gnu/3.4.4/../../../../x86_64-pc -linux-gnu/bin/ld: .libs/cxx_db.o: relocation R_X86_64_32S against `vtable for Db' can not be used when making a shared object; recompile with -fPIC .libs/cxx_db.o: could not read symbols: Bad value collect2: ld returned 1 exit status make[1]: *** [libdb_cxx-4.2.la] Error 1 make[1]: Leaving directory `/var/tmp/portage/openoffice-2.0.1/work/ooo-build-2.0.1.2/bu ild/ooa680-m1/berkeleydb/unxlngx6.pro/misc/build/db-4.2.52.N C/out' dmake: Error code 2, while making './unxlngx6.pro/misc/build/so_built_so_berkeleydb' '---* tg_merge.mk *---' ERROR: Error 65280 occurred while making /var/tmp/portage/openoffice-2.0.1/work/ooo-build-2.0.1.2/bui ld/ooa680-m1/berkeleydb make: *** [stamp/build] Error 1 !!! ERROR: app-office/openoffice-2.0.1 failed. !!! Function src_compile, Line 216, Exitcode 2 !!! Build failed !!! If you need support, post the topmost build error, NOT this status message. Т.к. я новичёк ,то не знаю как реагировать... Где ковырять хоть? Наводящий вопрос: где посмотреть, что означают конкретные use для конкретноко пакета. Я ,например собирал с такими юзами: [ebuild N ] app-office/openoffice-2.0.1 -binfilter +curl +eds +gnome +gtk +java +kde +ldap +mozilla +xml2 +zlib Ещё вопрос: что это за berkeleydb, нафига мне субд, о которой я ничего не знаю, обязательный ли это пакет, если нет , то где его можно отключить совсем?
  2. запускаю у себя emerge openoffice These are the packages that I would merge, in order: Calculating dependencies !!! All ebuilds that could satisfy "openoffice" have been masked. !!! One of the following masked packages is required to complete your request: - app-office/openoffice-2.0.1 (masked by: package.mask, missing keyword) For more information, see MASKED PACKAGES section in the emerge man page or refer to the Gentoo Handbook. Что с этим добром делать?
  3. Для начала отрывок из xorg.conf. Линух, естественно женту Section "InputDevice" Identifier "Keyboard1" Driver "keyboard" Option "AutoRepeat" "500 5" Option "XkbModel" "pc105" Option "XkbLayout" "us,ru" Option "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll" EndSection Возникла следующая проблемка. Хочется как-то настроить себе XkbLayout или что-то в этом роде, чтобы при включенной русской раскладке на месте английской раскладки "/" была русская "." и "," с шифтом соответственно а не "/" Аналогично на месте англ "(" - русск "?" а не "(" англ ")" - русск "%" а не ")" т.е. чтобы можно было отредактировать раскладку "для себя"
  4. Сразу скажу, что я новичок в линуксе Согласно с правилами 1.a)Мать K8NF4G-SATA2(socket 754),AMD Sempron64 2800+,nForce4, nVidia6100 on board,ALС850 (7.1 AC`97) sound. b)Linux Kernel v2.6.14-gentoo-r5 Configuration x86-64 2.Хочу добиться, чтобы грузился драйвер на встроенную звуковуху 3.Выставляю в настройках ядра (menuconfig) поддержку alsa для моего чипсета <*> Intel/SiS/nVidia/AMD/ALi AC97 Controller в результате при запуске alsaconf у меня не детектится звук вообще. Тогда я сделал по-другому - выставил модулем <M> Intel/SiS/nVidia/AMD/ALi AC97 Controller и скомпилил дрова отдельно alsa-driver-1.0.9b_26 # env ALSA_CARDS='intel8x0' emerge alsa-driver Звуковуха задетектилась. Я прописал в /etc/modules.d/alsa alias char-major-116 snd options snd major=116 cards_limit=1 alias snd-card-0 snd-intel8x0 options snd-intel8x0 index=0 id="ICH" alias sound-service-0-0 snd-mixer-oss alias sound-service-0-1 snd-seq-oss alias sound-service-0-3 snd-pcm-oss alias sound-service-0-8 snd-seq-oss alias sound-service-0-12 snd-pcm-oss alias /dev/mixer snd-mixer-oss alias /dev/dsp snd-pcm-oss alias /dev/midi snd-seq-oss После долгожданного /etc/init.d/alsasound start вижу * ERROR: Failed to load necessary drivers Догадок и предположений... Нет Просто я буквально 23 дня назад разбил свой диск полностью под линух, предварительно 4 года просидев под виндой. Помогите освоиться^) Спасибо всем, кто откликнется
×