Jump to content

FreeHold

Members
  • Content Count

    2
  • Joined

  • Last visited

    Never

Everything posted by FreeHold

  1. Проблема, в-основном, решена путем установки ядра Linux Home-CentOS-6 2.6.39-4.1.el6.elrepo.i686 и соответствующих драйверов к девайсам под данное ядро. Блютуз, правда, так и не хочет работать (хотя на предыдущем ядре мне удалось его как-то заставить работать, комбинируя различный фирмваре с различными драйверами - полагаю, и здесь заставлю, со временем). Всем спасибо.
  2. Апнем тему - вдруг нашлось решение? Доброго времени суток, уважаемые! В Линуксах я чуть менее, чем полный ноль, поэтому прошу сразу не запинывать ногами. $ uname -a Linux Home-CentOS-6 2.6.32-220.el6.centos.plus.i686 #1 SMP Mon Dec 19 11:44:15 GMT 2011 i686 i686 i386 GNU/Linux Суть вопроса: установил на свой ноут (HP ProBook 4720s) CentOS 6 (с гномом) - решил прикоснуться к неизведанному. (впрочем, KDE тоже ставил - не понравилось - снес) В-основном, все устраивает и радуваит. Главная проблема - wifi (который не пускается вообще) и bluetooth, который, вроде как, говорит что работает, но на самом деле это не так - его обнаружить не получается, он тоже никого обнаружить не может. Что касается bluetooth: Home-CentOS-6 Загрузки]$ lsusb Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub Bus 001 Device 003: ID 138a:0007 Validity Sensors, Inc. VFS451 Fingerprint Reader Bus 001 Device 004: ID 046d:c018 Logitech, Inc. Optical Wheel Mouse Bus 001 Device 005: ID 0461:4db6 Primax Electronics, Ltd Bus 002 Device 003: ID 148f:1000 Ralink Technology, Corp. Home-CentOS-6 Загрузки]$ hcitool dev Devices: hci0 70:F3:95:F5:6D:F4 Home-CentOS-6 Загрузки]$ hciconfig hci0: Type: BR/EDR Bus: USB BD Address: 70:F3:95:F5:6D:F4 ACL MTU: 310:10 SCO MTU: 64:8 UP RUNNING PSCAN ISCAN RX bytes:1066 acl:0 sco:0 events:40 errors:0 TX bytes:1605 acl:0 sco:0 commands:38 errors:0 Т.е., вроде как, операционка устройство видит и с ним работает. Однако, hcitool scan (inq тоже) выдает 'scanning' секунд на 5, после чего молча прекращает работу. Какие есть мысли-предложения как его запустить? Выкидывать нельзя, к сожалению. А нужен, по сути, только для цепляния мыши, которая мне очень дорога С wifi побольше описание. Когда только поставил - wifi оживать не хотел никак. Перелопатил поиском кучу сайтов, нашел несколько ссылок на решение проблем. Пробовал многое из предложенного - ничего не заработало. Собственно, что за модуль (железо) стоит: Home-CentOS-6 Загрузки]$ lspci -nn | grep Ralin 44:00.0 Network controller [0280]: Ralink corp. RT3090 Wireless 802.11n 1T/1R PCIe [1814:3090] Первое, что попробовал - установить пакеты из репозитория elrepo - нашел в инете ссылки на это решение. К сожалению, пакеты отказались ставиться: (kmod-rt3090sta-2.4.0.4-1.el5.elrepo.i686 requires kernel(rhel5_arch_i386_mm_ga) ну и т.д, т.п. Хотел было установить соответствующий кернел, но как-то ничего не получилось - туповат, видимо, для этого я еще. Последнее, что пробовал - установка из исходников с сайта производителя (ralinktech). make обрывался с ошибкой 2. Потом ядро обновилось до 6.1. Попробовал опять ставить пакеты из разных источников - никак. А вот из исходников, вдруг, все собралось и wifi даже не только запустился, но и заработал! Потом еще нашел ссылку на модификацию исходников для дебиана - попробовал и ее - и оно тоже работало! Стал тщательнее искать информацию про bluetooth. Ничего внятного не нашел. И тут, блин, CentOS обновляется до 6.2. В результате получаю крах системы при включении модуля wifi+bluetooh (зависон и циклические перезагрузки до отключения этого модуля). По сути, эта ситуация возникает только в том случае, если железка wifi+bluetooth включена и загружается модуль rt3090sta. Если этот модуль не грузить - система работает нормально, но и wifi, естественно, не пашет. Снес этот установленный модуль через make uninstall. Попробовал установить заново пакеты из репозитория elrepo - с предыдущим результатом. Ставил заново дрова из разных скачанных исходников - результат один - все время циклический перезагруз компа при включенной железке wifi. В dmesg из ошибок видно только: ERROR!!! H2M_MAILBOX still hold by MCU. command fail RTMPSetLED::Mode=0,HighByte=0x00,LowByte=0x00 Короче ушатался я с этой шнягой, товарищи. Поможите, кто чем может!
×
×
  • Create New...