Jump to content
Sign in to follow this  
rootree

Загрузка в X

Recommended Posts

Всем привет.

Такая проблема. Установил Madriva. Во время установки всё нормально, а потом, как только начинается загрузка установленной ос тут же происходит глюк с видеокартой (наверно). Вобщем происходит размножение по экрану отображаемой картинки, а загрузка идёт дальше. А потом появляется размноженная мышка.

Как это можно поправить?

Share this post


Link to post
Share on other sites

rootree писал(а) Чтв, 15 Июня 2006 12:18

Всем привет.

Такая проблема. Установил Madriva. Во время установки всё нормально, а потом, как только начинается загрузка установленной ос тут же происходит глюк с видеокартой (наверно). Вобщем происходит размножение по экрану отображаемой картинки, а загрузка идёт дальше. А потом появляется размноженная мышка.

Как это можно поправить?

drakconf

Share this post


Link to post
Share on other sites

rootree писал(а) Чтв, 15 Июня 2006 13:36

Так что получается паменять монитор на другой в drakconf или как-то донастроить

А Вы попробуйте, потом расскажите.

Да, если не заработает...

Какой монитор, какая виядха, какие разрешения и частоты выставлены?

Share this post


Link to post
Share on other sites

Видеокарта встроенная intel 915

Монитор Sony smd-s73

разрешение 800*600*60

в самом начале, загружается lilo - всё отображается нормально. Выбираю загрузку linux, с графикой тоже нормально, но проходит несколько секунд и начинаются глюки.

Share this post


Link to post
Share on other sites

rootree писал(а) Чтв, 15 Июня 2006 14:06

Вопрос между делом, как загрузиться в режим консоли, если linux сразу в X грузит.

<CTRL><ALT><F1> Если уже в x.

В /etc/inittab поменять 5-й уровень на 3-й.

Share this post


Link to post
Share on other sites

rootree писал(а) Чтв, 15 Июня 2006 13:55

Видеокарта встроенная intel 915

Монитор Sony smd-s73

разрешение 800*600*60

в самом начале, загружается lilo - всё отображается нормально. Выбираю загрузку linux, с графикой тоже нормально, но проходит несколько секунд и начинаются глюки.

У всех "несколько секунд" по разному.

Глюки с какого места начинаются?

Share this post


Link to post
Share on other sites

Вот у нас графический загрузчик, выпираем mandriva, нарисован пингвинчик и строки, в которых отображено что загрузилось, и что сейчас грузится, и в один из моментов, при появлении нового элемента загрузки, происходит ужасный глюк.

Share this post


Link to post
Share on other sites

rootree писал(а) Чтв, 15 Июня 2006 17:21

Поменял монитор на другие - не помогло. А если чипсет i810. Это может влиять.

У меня на 810 всё нормально было.

Вы в консоль просто для начала загрузитесь.

Х не грузити. Будет глюк или нет?

Share this post


Link to post
Share on other sites

rootree писал(а) Чтв, 15 Июня 2006 17:49

Глюка ни какого нет. Выводит приглашение пользователя.

Заходите рутом.

Далее startx

Если будут глюки - значит что то не в порядке с монитор-видеокартой. Частота не та возможно.

Попробуйте drakconf ом выставить стандартный монитор на 70 герц.

Память(ОЗУ) протестируйте. Встроенная видюха отгрызает память от ОЗУ.

Share this post


Link to post
Share on other sites

попробуйте смените глубину цвета и/или разрешения, возможно драйвер неправильно с некоторыми форматами работает.

Share this post


Link to post
Share on other sites

Я так понимаю - Sony smd-s73 - это 17" LCD-монитор,

если он нормальный Smile , с ним вообще проблем

не должно быть. Проблема скорее всего в драйвере

для чипсета i915. Когда Mandriva грузится, она

использует framebuffer и режим vesa, поэтому

картинка выглядит нормально. Потом стартует Xorg и

подгружает драйвер intel - и происходит страшный глюк Smile

Попробуйте в файле /etc/X11/xorg.conf в секции

Device поменять

Driver "intel..."

на

Driver "vesa"

Все должно заработать, правда медленно Smile

Share this post


Link to post
Share on other sites

LCD-монитор использует частоту обновления экрана 60Hz. В настройках иксов, скорее всего, прописаны частоты повыше - вот картинка и размножается.

Share this post


Link to post
Share on other sites

vpk писал(а) Птн, 16 Июня 2006 19:08

LCD-монитор использует частоту обновления экрана 60Hz. В настройках иксов, скорее всего, прописаны частоты повыше - вот картинка и размножается.

а почему мой ЛСД-моник, той-же линейки что у rootree, правильно определился? и моник, он ведь может сообщить системе обратно свои параметры, или не так? Smile

Share this post


Link to post
Share on other sites

etybaxe писал(а) Сбт, 17 Июня 2006 00:02

и моник, он ведь может сообщить системе обратно свои параметры, или не так? Smile

Не так. Во-первых, определяются мониторы правильно далеко не всегда, равно как и их параметры, во-вторых, конфиги Иксов не обязательно были сформированы автоматически. По незнанию или неосторожности вполне можно было вписать туда какую-нибудь ерунду.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...