Jump to content
Sign in to follow this  
kasak

монтирование smbfs при запуске

Recommended Posts

требуется подмонтировать smbfs раздел при запуске. пробовал добавить в fstab следующее:

//somehost/share /mnt/smb smbfs ro,password= 0 0

на что получаю:

2702: tree connect failed ERRDOS - ERRnoaccess (Access denied.)

SMB Connection failed

пробую добавить в rc.local следующее:

mount.smbfs //somehost/share /mnt/smb

получаю то же самое.

сам по себе rc.local (если его выполнить уже от рута) монтирует всё нормально...

Share this post


Link to post
Share on other sites

а кто сказал, что когда отрабатывает fstab все необходимое для работы самба подгружено? например сетевой интерфейс поднят к тому времени?

Share this post


Link to post
Share on other sites

Hans R. Steiner писал(а) Sun, 17 September 2006 21:44

в rc.local пропиши последней строчкой комманду монтирования

я же попробовал. написал что то же самое что и с fstab.

Цитата:

пробую добавить в rc.local следующее:

mount.smbfs //somehost/share /mnt/smb

получаю то же самое.

сам по себе rc.local (если его выполнить уже от рута) монтирует всё нормально...

да и вообще как-то отпала нужна в этом "монтировании" скорость по самбе настолько ничтожна что невозможно даже послушать мп3 не скопировав его предварительно. это ужасно.

Share this post


Link to post
Share on other sites

при загрузке системы, rc.local, выполняется с правами рута и уже после всех остальных rc'шников... все должно работать.

в крайнем случае, ради эксперемента, сделай перед монтированием

sleep секунд на 10.

Ну... самба - это вообще не лучшее решение...

Share this post


Link to post
Share on other sites

я не хочу sleep ещё и 10 Sad это же долго! перебьюсь как-нибудь... да и как я уже сказал скорость... сам уже думаю нахрен оно нужно.. но нужно...

Share this post


Link to post
Share on other sites

сделал sleep. не помогло. не хочет и всё. кстати скорость я исправил. на линуксфоруме помогли.. но монтировать никак не хочет:(

Share this post


Link to post
Share on other sites

kasak писал(а) Thu, 21 September 2006 18:44

сделал sleep. не помогло. не хочет и всё. кстати скорость я исправил. на линуксфоруме помогли.. но монтировать никак не хочет:(

И что Вы со скоростью сделали, если не секрет?

Share this post


Link to post
Share on other sites

добавил в smb.conf в [global] строку

socket options = TCP_NODELAY SO_SNDBUF=8192 SO_RCVBUF=8192

за совет спасибо Liksys

только работать это будет если именно монтировать расшарки, если заходить через smb:// скорость будет всё равно низкой

там же предлагают для успешного монтирования задать mount.smbfs бит suid но мне кажется лучше не стоит такими правами бросаться.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...