Jump to content
Sign in to follow this  
Hans R. Steiner

SLED 10.0 SP 1

Recommended Posts

Если ты имеешь в виду обновить "по-маленькому", т.е. скажем 3.2.1 на 3.2.2, то оно будет в апдейтах к дистру.

А вот если "по-большому" Smile то надо подключать дополнительный репозитарий и тянуть из него. Разработчик дистра так делать не советовал (возможна потеря стабильности в целом), хотя сейчас я такого примечания не нашел на сайте.

Подробнее почитать здесь:

http://en.opensuse.org/KDE/Upgrade

http://en.opensuse.org/KDE

Это касается openSUSE. Для SLED можно либо подключить репозитарии от openSUSE 10.1, либо поискать на Novell.com про обновление КДЕ. Насколько я помню, в сети видел статью, где рассказывалось про опыт обновления КДЕ в SLED как раз из репозитариев openSUSE 10.1. В общем, делаешь все на свой страх и риск Smile

P.S. Вики SUSE сильно изменилась, причем, ИМХО, не в лучшую сторону Smile

Share this post


Link to post
Share on other sites

В общем, из-за желания обновить kopete (чтобы заработал выбор кодировки)

приходится обновлять почти 900 пакетов... раз 70 пришлось сказать

"забить на зависимости" и выживет ли суся после этого.......

Обновляю с репозитория OpenSUSE 10.2 :)

Share this post


Link to post
Share on other sites

Обновление прошло пока только на 40%, но результаты уже есть :)

- не открывается меню приложений

- не запускается гном-терминал

gnome-terminal: error while loading shared libraries: libvte.so.4: cannot open shared object file: No such file or directory

- гном-скринсейвер приходится убивать килом из текстовой консоли

- не запускается гном-калькулятор

gnome-calculator: error while loading shared libraries: libdbus-1.so.2: cannot open shared object file: No such file or directory

в общем, система почти умерла :)

Share this post


Link to post
Share on other sites

Во... потихоньку оживает...

Заметил строку

Получение gnome-terminal...Установка /suse/i586/gnome-terminal-2.16.1-26.i586.rpm: "The GNOME 2.x Desktop Terminal" OK

запустил гном-терминал... с руганью, но запустился... есть вероятность,

что система не сдохнет :)

Share this post


Link to post
Share on other sites

Невероятно....

Обновление: 100%

:)

Сохранил лог обновления в файл

cat Обновление | grep OK | wc -l

900

:)

ща яст протупит и в ребут... посмотрим, будем ли мы жить дальше :)

Share this post


Link to post
Share on other sites

Ай-ай, прочел тред и лихорадочно полез проверять, на месте ли еще команда emerge Smile

Share this post


Link to post
Share on other sites

Просто не отписался... домой спешил :)

И так, подводим предворительный итог мероприятия:


  • система загрузилась (что определенно не может не радовать)
  • после старта не поднялись иксы (велечилось подтверждением конфигурации в ясте)
  • гном сдох... пришлось реанимировать... в качестве инструмента для реанимации зверя, был исвользован "ln". лечение: ln -s /usr/lib/libdbus-1.so.3 /usr/lib/libdbus-1.so.2
  • панель гнома, в не обновилась. Пришлось ее отдельно обновлять. Причиной этого явилось то, что в новеловской сборке, имя пакета несколько изменено.
  • очень огорчило то, что не заработал такой апплет панели, как "Главное Меню" - меню "пуск" в новеловской редакции. При этом, это меня огорчило еще больше, чем если бы вся система рухнула так, как я вообще только из-за этой кнопочки гнома оставил.
  • Порадовало то, что KDE и все приложения (... ну... парочка приложений, включая kopete, которые я успел запустить) заработала "на ура" без багов и ненорм.лексики.
  • копете нормально обновился и теперь поддерживает глобальный выбор кодовой страници (собственно говоря, это и было единствен- ной причиной всего этого гемороя)

Остальное пока не успел посмотреть. СуСЯ опять отложена в дальний

ящик (на другой винт) и я вернулся в старую добрую Слакварю :)

Как будет время продолжить эксперемент, обядательно к нему

вернусь... а сейчас, еще много работы... надо еще удостовериться,

что SLES не способен выступать в роли нормального корпоративного

INTERNET-сервера (NTPD, HTTPD, MAIL, DNS)

:)

Share this post


Link to post
Share on other sites

Hans R. Steiner писал(а) Thu, 02 August 2007 09:33

EvilShadow писал(а) Thu, 02 August 2007 00:59

Ай-ай, прочел тред и лихорадочно полез проверять, на месте ли еще команда emerge Smile

А у тебя SLED стоит? Smile

Нет, но все равно страшно Smile

Share this post


Link to post
Share on other sites

ИМХО, игра не стоила свеч. То есть не надо было так жестко обновлять кеды. Тем более, если дело только в копыте было. Можно было, наверное, собрать Kopete отдельно, к примеру. Или поискать бэкпорт Kopete на старые кеды.

Ну это дело вкуса, в любом случае Smile

А меню от Novell, чувствую, тебе понравилось Smile

Share this post


Link to post
Share on other sites

Там трабла была в том, что копыта, пири сборке, требуют более

новую кде и кутэ. Самостоятельная сборка копыт - первое, что

я попытался сделать, когда не смог найти подходящей версии в

портах :)

А меню от Novell, мне действительно очень понравилось :)))

Попробуй в слаку перетащить, если смогу заставить его вновь

работать :)

Share this post


Link to post
Share on other sites

И так, последние новости:

После предыдущего эксперемента, мне уже было лень лечить дистрибутив,

но новершать свои опыты над ним, пока еще не хочется. Я поставил SLED

заново и продолжил эксперементы.

Как и прежде, первичная задача - заставить работать новые копыта

(kopete) так, как в старых версиях, нет возможности выбора глобальной

кодовой страници (у меня очень много контактов и мне лень кликать на

каждый из них и устанавливать им windows-1251)

Как и раньше, установка новых копыт без установки новой QT не возможна.

Приходится ставить QT. В прошлый раз, при обновлении QT из репозитариев,

SLED мутировал в OpenSUSE, а побочным эффектом был отказ от работы

Novell'овских добавок и прибомбасов... но в целом, к моему удивлению,

система осталась вполне работоспособной.

Сейчас я решил пойти несколько иным путем. Я решил не обновлять пакеты

из репозитариев, а компилить их самостоятельно (ужас! их много!).

с qt-4.4.0 совладать не удалось... ошибка при компилляции... разбираться

несколько ломает. сейчас пытаюсь поставить qt-3.3.8. Посмотрим, каким

местом судьба повернется.

Share this post


Link to post
Share on other sites

Нда... поставил я новый QT... результат - половина софта сдохла :(

Вернул старый QT обратно... фиг с ним...

А Kopete я все-таки заставил работать... оказывается, эта ХХХ одинаково

ругается на несоответствие версии QT и на отсутствие библиотек qt-mt,

которые идут с kdelib-devel (кажется)... в общем, трабла решилась

установкой пары devel-пакетов :)

Share this post


Link to post
Share on other sites

Hans R. Steiner писал(а) Thu, 16 August 2007 15:07

в общем, трабла решилась

установкой пары devel-пакетов Smile

То есть, достаточно было на SLED накатить два пакета от нее же, и все заработало?

Жжоте Smile

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...