Jump to content
Sign in to follow this  
Lisav

Настройка WiFi Broadcom BCM4310 USB Controller

Recommended Posts

Доброе время суток, Уважаемые.

В недавнем времени приобрел себе Vostro Dell 500. Зарядил на него Gentoo.

Wifi на этой модели из сабжа. Собрал ndiswrapper, подсунал виндовые дрова, переобулся и увидел следующее:

lsmod | grep ndis
 ndiswrapper 143516 0
 

dmesg
 ndiswrapper version 1.53 loaded (smp=yes, preempt=no)
 ndiswrapper: driver bcmwl5 (Broadcom,09/20/2007, 4.170.25.12) loaded
 ndiswrapper 0000:0b:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
 ndiswrapper 0000:0b:00.0: setting latency timer to 64
 ndiswrapper: using IRQ 17
 wlan0: ethernet device 00:16:44:c3:f6:5f using NDIS driver: bcmwl5, version: 0x4aa190c, NDIS version: 0x501, vendor: 'NDIS Network Adapter', 14E4:4315.5.conf
 wlan0: encryption modes supported: WEP; TKIP with WPA, WPA2, WPA2PSK; AES/CCMP with WPA, WPA2, WPA2PSK
 usbcore: registered new interface driver ndiswrapper
 ndiswrapper: changing interface name from 'wlan0' to 'wlan1'
 udev: renamed network interface wlan0 to wlan1

 iwconfig
 lo no wireless extensions.
 
 eth0 no wireless extensions.
 
 wlan1 IEEE 802.11g ESSID:off/any
 Mode:Managed Frequency:2.462 GHz Access Point: Not-Associated
 Bit Rate:54 Mb/s Tx-Power:32 dBm
 RTS thr:2347 B Fragment thr:2346 B
 Encryption key:off
 Power Management:off
 Link Quality:0 Signal level:0 Noise level:0
 Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
 Tx excessive retries:0 Invalid misc:0 Missed beacon:0

iwlist wlan1 scan отлично показывает все имеющиеся в округе сети

т.е. на лицо работающая карточка, но вот одна проблема:

при попытке подключиться к любой сети через KWifiManager в окне санирования кнопка "перейти в сеть" неактивна.

Пытался настроить подключение через iwconfig, долго курил но так и не понял почему у меня не изменяется ни один параметр в настройках карты, а при попытке указать ключ для сети вылетает:

 iwconfig wlan1 key 12345
 Error for wireless request "Set Encode" (8B2A) :
 SET failed on device wlan1 ; Invalid argument.

Знаю что в убунте карта работает отлично с этими же дровами (gentoo стаивил из ubuntu).

Подскажите что я мог пропустить? подразумеваю что что-то недособрано типа wpa_suplicant или чего подобного для работы wifi (опыта работы с Wifi в Linux не имею)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...