Jump to content
Sign in to follow this  
tumanovalex

Archlinux - пропали русские буквы после установки wicd

Recommended Posts

После включения в демоны dbus и wicd для нормальной работы wicd в консольном режиме сбился шрифт, появились вместо русских букв маленькие квадратики. До этого все было нормально, в текстовом редакторе nano интерфейс был русскими буквами. Причем этот эффект наблюдал на двух компьютерах, на которых в конце концов удалось установить wicd. Руссификация в файле rc.conf сделана по Ctrl+Shift, как описано в руководстве для начинающих. Подскажите, пожалуйста, как с этим бороться.

Share this post


Link to post
Share on other sites

wicd тут не виноват. Проблема в модуле видео, который с очередным обновлением стал "убивать" шрифт.

Решение проблемы элементарное:

Команды showconsolefont и setfont cyr-sun16 помогут вручную настроить консольный шрифт и с нормальным шрифтом применить рекомендуемое изменение.

В mkinitcpio.conf нужно добавить загрузку модуля видео, что бы тот загружался до инициализации rc.conf:

# MODULES# The following modules are loaded before any boot hooks are# run.  Advanced users may wish to specify all system modules# in this array.  For instance:#     MODULES="piix ide_disk reiserfs"MODULES="drm i915"

Естественно, модуль нужно указать соответствующий железу.

Затем необходимо пересобрать загрузочный образ командой mkinitcpio -p linux.

Share this post


Link to post
Share on other sites

lsmod показывает какие модули ядра загружены.

Для правильной настройки нужно знать модель своей видеокарты:

если intel, то скорее всего это будет i915, как в моем примере.

если nvidia, то тут наверняка будет что-то вроде nouveau.

В принципе lspci | grep -i vga поможет сориентироваться.

Ну и главная кладезь знаний - wiki тоже поможет найти подсказку.

p.s. Перед сборкой нового образа рекомендуется сделать резервную копию .img файлов в /boot что бы не лишиться системы, если загрузка модуля по какой-то причине не удастся. И внимательно читать все сообщения при работе команды mkinitcpio

Share this post


Link to post
Share on other sites

Сейчас изучал багтрекер. Нашлась там и наша проблема (сам искал решение всю прошлую неделю Smile ) - https://bugs.archlinux.org/task/29781 - разработчики на днях уже внесли исправления в git, так что с одним из ближайших исправлений стоит ждать, что проблема отпадет сама собой.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...