Перейти к содержимому
tumanovalex

Archlinux - отключение тачпада при подлючении USB мыши

Рекомендуемые сообщения

Для достижения этого, просто добавьте следующее правило udev:

ACTION=="add", SUBSYSTEM=="input", ID_CLASS="mouse", RUN+="/usr/bin/synclient TouchpadOff=1"ACTION=="remove", SUBSYSTEM=="input", ID_CLASS="mouse", RUN+="/usr/bin/synclient TouchpadOff=0"

Поместите это в /etc/udev/rules.d/01-touchpad.rules, убедитесь что опция SHMConfig включена.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Файла 01-touchpad.rules не обнаружил, вообще директория оказалась пустая. Создал этот файл, внес туда указанные строки. А где нужно включить опцию SHMConfig?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

tumanovalex писал(а) Сбт, 16 Июнь 2012 15:05

Файла 01-touchpad.rules не обнаружил, вообще директория оказалась пустая. Создал этот файл, внес туда указанные строки. А где нужно включить опцию SHMConfig?

Всё правильно, файла 01-touchpad.rules изначально нет. Его нужно создать.

Затем включить опцию SHMConfig в конфиге /etc/X11/xorg.conf.d/10-synaptics.conf

Section "InputClass"     Identifier "touchpad catchall"     Driver "synaptics"     MatchIsTouchpad "on"     MatchDevicePath "/dev/input/event*"           Option "TapButton1" "1"           Option "TapButton2" "2"           Option "TapButton3" "3"           Option "SHMConfig"  "true" # <<== SHMConfig enabledEndSection

Если что, в wiki ArchLinux есть и другие примеры дополнительных настроек для тачпада - включение скроллинга, обработка нажатий в углах для эмуляции кнопок и т.п.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас

×