Jump to content

askaev

Members
  • Posts

    9
  • Joined

  • Last visited

    Never

Everything posted by askaev

  1. - меня тож интересует ента проблема. В сервисах висит запущеной, вроде даж настроена через панель (не помню через какую и где, но там я вродь всё чо нужно попрописывал) , однако на lan:// ругается, что не установлена и не настроена.... Юзаю Мандрэйк 10.0 Коммунити. на Byte писал(а) Втр, 25 Апреля 2006 11:51 $ps ax | grep "lisa" выдаёт 3007 ? S 0:00 /usr/bin/lisa -c /etc/lisarc 4378 pts0 S 0:00 grep lisa
  2. Итак. Имеем сервер на Вин2003 с АД, ДНС и ДХЦП. Сервер поднят до уровня пред-2000, дабы клиенты вин9х,МЕ,ХР и выше могли спокойно входить в домен. В АД прописаны юзеры. И на Вин ХР вход в домен выглядит стандартно: 1) после загрузки оси вываливается окно: Нажмите Ктрл-Алт-Дел 2) вбиваем логин и пароль (проверяем что вход будет осуществлён в домен, а не на локальную машину) 3) в случае удачной авторизации (логин/пароль совпали с вбитыми в АД) входим в домен и попадаем на рабочий стол данного юзера. Т.е в данном случае, мы на данной машине с ХР не прописывали юзерей вообще - они бирутся из АД, и все их параметры сохраняются уже на локальной машине (хотя можно и на серваке хранить,но пока это не требуется). Вот тоже самое необходимо проделать с машиной с линуксом. На данный момент установлен Мандрэйк 10.0 коммунити. Вбит днс сервак локалки, имя машины включает и имя домена локалки (т.е km.rintek.local). IP машина по ДХСЦ получает без проблем. Пинги по ip на большинство машин локалки проходят (на оставшиеся машины пинги не проходят и с виндовс-машин,..почему-то...но это не суть.). Пинг по ip на сервак также проходит. В krb5.conf и smb.conf были проделаны действия из http://volgograd.lug.ru/wiki/GrableVodstvo/articles/SquidNtl m?v=4sl за исключением установки и настройки squid (в данном случае он не нужен). перезапускаем самбу и винбинд И так, выполнив всё и получив на ввод # net ads join -S 192.168.0.151 -U maxim запрос пароля, вводим его,..и получаем ожидаемую строку Joined 'km37' to realm 'RINTEK.LOCAL' Ага, отлично... Далее вводим # wbinfo -p и получаем ожидаемые Ping to winbindd succeeded on fd 4 Замечательно... далее добавил в lmhosts ИП и хостнэйм сервака с АД. Водим # wbinfo -u и поолучаем список юзерей домена в таком виде (кусочек): DIREKTOR$katyaKADRY$lenamashaSERVER$HOST/km37 по # wbinfo -g показало группы домена просто так ребутимся ..просто так получаем список юзерей кликаем на любой,вводим пароль,и обламуемся.. - типа мол вроде как пароль не верный. Чего делать? Куда рыть? Конфиги: smb.conf: workgroup = RINTEK server string = printcap name = cups load printers = yes printing = cups printer admin = @adm log file = /var/log/samba/log.%m max log size = 50 realm = rintek.local map to guest = bad user security = ads password server = server2 encrypt passwords = yes smb passwd file = /etc/samba/smbpasswd winbind uid = 10000-20000 winbind gid = 10000-20000 winbind separator = + winbind use default domain = yes socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192 dns proxy = no use sendfile = yes конфиг кербероса не привожу, т.к. имхо не в нём дело - иначе б и юзерей-то не выводило...при старте,да и в консоле... Логи: Кусок лога, при перезагрузке ПК, /var/log/samba/log.winbindd [2006/04/24 12:44:49, 1] nsswitch/winbindd.c:main(843) winbindd version 3.0.2a started. Copyright The Samba Team 2000-2004 [2006/04/24 12:44:54, 1] nsswitch/winbindd_util.c:add_trusted_domain(166) Added domain RINTEK rintek.local S-1-5-21-1547364447-1060086519-4252789474 [2006/04/24 12:44:54, 1] libsmb/clikrb5.c:ads_krb5_mk_req(269)krb5_cc_get_principal failed (No credentials cache found) Мне вот не нравятся последние 2 строчки...Чего-н-то тут не то... Кусок лога, при перезагрузке ПК, /var/log/samba/log.smbd [2006/04/24 12:44:53, 0] smbd/server.c:main(747) smbd version 3.0.2a started. Copyright Andrew Tridgell and the Samba Team 1992-2004 [2006/04/24 12:44:53, 0] printing/print_cups.c:cups_printer_fn(108) Unable to connect to CUPS server localhost - Connection refused Ну тут вроде ничего интересного...Имхо... Кусок лога, при перезагрузке ПК, /var/log/samba/log.nmbd [2006/04/24 12:44:53, 0] nmbd/nmbd.c:main(664) Netbios nameserver version 3.0.2a started. Copyright Andrew Tridgell and the Samba Team 1994-2004 [2006/04/24 12:44:53, 0] libsmb/namequery.c:getlmhostsent(588) getlmhostsent: Ill formed hosts line [127.0.0.1localhost] Тут вроде тоже ничего интересного нет.... Жду-с подсказок как решить проблему...
  3. жаль...Выходит на часть кампов линух поставить неудасца ... ээ..а в каком-либо другом дистре есть дрова на эту сетевуху? (SuSE, ALT, ASP,...)
  4. Aceler писал(а) ср, 01 марта 2006 19:45 У меня Windows на настольном компьютере уже 5 лет как отсутствует, но я же не кричу об этом на каждом углу... Да ладно уж Не мешайте человеку радоваться Я вон, в соседней ветке, мучаюсь с установкой дров в Mandrake 10.0 Community для сетевушки ULi 526x от Tulip. Кстати, в Mandriva 2006 есть встроенные дрова для сей сетевухи? Поглядите, плз.
  5. Просто "make" - даёт тотже эффект - Нет правила для сборки цели `drivers/net/tulip/uli526x.c'. И хоть ты тресни.. Makefile лежит,естественно... Что делать?
  6. дык что делать то? Кто подскажет?
  7. на modeprobe tulip ничего не пишет на ifconfig eth0 выдало: eth0: error fetching interface information: Device not found тобишь, устройство не обнаружено... И? ----------------- Дополнено: спасибо за подсказку по установке kernel-sources Всё нужное сделал (uli526x.c положил в /usr/src/linux-2.6.3-4mdk/drivers/net/tulip/ . Тамже дополнил по инструкции файлы Makefile и Kconfig) Далее перешёл в /usr/src/linux-2.6.3-4mdk/ и там ввёл make xconfig. После чего получил ошибку, что мол QT не стоит. Поставил. Снова make xconfig и новая ошибка: make[1]: `scripts/fixdep' не требует обновления. HOSTCXX scripts/kconfig/qconf.o /bin/sh: line 1: g++: command not found make[1]: *** [scripts/kconfig/qconf.o] ошибка 127 make: *** [xconfig] ошибка 2 Вот...Еще какой-то пакет не стоит? Или что?? --------- Дполонение: доставил gcc-c+ продолжаю дальше мучаца..однако продвинулся еще немного дальше... --------- Дполонение: в общем дошёл-таки до пункта make xconfig. Запускается он. сделал там,что требовалось по инструкции. Сохранил (ткнул на картинку с дискеткой) и вышел. Далее ввёл make modules. И после неск. минул какого-то расколбаса выдало: make[3]: *** Нет правила для сборки цели `drivers/net/tulip/uli526x.c', требуемой для `drivers/net/tulip/uli526x.o'. Останов. make[2]: *** [drivers/net/tulip] Ошибка 2 make[1]: *** [drivers/net] Ошибка 2 make: *** [drivers] Ошибка 2 Что делать? (с)
  8. в списке сетевух ни в мандрэйке 9,1 ни в 10,0 изначально нет пункта tulip. Иначеб,имхо,сетевушка б сама установилась. На ввод make menuconfig таже проблема. В /usr/src/linux-2.6.x/drivers/net/tulip/ лкжат Makefile, Kconfig, его копия Kconfig.in и сам драйвер uli526x.c. В соответсвии с инструкцией, перехожу в /usr/src/linux-2.6.x/ и ввожу make xconfig или make menuconfig и получаю "make: *** Нет правила для сборки цели `xconfig'. Останов." Вот Makefile c CD: # # Makefile for the Linux "Tulip" family network device drivers. # obj-$(CONFIG_PCMCIA_XIRTULIP) += xircom_tulip_cb.o obj-$(CONFIG_PCMCIA_XIRCOM) += xircom_cb.o obj-$(CONFIG_DM9102) += dmfe.o obj-$(CONFIG_WINBOND_840) += winbond-840.o obj-$(CONFIG_DE2104X) += de2104x.o obj-$(CONFIG_TULIP) += tulip.o obj-$(CONFIG_DE4X5) += de4x5.o obj-$(CONFIG_ULI526X) += uli526x.o # Declare multi-part drivers. tulip-objs := eeprom.o interrupt.o media.o \ timer.o tulip_core.o \ 21142.o pnic.o pnic2.o Вот отрывок Kconfig c CD, касающийся моей сетевушки (ULi526x): # # Tulip family network device configuration # menu "Tulip family network device support" depends on NET_ETHERNET && (PCI || EISA || CARDBUS) config NET_TULIP bool "\"Tulip\" family network device support" help This selects the "Tulip" family of EISA/PCI network cards. config TULIP tristate "DECchip Tulip (dc2114x) PCI support" depends on NET_TULIP && PCI select CRC32 ---help--- This driver is developed for the SMC EtherPower series Ethernet cards and also works with cards based on the DECchip 21140 (Tulip series) chips. Some LinkSys PCI cards are of this type. (If your card is NOT SMC EtherPower 10/100 PCI (smc9332dst), you can also try the driver for "Generic DECchip" cards, above. However, most people with a network card of this type will say Y here.) Do read the Ethernet-HOWTO, available from <http://www.tldp.org/docs.html#howto>. To compile this driver as a module, choose M here and read <file:Documentation/networking/net-modules.txt>. The module will be called tulip. config ULI526X tristate "ULi M526x controller support" depends on NET_TULIP && PCI select CRC32 ---help--- This driver is for ULi M5261/M5263 10/100M Ethernet Controller (<http://www.uli.com.tw/>). To compile this driver as a module, choose M here. endmenu Вот кусок инструкции с CD: 1.Kconfig.in add the following lines to Kconfig.in file.(refer to the Kconfig.in file we provide to you) config ULI526X tristate "ULi M526x controller support" depends on NET_TULIP && PCI select CRC32 ---help--- This driver is for ULi M5261/M5263 10/100M Ethernet Controller (<http://www.uli.com.tw/>). To compile this driver as a module, choose M here. 2.Makefile add the following lines to Makefile.(refer to the Makefile we provide to you) obj-$(CONFIG_ULI526X) += uli526x.o ------------------------------------ Install as a kernel module ------------------------------------ Step 1: Change directory to /usr/src/linux-2.6.x Use the command "make menuconfig" or "make xconfig", and make sure "ULi M526x controller support" is set as module. Example: Select "Device Drivers" Select "Networking support" Select "Ethernet (10 or 100Mbit)" Select "Tulip family network device support" Unselect "DECchip Tulip (dc2114x) PCI support" Select "ULi M526x controller support" as "m" Step 2: Select "Loadable module support", and unselect "Set version information on all module symbols" Before exit, save your configration. Step 3: make modules make modules_install Step 4: rmmod tulip modprobe uli526x Then, you can bind any protocol into M5263 driver and use it. Команда modprobe tulip ничего не дала, .. вообще.. Пытаюсь настроить дрова на сетевушку: 1)Выбираю соединение - "Соединение по локальной сети" 2)кнопка [ Далее ] 3)Выбираю в списке драйверов всё-таки откуда-то появившийся tulip 4)кнопка [ Далее ] 5)Найдены tulip интерфейсы. Есть ли другие? Выбираю [x] Нет 6)кнопка [ Далее ] 7)Сетевой интерфейс для настройки: Сетевое устройство [x] самостоятельный выбор 8)кнопка [ Далее ] И после этого почему-то происходит возврат к п.3 - выбор драйвера. Если нужно, могу подклеить сюда все файлы (Makefile, Kconfig, uli526x.c, инструкцию) - мало ли.. может поможет вам что-нить мне подсказать.
  9. не могу уст.дрова на ULi LAN. Материнка новая - сентября 2005. В инструкции на CD сказано, что надо взять прилагаемые файлы uli526x.c, Makefile, Kconfig.in и положить их в созданную папку /usr/src/linux-2.6.x/drivers/net/tulip/. При этом вместо указанного в иструкции Kconfig.in лежит файл с названием Kconfig. - т.е без ".in". На всякий , я в /usr/src/linux-2.6.x/drivers/net/tulip/ ложу две копии файла: и Kconfig и Kconfig.in. Далее сказано, что необходимо переместиться в папку /usr/src/linux-2.6.x/ и набрать make xconfig. При этом вылетает вот что: "make: *** Нет правила для сборки цели `xconfig'. Останов." Что делать? Всё проделывается естественно в консоли под рутом. Дистриб: Мандрэйк 10.0 с КДЕ 3.2. Сам Линух-то нашёл сетевуху, но вот дров естественно не поставил. Однако в списке дров появился пункт tulip, но при выборе его, происходит возврат к списку дров.
×
×
  • Create New...