Jump to content

counsellor

Members
  • Content Count

    33
  • Joined

  • Last visited

    Never

About counsellor

  • Rank
    Advanced Member

Profile Information

  • Location
    Moscow
  • Interests
    Linux
  1. А нет у меня такой опции в Бивисе. Я еще феньку заметил. Если комп выключить минут на 20-30, я имею ввиду полностью питание отрубить. То после загрузки с холодной машины, старт eth0 не происходит. Делаю ребут все становится нормально. Дома, только не удобно. Приходится вынимать кабель из блока питания.
  2. Цитата:а еще есть такая штука как логи.. чтобы не гадать В каком месте логи смотреть, наведите на мысль плиз
  3. Да нет. В общем то меня и через YaST настройки устраивают, вот только я не врубаюсь как правильно папку расшарить. У меня сетевая папка находится на linux машине. С виндовых компов она видна, но не открывается, а требует пароль. Я ввожу пароль пользователя, которого прописал в linux, а меня в папку все равно не пускает, требуя опять ввести пароль. Вот я и хочу понять, почему не принимается этот пароль. Предположений два: 1. Винда шифрует пароль, а никс либо его неправильно расшифровывает, либо вообще не пытается расшифровать. 2. Не хватает прав для этой папки под этим паролем. (хотя я пароль рута тоже пробовал. Комп с никсом стоит в офисе, папку надо расшарить для всех пользователей так, что бы они не вводили пароль к ней каждый раз.
  4. А можно так: valid users=All или valid users=guest ?
  5. Проблема локализовалась. Наблюдения следующие. При "мягком" выключении компа, когда 5вольт на матери остается, и года комп можно завести кликнув на мышь, все нормально, но до первой загрузки Винды. Если после Винды грузить linux, eth0 может пинговать только сам себя и lo Необходимо полное выключение, т.е. снятие 5вольт с материнки. Настройки в YaST правильные (стартовать при загрузке), т.к. после полного выключения все работает. На роутере, куда воткнут сетевой кабель после Винды светодиод гаснет и при загрузке linux не загорается вновь. Только если вынуть сетьевой (220V) кабель из блока питания (выключателя на БП нет). После обратного включения и первой загрузке linux все восстанавливается. Не пойму то ли винда вырубает сетевую карту и никс ее врубить не может, то ли в никсе какие то проблемы. Ниже привожу траблы: ip link show 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen 1000 link/ether 00:1a:4d:91:30:b8 brd ff:ff:ff:ff:ff:ff arp -n Address HWtype HWaddress Flags Mask Iface 192.168.0.1 (incomplete) eth0 А это кусок лога при загрузке, видно как пытается начать работу eth0 но потом падает (последняя строчка) Nov 28 18:44:47 Counellor ifup: eth0 device: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01) Nov 28 18:44:47 Counellor ifup: eth0 Nov 28 18:44:47 Counellor ifup: IP address: 192.168.0.5/24 Nov 28 18:44:47 Counellor ifup: Nov 28 18:44:47 Counellor SuSEfirewall2: /var/lock/SuSEfirewall2.booting exists which means system boot in progress, exit. Nov 28 18:44:47 Counellor kernel: klogd 1.4.1, log source = /proc/kmsg started. Nov 28 18:44:47 Counellor kernel: JBD: barrier-based sync failed on dm-1 - disabling barriers Nov 28 18:44:47 Counellor kernel: IA-32 Microcode Update Driver: v1.14a <tigran@aivazian.fsnet.co.uk> Nov 28 18:44:47 Counellor kernel: powernow: This module only works with AMD K7 CPUs Nov 28 18:44:47 Counellor kernel: ip6_tables: © 2000-2006 Netfilter Core Team Nov 28 18:44:47 Counellor kernel: ip_tables: © 2000-2006 Netfilter Core Team Nov 28 18:44:47 Counellor kernel: Netfilter messages via NETLINK v0.30. Nov 28 18:44:47 Counellor kernel: nf_conntrack version 0.5.0 (8192 buckets, 65536 max) Nov 28 18:44:47 Counellor kernel: r8169: eth0: link down
  6. SuSe 10.3 Совсем запутался в настройках. На работе вроде настроилось, только как так и не понял. Дома не хочет хоть ап стену убейся. ip link show кажет <NO-CARRIER,BROADCAST,MULTICAST,UP> ..... eth0 пигуется по своему адресу, не пингуются компьютеры в сети. В ifconfig тоже BROADCAST MULTICAST, a вроде должно быть RUNNING. В route появилось link-local с маской 255.255.0.0 - что это такое? Разница в том что на работе стоит прокси, а дома DLINK router, провайдер через него подключен, в винде все работает ок. ifconfig eth0 192.168.0.5 netmask 255.255.255.0 route add -net 192.168.0.0 netmask 255.255.255.0 eth0 Что делаю не правильно не пойму
  7. # smb.conf is the main Samba configuration file. You find a full commented # version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the # samba-doc package is installed. # Date: 2007-09-22 [global] workgroup = Heuft Eurasia printing = cups printcap name = cups cups options = raw map to guest = Bad User include = /etc/samba/dhcp.conf logon path = \\%L\profiles\.msprofile logon home = \\%L\%U\.9xprofile logon drive = P: usershare max shares = 100 [homes] comment = Home Directories valid users = %S, %D%w%S browseable = No read only = No inherit acls = Yes [profiles] comment = Network Profiles Service path = %H read only = No store dos attributes = Yes create mask = 0600 directory mask = 0700 [users] comment = All users path = /home read only = No inherit acls = Yes veto files = /aquota.user/groups/shares/ [groups] comment = All groups path = /home/groups read only = No inherit acls = Yes [printers] comment = All Printers path = /var/tmp printable = Yes create mask = 0600 browseable = No [print$] comment = Printer Drivers path = /var/lib/samba/drivers write list = @ntadmin root force group = ntadmin create mask = 0664 directory mask = 0775 [catalog] comment = Общий каталог inherit acls = yes path = /Users/ read only = no guest ok = yes force user = counsellor force group = users case sensitive = no strict locking = no msdfs proxy = no valid users = counsellor write list = counsellor
  8. SuSe 10.3 + Samba Установил и настроил. Создал папку, дал ей имя для сети. Винда папку видит, но требует к ней логин и пароль. Ввожу логин и пароль пользователя который настроен на linux компе, а меня не пускает в эту папку и заново требует пароль с логином. Дабы не пойти по ложному пути объясните: при вводе логина и пароля с виндового компа может происходить перекодировка либо шифрование? Может поэтому не пускает в эту папку?
  9. У меня сейчас так: SuSeSer:/home/counsellor # route Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface 192.168.0.0 * 255.255.255.0 U 0 0 0 eth0 link-local * 255.255.0.0 U 0 0 0 eth0 loopback * 255.0.0.0 U 0 0 0 lo Default gateway, как я понимаю не прописан. А инет пашет, почему? Ведь если Цитата:софт работает согласно таблице маршрутизации , значит я не смогу дальше своей 192.168.0.0 сети выйти? Или браузер берет параметры прокси из своих настроек и ему плевать на таблицу маршрутизации. А вот команда traceroute действительно не работает, правда целевой адрес выдает в виде [ipadres] name. Откуда она его узнает?
  10. Byte писал(а) Tue, 27 November 2007 11:59софт работает согласно таблице маршрутизации А если указан один gateway для eth0 и eth1, они же должны обе ходить через этот gateway, так? Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface 192.168.0.0 * 255.255.255.0 U 0 0 0 eth0 192.168.0.0 * 255.255.255.0 U 0 0 0 eth1 link-local * 255.255.0.0 U 0 0 0 eth0 loopback * 255.0.0.0 U 0 0 0 lo
  11. Если всё так, как написано - то работать и не должно. 2 интерфейса в одну сеть?
  12. route Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface 192.168.0.0 * 255.255.255.0 U 0 0 0 eth0 192.168.0.0 * 255.255.255.0 U 0 0 0 eth1 loopback * 255.0.0.0 U 0 0 0 lo А какой должен быть default, если локальная сеть 192.168.0.0 и надо коннектится только с внутренней сетью и выход через прокси 192.168.0.55? А если наружу через eth1 используя provider ip provider gate provider netmask? Если можно на примерах.
  13. SuSe 10.3 eth0 - сетевуха на материнке. Почему то отказывается работать. Стоящая в PCI слоте eth1 U.S.Robotix работает при переключении в нее Ethernet кабеля. eth0 пингуется по собственному адресу, но невозможно пропинговать внешние рессурсы сети (через eth1 все нормально). В настройках сетевых плат напротив названия пишет, что нет подключения (тогда, как напротив eth1 такой надписи нет). Настройки для обоих eth идентичные за исключением ip адреса eth0 192.168.0.51 eth1 192.168.0.52 По ip link show следующее: 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen 1000 link/ether 00:c0:49:b4:bb:58 brd ff:ff:ff:ff:ff:ff 3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast qlen 1000 link/ether 00:0f:ea:66:d2:87 brd ff:ff:ff:ff:ff:ff Хотя кабель один и тот же, просто перетыкаю из гнезда в гнездо. Может это как то с дровами связано? А может с маршрутизацией, хотя route Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface 192.168.0.0 * 255.255.255.0 U 0 0 0 eth0 loopback * 255.0.0.0 U 0 0 0 lo это если ifconfig eth1 192.168.0.52 down Помогите, пожалуйста, разобраться с проблемой
  14. Подключено на eth0 SuSeSer:/home/counsellor # ip link show 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen 1000 link/ether 00:c0:49:b4:bb:58 brd ff:ff:ff:ff:ff:ff 3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast qlen 1000 link/ether 00:0f:ea:66:d2:87 brd ff:ff:ff:ff:ff:ff Просто переткнул сетевой кабель на eth1 и немного подождал SuSeSer:/home/counsellor # ip link show 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen 1000 link/ether 00:c0:49:b4:bb:58 brd ff:ff:ff:ff:ff:ff 3: eth1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen 1000 link/ether 00:0f:ea:66:d2:87 brd ff:ff:ff:ff:ff:ff Ничего не делал, только подождал eth0 стал <BROADCAST, а eth1 <NO-CARRIER SuSeSer:/home/counsellor # ip link show 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast qlen 1000 link/ether 00:c0:49:b4:bb:58 brd ff:ff:ff:ff:ff:ff 3: eth1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen 1000 link/ether 00:0f:ea:66:d2:87 brd ff:ff:ff:ff:ff:ff Почему так?
×
×
  • Create New...