Jump to content

Не работает экран лэптопа


renton88
 Share

Recommended Posts

Всем привет! Очень нужна помощь, не работает основной монитор ноута.
 
Есть ноут HP Pavilion Laptop 15-eg0083ur с ubuntu 21.04, к нему подключен монитор по hdmi. Сейчас работает только внешний. built-in-display просто черный, хотя в настройках есть, система его видит. У него с самого начала наблюдаются траблы с экраном.
 
Сначала на него был поставлен mint с кернелом 5.8.0.55 (если не ошибаюсь), работали оба экрана, всё было ок. При попытке обновить кернел в пределах 5.8, либо 5.11 - основной монитор переставал работать еще при загрузке.
Через какое-то время решил попробовать Clear Linux, но выяснилось, что при загрузке инсталлятора работает тоже только внешний. Такое же поведение было, когда пытался поставить pop_os. Решил попробовать старую добрую убунту, и всё ок, в инсталляторе работают оба экрана, всё прекрасно. Но! После установки основной снова отвалился, и не подает признаков жизни, как это было до этого со многими дистрибутивами.
 
Вот inxi:
 

System:
  Kernel: 5.11.0-37-generic x86_64 bits: 64 compiler: gcc v: 10.2.1  
  Desktop: GNOME 3.38.4 Distro: Ubuntu 21.04 (Hirsute Hippo)  
Machine:
  Type: Laptop System: HP product: HP Pavilion Laptop 15-eg0xxx  
  v: Type1ProductConfigId serial: <filter>  
  Mobo: HP model: 87CB v: 34.27 serial: <filter> UEFI: Insyde v: F.11  
  date: 01/15/2021  
Battery:
  ID-1: BAT0 charge: 41.3 Wh condition: 41.3/41.3 Wh (100%)  
  model: HP Primary status: Full  
CPU:
  Info: Quad Core model: 11th Gen Intel Core i5-1135G7 bits: 64 type: MT MCP  
  arch: Tiger Lake rev: 1 L2 cache: 8 MiB  
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx  
  bogomips: 38707  
  Speed: 1200 MHz min/max: 400/4200 MHz Core speeds (MHz): 1: 1200 2: 1200  
  3: 1200 4: 1200 5: 1184 6: 1200 7: 1200 8: 1202  
Graphics:
  Device-1: Intel TigerLake GT2 [Iris Xe Graphics] vendor: Hewlett-Packard  
  driver: i915 v: kernel bus ID: 0000:00:02.0  
  Device-2: Luxvisions Innotech Limited HP Wide Vision HD Camera type: USB  
  driver: uvcvideo bus ID: 3-3:3  
  Display: wayland server: X.Org 1.21.1.1 compositor: gnome-shell driver:  
  loaded: i915 note: n/a (using device driver) resolution: 1920x1080~60Hz  
  OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 21.0.3  
  direct render: Yes  
Audio:
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Hewlett-Packard  
  driver: sof-audio-pci bus ID: 0000:00:1f.3  
  Sound Server: ALSA v: k5.11.0-37-generic  
Network:
  Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel port: 3000  
  bus ID: 0000:00:14.3  
  IF: wlp0s20f3 state: up mac: <filter>  
Bluetooth:
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB  
  driver: btusb v: 0.8 bus ID: 3-10:5  
  Report: ID: hci0 state: up running bt-v: 3.0 lmp-v: 5.2 address: <filter>  
RAID:
  Hardware-1: Intel Volume Management Device NVMe RAID Controller  
  driver: vmd v: 0.6 bus ID: 0000:00:0e.0  
Drives:
  Local Storage: total: 953.87 GiB used: 52.41 GiB (5.5%)  
  ID-1: /dev/nvme0n1 vendor: Western Digital  
  model: PC SN530 SDBPNPZ-1T00-1006 size: 953.87 GiB temp: 38.9 C  
Partition:
  ID-1: / size: 238.81 GiB used: 8.98 GiB (3.8%) fs: ext4  
  dev: /dev/nvme0n1p2  
  ID-2: /boot/efi size: 511 MiB used: 45.4 MiB (8.9%) fs: vfat  
  dev: /dev/nvme0n1p1  
Swap:
  ID-1: swap-1 type: file size: 2 GiB used: 0 KiB (0.0%) file: /swapfile  
Sensors:
  System Temperatures: cpu: 47.0 C mobo: N/A  
  Fan Speeds (RPM): N/A  
Info:
  Processes: 271 Uptime: 36m Memory: 15.4 GiB used: 2.55 GiB (16.5%)  
  Init: systemd runlevel: 5 Compilers: gcc: N/A Packages: 1712 Shell: Bash  
  v: 5.1.4 inxi: 3.3.01  
 
 
Если кто знает, в какую сторону рыть - подскажите! Я уже задолбался, ничего не могу найти действенного по теме.
 
Заранее спасибо

Link to comment
Share on other sites

Смотрите проблемы могут быть в:

1. Не корректно поддерживается графика вашим дистрибутивом

2. Параметры графики для встроенного монитора не корректны (разрешение, частота обновления).

Я бы начал копать с пункта 2.

 Или поставил бы Ubuntu 20.10 - хоть он еще и не релизнулся - но там новое ядро и с большой долей вероятности у вас будет все ок

Link to comment
Share on other sites

17 minutes ago, Firebird said:

2. Параметры графики для встроенного монитора не корректны (разрешение, частота обновления).

Я бы начал копать с пункта 2.

Второй пункт первым делом проверил, всё в порядке. Разрешение и частота родные.

 

17 minutes ago, Firebird said:

Или поставил бы Ubuntu 20.10 - хоть он еще и не релизнулся - но там новое ядро и с большой долей вероятности у вас будет все ок

 

Вы наверное имеете ввиду 21.10? Возможно стоит попробовать.

 

Кстати, сейчас откатился с 5.11.0-37 на 5.11.0-16, и экран работает. Хотя на минте на этом ядре не работал.

 

Просто ноут довольно свежий, возможны проблемы с дровами, я понимаю. Но в эту парадигму не ложится работа на более старых ядрах. Вот что хотелось бы понять

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...