Jump to content

Olgerd

Members
  • Posts

    47
  • Joined

  • Last visited

    Never

Everything posted by Olgerd

  1. Блин фигня какая-то получается. Снёс дрова, но теперь базовая конфигурация говорит, что 3D нет. То есть в Yast показывется всё нормально, крестик поддержка напротив 3D, но в когда тест запускаеш то 3D зачёркнуто , и когда входиш в мой компьютер показывается что нет поддержки 3D. Блин чего за фигня. И дрова 40.4 не помогли. 3D не включается. Вопрос как вернуть поддержку 3D в базовую конфигурацию? (вообще без установки дополнительных драйверов)
  2. 3D в 10.3 ATI Radeon 9600. Может кто знает. 1. Репозитарий ATI вначале включил потом снёс. 2. Поставлены все официальные апдейты. 3. Вчера ставил по инструкции последнии драйвера. http://en.opensuse.org/Ati#Step_2_-_Generate_Distribution_Sp ecific_Driver_Package Дрова встали, но: glxinfo OpenGL vendor string: ATI Technologies Inc. OpenGL renderer string: RADEON 9600 здесь всё хорошо. fglrxinfo проходит нормально fgl_glxgears - тест не проходит и в уасте 3D показано что нет. При установке добавлял следующие записи в файл. Resolution: To disable the Composite extension, edit/add the following lines to the end of /etc/X11/xorg.conf file: Section "Extensions" Option "Composite" "false" EndSection (закоментировав аналогичнуб предудущую запись) Note: Apparently the default is Enabled, so removing the line to disable Composite will not work. The setting needs to be explicitly set to false. [edit] Other important Settings in the xorg.conf For best and most stable working fglrx driver set the following options to Section "Device" in the xorg.conf: Option "BlockSignalsOnLock" "on" Option "KernelModuleParm" "locked-userpages=0" Option "OpenGLOverlay" "off" Option "UseFastTLS" "2" Option "UseInternalAGPGART" "no" Option "VideoOverlay" "on" Option "mtrr" "off" Option "no_accel" "no" Option "no_dri" "no" Option "EnablePrivateBackZ" "no" Option "backingstore" "true" Просто добавил. Итог: 3D нет. Есть периодические артефакты в виде вертикального (2 см шириной цветного полупрозрачного типа штрихкода) И мыш показывается на экране не там где находится.Смещение на 5 см по вертикали. Это сырые дрова или может кто-нибудь с таким сталкивался?
  3. Legalizer писал(а) Tue, 13 November 2007 19:57 Olgerd писал(а) Tue, 13 November 2007 17:59 А в каком репозитарии он находится? Подключите репозитарий Packman. Поставьте пакет MPlayer. Там уже есть mencoder. Как подключить mencoder? где галку в репозитарии поставить? Как его использовать в графическом режиме? Чего то не пойму.
  4. А в каком репозитарии он находится?
  5. Конвертация видео. Существует ли базовая программа (доступная в репозитариях) для конвертации видеофайлов в другой формат (3gp например) и изменения параметров видео (размер экрана, битрейт...).
  6. Где достать libdvdcss для suse 10.3? В Пакмене пока нет. Для 10.2 подойдёт (хотя думаю что нет)?
  7. 4 Октября - openSUSE 10.3 public release. Будет сразу доступно для скачивания или нет? Кто нибудь точно знает?
  8. AccessD писал(а) Wed, 28 March 2007 17:17 а гугл на что? Специально сейчас посмотрел. По knx информации хорошей море, по остальным меньше. Вопрос простой, мне надо из openSuse 10.2 брать под удаленный контроль в графическом виде машины на которых стоит Win 2000, XP, 2003. Чем это лучше делать? По чему в графическом - на них крутятся SQL сервера. Работа в удаленном доступе в текстовом режиме СИЛЬНО замедляет работу. Делать выборки и проверять корректность работы клиентской программы можно только в графике. Как лучше сделать данный удалённый доступ?
  9. alex_niv писал(а) Wed, 28 March 2007 12:42 У меня KDE - Система - Remote Access : - KNX - KSSH - Krdc - Krbf - Новый сеанс Может кто нибудь расписать, что означает каждый из вышеуказанных методов?
  10. Ура linux-oleg:/usr/src/packages/RPMS/i386 # fglrxinfo display: :0.0 screen: 0 OpenGL vendor string: ATI Technologies Inc. OpenGL renderer string: RADEON 9600 XT OpenGL version string: 2.0.6334 (8.34. Всё понял. Вначале не было требуемых пакетов для установки (на диске установочном) потом проблема, что пытался ставить дрова с ATI сайта, и проставилась не последняя версия. Итого снёс через Яст дрова установленные с сайта потом rpm -e $(rpm -qa | grep fglrx) потом ставил дрова rpm -Uvh --force fglrx_7_1_0_SUSE102-8.34.8-1.i386.rpm fglrx-kernel-build.sh Перезегрузился и всё заработало!
  11. Так в логе media:/sda8/var/log/Xorg.0.log нашёл следующее: (II) fglrx(0): [drm] DRM interface version 1.0 (II) fglrx(0): [drm] created "fglrx" driver at busid "PCI:1:0:0" (II) fglrx(0): [drm] added 8192 byte SAREA at 0x2000 (II) fglrx(0): [drm] mapped SAREA 0x2000 to 0xb7379000 (II) fglrx(0): [drm] framebuffer handle = 0x3000 (II) fglrx(0): [drm] added 1 reserved context for kernel (II) fglrx(0): DRIScreenInit done (II) fglrx(0): Kernel Module Version Information: (II) fglrx(0): Name: fglrx (II) fglrx(0): Version: 8.33.6 (II) fglrx(0): Date: Jan 8 2007 (II) fglrx(0): Desc: ATI FireGL DRM kernel module (WW) fglrx(0): Kernel Module version does *not* match driver. (EE) fglrx(0): incompatible kernel module detected - HW accelerated OpenGL will not work (II) fglrx(0): [drm] removed 1 reserved context for kernel (II) fglrx(0): [drm] unmapping 8192 bytes of SAREA 0x2000 at 0xb7379000 (WW) fglrx(0): *********************************************** (WW) fglrx(0): * DRI initialization failed! * (WW) fglrx(0): * (maybe driver kernel module missing or bad) * (WW) fglrx(0): * 2D acceleraton available (MMIO) * (WW) fglrx(0): * no 3D acceleration available * (WW) fglrx(0): ********************************************* * Есть идеи куда копать дальше?
  12. Поставил с диска все требуемые пакеты. Карточка определилась в Sax правильно Radeon 9600. Поставил заново драйвера. вроде встали, проапдейтил ядро. но linux-oleg:/usr/X11R6/bin # fglrxinfo display: :0.0 screen: 0 OpenGL vendor string: Mesa project: www.mesa3d.org OpenGL renderer string: Mesa GLX Indirect OpenGL version string: 1.4 (1.5 Mesa 6.5.1) linux-oleg:/usr/X11R6/bin # fgl_glxgears Using GLX_SGIX_pbuffer X Error of failed request: BadMatch (invalid parameter attributes) Major opcode of failed request: 143 (GLX) Minor opcode of failed request: 5 (X_GLXMakeCurrent) Serial number of failed request: 33 Current serial number in output stream: 33 linux-oleg:/usr/X11R6/bin # Опять 25 думаю .......
  13. i386 # rpm -Uvh --force fglrx_7_1_0_SUSE102-8.34.8-1.i386.rpm Preparing... ########################################### [100%] 1:fglrx_7_1_0_SUSE102 ########################################### [100%] ************************************************************ * Package "kernel-source" needs to be installed by YaST2 first! ************************************************************ * ************************************************************ ** Building/installation of fglrx kernel module failed! Try again by calling "/usr/X11R6/bin/fglrx-kernel-build.sh" manually. ************************************************************ ** ************************************************************ * Please read "/usr/share/doc/packages/fglrx/README.SuSE" for configuration details when using SaX2. ************************************************************ * пробовал переставить по инструкции. вылетает следующая ошибка. что подразумевается?
  14. Подскажите теперь встали дрова ли нет? linux-oleg:/home # glxgears Xlib: extension "XFree86-DRI" missing on display ":0.0". 1002 frames in 5.5 seconds = 180.673 FPS 960 frames in 5.5 seconds = 174.037 FPS 960 frames in 5.5 seconds = 174.073 FPS linux-oleg:/home # glxinfo name of display: :0.0 Xlib: extension "XFree86-DRI" missing on display ":0.0". display: :0 screen: 0 direct rendering: No server glx vendor string: SGI server glx version string: 1.2 server glx extensions: GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method, GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe, GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig, GLX_MESA_copy_sub_buffer client glx vendor string: ATI client glx version string: 1.3 client glx extensions: GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context, GLX_ARB_get_proc_address, GLX_SGI_video_sync, GLX_ARB_multisample, GLX_ATI_pixel_format_float, GLX_ATI_render_texture GLX extensions: GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context, GLX_ARB_multisample OpenGL vendor string: Mesa project: www.mesa3d.org OpenGL renderer string: Mesa GLX Indirect OpenGL version string: 1.4 (1.5 Mesa 6.5.1) OpenGL extensions: GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp, GL_ARB_texture_cube_map, GL_ARB_texture_env_add, GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3, GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color, GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add, GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3, GL_EXT_texture_lod_bias glu version: 1.3 glu extensions: GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat ------------------------------------------------------------ ---------- 0x23 24 tc 0 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 1 0 None 0x24 24 tc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 1 0 None 0x25 24 tc 0 32 0 r y . 8 8 8 8 0 16 8 16 16 16 16 1 0 None 0x26 24 tc 0 32 0 r . . 8 8 8 8 0 16 8 16 16 16 16 1 0 None 0x27 24 dc 0 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 1 0 None 0x28 24 dc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 1 0 None 0x29 24 dc 0 32 0 r y . 8 8 8 8 0 16 8 16 16 16 16 1 0 None 0x2a 24 dc 0 32 0 r . . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
  15. Как-то всё странно: 1. когда дрова ставились судя по логу что-то не поставилось. Это было видно по терминальному окну. 2. В меню появилась иконка управления графикой,ATI, но при клике ничего не запускается. 3. Скорость поднялась заметно. 4. Дрова скачивал с ati сайта. Ставил дрова, не генерил чего-то там. (когда начинаешь ставить есть выбор ставить дрова или чего-то там сгенерить, Я тупо ставил) http://ati.amd.com/support/drivers/linux/linux-radeon.html 5. В КДЕ карта распознается как ... 350 чегото там, а у меня Radeon9600 ХТ. 3Д ускорение выбрать нельзя. но команда glxgears выдает следуещее. Xlib: extension "XFree86-DRI" missing on display ":0.0". 1836 frames in 5.3 seconds = 347.376 FPS 1800 frames in 5.3 seconds = 338.541 FPS 1800 frames in 5.3 seconds = 338.529 FPS 1800 frames in 5.3 seconds = 338.639 FPS 1800 frames in 5.3 seconds = 338.756 FPS 1800 frames in 5.3 seconds = 338.767 FPS 1800 frames in 5.5 seconds = 327.798 FPS Может просто не поставился ATIшный центр управления, или Я чегото не додел или не так сделал?
  16. У меня такая же мамка, но проблем не было. Ставил 2 раза. Новый биос говорите, но последнее обновление биоса к этой материнке относится к концу 2004 года. Или ставили не оффициальный? - Тогда это только ваши проблемы. Обновите биос на оффициальный.
  17. Legalizer писал(а) Sun, 11 March 2007 21:15 Olgerd писал(а) Sun, 11 March 2007 19:54 Вот так у меня сейчас видны шрифты. Как можно поправить данную ситуацию? Заголовок окна и названия меню у вас нормально выглядят. А сам текст страницы отображается действительно криво, потому что сглаживание отключено, а вот шрифты, которые должен использовать Firefox, не настроены. ЗАйдите в Firefox в Правка -> Настройки -> вкладка "Содержимое" -> кнопка "Дополнительно" в разделе "Шрифты и Цвета". Там уберите галку "Разрешить веб страницам использовать свои шрифты". Потом выберите в менюшке "Кириллица" такие же шрифты, как указаны на приложенном скриншоте. Потом выберите пункт "ЗАпадноевропейский" и там выставите ТЕ ЖЕ шрифты. Удачи Спасибо огромное!!! Всё заработало!!!
  18. Вот так у меня сейчас видны шрифты. Как можно поправить данную ситуацию?
  19. Что с форумом? более суток не мог зайти!!! У меня так одного или нет?
  20. Legalizer писал(а) Tue, 06 March 2007 12:50 На таком железе все должно летать, по идее. 1. А какой драйвер для видео платы используется? То есть АТИшный "родной" или свободный radeon? Иными словами, драйвер АТИ устанавливали? 2. Можно попробовать поиграть с наcтройками вывода видео Kaffeine (меню Настройка -> Параметры движка xine -> видео -> вместо "auto" попробовать другие варианты). Не факт, что поможет, но вдруг Да!!! Спасибо. Xshm драйвер дал скорость!!! Kaffeine - автоопределение драйвера отрабатывало не правильно. Следующий вопрос, по наблюдениям сглаживание видеопотока при просмотре видео не работает - это где лучше посмотреть настройки? По простому в винде пока видео смотрится лучше всётаки, хочу Линукс полностью добить и про винду забыть.
  21. Legalizer писал(а) Tue, 06 March 2007 12:50 На таком железе все должно летать, по идее. 1. А какой драйвер для видео платы используется? То есть АТИшный "родной" или свободный radeon? Иными словами, драйвер АТИ устанавливали? 2. Можно попробовать поиграть с наcтройками вывода видео Kaffeine (меню Настройка -> Параметры движка xine -> видео -> вместо "auto" попробовать другие варианты). Не факт, что поможет, но вдруг Дрова родные ATI. Скачивал с офф сервера. Ставил по инструкции. Вечером проверю ещё раз встали ли все кодеки. С настройками поиграюсь. О вспомнил, когда запускал Kaffeine он сказал, что нехватеат каких-то кодеков и типа ДВД и чего-то из Win кодеков он не нашёл и играть не будет, это может повлиять? Когда ставил Гуру он сказал, что 1 пакет не находит требуемую библиотеку, и Я его тоже не ставил. Всего утром поставил Пакмана 250 МБ апдейтов и Гуру 150 МБ. Более ничего поставить не успел. Посмотрел клипы, увидел что пошло и поехал на работу. Старый xine не удалял, вроде он при установке сам удаляется и ставится новый. К Пакмана и Гуру ставил всё по умолчанию, проверю, может чего не доставилось.
  22. Legalizer писал(а) Tue, 06 March 2007 11:35 Olgerd писал(а) Tue, 06 March 2007 10:10 kaffeine - дико тормозит проигрыш видео. Аудио нормально. 1. Какое у вас железо? 2. Вообще система не подтормаживает? 3. Сколько свободной оперативной памяти при этом? (смотреть командой free) 1. 2.8 Пень, Ядро Northood 1 гиг оперативки Мать Asus P 800C Deluxe Винт 120 ГБ Sata (IBM вроде) видео Ati Radeon 9600 XT монитор 17 Nec 1280*1024 2. Система отлично работает. 3. Да оперативки море говорю (дома проверю), другой проигрыватель нормально работает. Впечатление как будто kaffeine показывает только каждый 4 кадр (то есть видео успевает за звуком (идёт адекватно), но "квадратно" идёт)
  23. Поставил пакмана и гуру! Видео пошло!!! Только одня проблемка! kaffeine - дико тормозит проигрыш видео. Аудио нормально. Видео пока смотрю Totem Movie Player 2.17.3. kaffeine - как от тормозов отучить? Плюс на мой взгяд видео отображается немного хуже чем в винде, это так?
×
×
  • Create New...