Jump to content

Recommended Posts

Народ, у меня проблема с Fedora Core 4 и Хorg после загрузки Х-ов я не могу попасть обратно в консоль по Ctrl+Alt+F1,F2,F3..., появляется серый экран, а самой командной строки нет, то-же самое происходит и после выхода из Х-ов, подскажите пожалуйста, что делать. И еще в каком файле находится лог загрузки Х-ов?

Link to post
Share on other sites

/var/log/Xorg.0.log или что-то в этом духе.

Подобная проблема, как правило, возникает из-за использования неправильных настроек видео.

Загляните на предмет настроек в /etc/X11/xorg.conf

Link to post
Share on other sites

webgrig писал(а) пн, 15 августа 2005 14:19

появляется серый экран, а самой командной строки нет, то-же самое происходит и после выхода из Х-ов, подскажите пожалуйста,

иногда помогает "вслепую" набрать

reset

и нажать enter

это сброс консоли

Link to post
Share on other sites

по поводу настроек видео я думаю, что у меня все нормально, т.к. у меня же раньше все работало нормально, только вот я не заметил после чего перестало работать

Link to post
Share on other sites

White_Mouse писал(а) вт, 16 августа 2005 00:50

Не стоит ли показать настройки видео из /etc/X11/xorg.conf, а равно и логи Х-сервера. Это может быть информативно.

/etc/X11/xorg.conf

---------------------------

Section "ServerLayout"

Identifier "Default Layout"

Screen 0 "Screen0" 0 0

InputDevice "Mouse0" "CorePointer"

InputDevice "Keyboard0" "CoreKeyboard"

EndSection

Section "Module"

Load "dbe"

Load "extmod"

Load "fbdevhw"

Load "glx"

Load "record"

Load "freetype"

Load "type1"

Load "dri"

EndSection

Section "InputDevice"

Identifier "Keyboard0"

Driver "kbd"

Option "XkbModel" "pc105"

Option "XkbLayout" "us,ru(winkeys)"

Option "XkbOptions" "grp:shift_toggle,grp_led:scroll"

EndSection

Section "InputDevice"

Identifier "Mouse0"

Driver "mouse"

Option "Protocol" "IMPS/2"

Option "Device" "/dev/input/mice"

Option "ZAxisMapping" "4 5"

Option "Emulate3Buttons" "yes"

EndSection

Section "Monitor"

Identifier "Monitor0"

VendorName "Monitor Vendor"

ModelName "SyncMaster"

DisplaySize 310 230

HorizSync 30.0 - 85.0

VertRefresh 50.0 - 160.0

Option "dpms"

EndSection

Section "Device"

Identifier "Videocard0"

Driver "i810"

VendorName "Videocard vendor"

BoardName "Intel 845"

EndSection

Section "Screen"

Identifier "Screen0"

Device "Videocard0"

Monitor "Monitor0"

DefaultDepth 24

SubSection "Display"

Viewport 0 0

Depth 16

Modes "1024x786" "800x600" "640x480"

EndSubSection

SubSection "Display"

Viewport 0 0

Depth 24

Modes "1024x768" "800x600" "640x480"

EndSubSection

EndSection

Section "DRI"

Group 0

Mode 0666

EndSection

------------------------------------------------------

А что поводу лога, то я бы с удовольствием показал его, но дело все в том, что я не совсем понял какие именно строки нужно показать?

Link to post
Share on other sites

строки в которых присутвуют слова: error, not found и т.п.

а в конфиге можно попробовать закомментировать

Load "glx"

Load "dri"

DefaultDepth 24

и из modes убрать разрешения - должно запустится пусть хоть на 320х240

Link to post
Share on other sites

Byte писал(а) ср, 17 августа 2005 15:12

строки в которых присутвуют слова: error, not found и т.п.

Это все что я нашел

-------------------------

Module Loader present

OS Kernel: Linux version 2.6.12-1.1398_FC4 (bhcompile@tweety.build.redhat.com) (gcc version 4.0.0 20050519 (Re

d Hat 4.0.0-8)) #1 Fri Jul 15 00:52:32 EDT 2005

Markers: (--) probed, (**) from config file, (==) default setting,

(++) from command line, (!!) notice, (II) informational,

(WW) warning, (EE) error, (NI) not implemented, (??) unknown.

(==) Log file: "/var/log/Xorg.0.log", Time: Thu Aug 18 11:48:22 2005

(==) Using config file: "/etc/X11/xorg.conf"

(==) ServerLayout "Default Layout"

(**) |-->Screen "Screen0" (0)

(**) | |-->Monitor "Monitor0"

(**) | |-->Device "Videocard0"

(**) |-->Input Device "Mouse0"

(**) |-->Input Device "Keyboard0"

(**) FontPath set to "unix/:7100"

(**) RgbPath set to "/usr/X11R6/lib/X11/rgb"

(==) ModulePath set to "/usr/X11R6/lib/modules"

(WW) Open APM failed (/dev/apm_bios) (No such file or directory)

(II) Module ABI versions:

X.Org ANSI C Emulation: 0.2

X.Org Video Driver: 0.7

X.Org XInput driver : 0.4

X.Org Server Extension : 0.2

X.Org Font Renderer : 0.4

(II) Loader running on linux

Link to post
Share on other sites

Byte писал(а) ср, 17 августа 2005 15:12

а в конфиге можно попробовать закомментировать

Load "glx"

Load "dri"

DefaultDepth 24

и из modes убрать разрешения - должно запустится пусть хоть на 320х240

Не помогает.

Link to post
Share on other sites

Byte писал(а) чт, 18 августа 2005 18:58

хм... а если воспользоваться xorg.conf-vesa?

типа так:

#cp /etc/X11/xorg.conf /etc/X11/xorg.conf.old

#cp /etc/X11/xorg.conf-vesa /etc/X11/xorg.conf

$startx

у меня нет такого файла xorg.conf-vesa

Link to post
Share on other sites

ну тогда в существующем секцию Device переписать как

Section "Device" 
    Identifier  "VESA" 
    Driver      "vesa" 
EndSection

и в секции Screen заменить на Identifier "VESA"

Link to post
Share on other sites

Люди, подскажите пожалуйста, что значят такие записи в Xorg.0.log

(WW) Open APM failed (/dev/apm_bios) (No such file or directory)

(WW) I810(0): Bad V_BIOS checksum

(WW) I810(0): Extended BIOS function 0x5f11 not supported.

(WW) I810(0): Bad V_BIOS checksum

*(WW) ((null),Monitor0) mode clock 189.911MHz exceeds DDC maximum 180MHz

(WW) ((null),Monitor0) mode clock 188.5MHz exceeds DDC maximum 180MHz

(WW) ((null),Monitor0) mode clock 187.314MHz exceeds DDC maximum 180MHz

(WW) ((null),Monitor0) mode clock 185.908MHz exceeds DDC maximum 180MHz

(WW) ((null),Monitor0) mode clock 184.723MHz exceeds DDC maximum 180MHz

(WW) ((null),Monitor0) mode clock 183.321MHz exceeds DDC maximum 180MHz

(WW) ((null),Monitor0) mode clock 182.138MHz exceeds DDC maximum 180MHz

(WW) ((null),Monitor0) mode clock 180.74MHz exceeds DDC maximum 180MHz

(WW) I810(0): Bad V_BIOS checksum

(WW) I810(0): Setting the original video mode instead of restoring

the saved state

(WW) Open APM failed (/dev/apm_bios) (No such file or directory)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...