Jump to content

Странная ошибка в VMware Workstation 5.5.3 - HELP!


Recommended Posts

Я скачал VMware Workstation 5.5.3. Установка прошла успешно, без единого ворнинга. Я завел новую виртуальную машину для Windows XP Professional, выделил под нее 8Гб харда и 256Мб оперативки. Пока все нормально.

Однако сейчас - самое интересное. Нажимаю кнопку "Power On" - и... Вся VMware наглухо виснет. Не работают кнопки, экран совершенно черный. По команде ps -aux узнаю, что процесс vmware ест около 98% процессорного времени.

Иногда через 3-5 минут выскакивает следующее сообщение; "Unable to change virtual machine power state: Cannot find a valid peer process to connect to.". При этом процесс vmware остается, так что приходится его киллить. А иногда можно хоть 10 минут ждать, ничего не происходит.

На одном англоязычном форуме нашел, что кто-то решил эту проблему, добавив в файл *.vmx машины следующие строки;

hostinfo.noTSC = "TRUE"

tools.syncTime = "TRUE"

Я их добавил. Теперь иногда при запуске также все виснет, но верхние меню (например, "settings") работают. Однако ничего не происходит. А чаще всего, как и раньше, все наглухо виснет - и все.

Файл *.vmx машины я выкладываю (см. вложенный файл) для всеобщего обозрения.

Помогите, пожалуйста! Очень нужна VMware для изучения английского по виндовому диску, а то wine у меня не попер данный диск...

P.S. С VMware Player то же самое.

Link to comment
Share on other sites

А зачем вам Workstation, тем более наверняка крякнутая? Скачайте бесплатную VMWare Server - там таких ошибок быть не может, поскольку она по другому работает и с утсройствами и с памятью.

Хотя, если у вас не быстрый или дорогой интернет, 100 Мб это не так уж и бесплатно Smile

Link to comment
Share on other sites

Dr.Spectre писал(а) Fri, 05 January 2007 19:26

глупый совет -но дам. попробуйте parallels - это типа вмваре но другая.

Да, слышал про такую. Но дело в том, что 2 года назад, при моем первом знакомстве с Linux (тогда еще Red Hat 7.3) я использовал VMware Workstation. И она мне очень понравилась, так что сейчас очень хочется юзать именно ее. Да и скорость ее мне понравилась: при моих тогдашних 128Мб Red Hat Linux 7.3 + вмварная Windows 98 SE шли довольно шустренько.

Aceler писал(а) Fri. 05 January 2007 19:37

А зачем вам Workstation, тем более наверняка крякнутая? Скачайте бесплатную VMWare Server - там таких ошибок быть не может, поскольку она по другому работает и с утсройствами и с памятью.

Хотя, если у вас не быстрый или дорогой интернет, 100 Мб это не так уж и бесплатно Smile

Аналогично.

P.S. Интернет у меня не самый медленный; 2 MBit/s безлимитка Very Happy

Link to comment
Share on other sites

Ну, помогите чем-нибудь, пожалуйста! Выкладываю скриншот типичного зависания для ясности.

P.S. Кстати, при запуске Linux'а пишется, что подключается вмварный DHCP-сервер, хотя я при создании VMware указывал, что не надо создавать сеть. Может быть, ошибка как-то с этим связана?

Link to comment
Share on other sites

  • 2 weeks later...

Я переустановил весь Линух на X86_64 - и вмваре заработала! Винда Хрюндель поставилась без проблем!

Однако звук у меня почему-то так и не заработал. Сначала писал, что устройство /dev/dsp занято другим приложением (наверное, arts'ом), а затем, после запуска со звуком esd (подозреваю, что все еще с ним запускается), ошибка исчезла, но звука все равно нет. Очень странно! Странно и то, что даже сам по себе esd у меня упорно не хочет звучать. Может быть, я чего-то не доставил?

Помогите, пожалуйста! Винду я ставил с единственной целью - учить английский с диска (wine его не потянул), а без звука этим заниматься нет никакого смысла Sad

Link to comment
Share on other sites

  • 2 weeks later...

Все прекрасно работает!!! Даже звук пошел - надо было просто отключить звук в KDE, и VMware зазвучала!

Все работает быстро и хорошо! Поставил Microsoft Office 2007 (для изучения, естественно) - летает, быстрее, чем был 2003 в чистой винде! Настроил сеть, так что с другим (виндовым) компом можно перекидываться файлами. Даже удалось вспомнить старые времена и по сети погамать в Age of Empires Smile

В-общем, всем спасибо, но я остаюсь на VMware Wink

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...