Jump to content

gambas не компилируется (linux+virtualbox)


Recommended Posts

Доброго времени суток. В linux новичок. Установил virtualbox

и Linux ubuntu. Попытался установить gambas

не выходит. Компиляцию прошло нормально. А дальше я ничего не понял. Файл трассировки терминала прилагаю.

Можете послать меня почитать книжки и тд, Embarassed но лучше скажите решение. Или как правильно сделать. Спасибо

Link to post
Share on other sites

Kreol писал(а) Wed, 28 July 2010 01:47

Доброго времени суток. В linux новичок. Установил virtualbox

и Linux ubuntu. Попытался установить

не выходит. Компиляцию прошло нормально. А дальше я ничего не понял. Файл трассировки терминала прилагаю.

Можете послать меня почитать книжки и тд,
Embarassed
но лучше скажите решение. Или как правильно сделать. Спасибо

Для начала, у Вас компилятор не установлен.

Link to post
Share on other sites

В README или INSTALL к Gambas должен быть список необходимых инструментов необходимых для сборки. Проверьте их наличие. Заодно проверьте наличие -dev/-devel пакетов нужных библиотек.

Link to post
Share on other sites

Ребят вопрос. А где брать библиотеки и как их устанавливать? Что каждую через поиск искать? Просто видать слишком привык в хрюше. Что все в куче и ничего искать не нужно.

Readme приложил. Да написано что должны установить. а как? куда? Question

Link to post
Share on other sites

gambas2-2.21.0 скачан с оф сайта Smile Можно тогда риторический вопрос Smile почему все так сложно?. Ну неужели нельзя все сделать чтоб распаковывалось само?

Link to post
Share on other sites

Вы не ответили на поставленный вопрос.

Но вообще-то сейчас такой необходимости собирать что-то нет, за исключением специфических условий, которые мы в данном случае не рассматриваем. Всё берётся из репозиториев того дистрибутива, которым Вы пользуетесь. Там уже должен быть готовый собранный бинарник, который ставится в пару щелчков мыши со всеми зависимостями. Это и есть то, что Вы называете "просто распаковывается".

P.S.

А пардон. Я не заметил, что вы с самом начале написали ,что у Вас Ubuntu. Mea culpa, однако.

В вашем случае, вам досточно запустить Synaptic и поискать Gambas там. Если там нет Gambas, поискать репозитории Ubuntu, где он есть. Подключить его и, собственно, пользоваться. Хотя не уверен, что найдёте. Ибо в README вижу зависимость Gambas от библиотек QT3. Просто QT3 считается устаревшим, и сейчас программы на нём написанные медленно, но верно портируются под QT4. Руками поставить можно, но тогда вам придётся вытягивать тонны QT3-шых библиотек. Как-то так.

Link to post
Share on other sites

Kreol писал(а) Wed, 28 July 2010 23:46

gambas2-2.21.0 скачан с оф сайта
Smile
Можно тогда риторический вопрос
Smile
почему все так сложно?. Ну неужели нельзя все сделать чтоб распаковывалось само?

А распаковывется всё и так само.

Хотите что бы ещё и устанавливалось само - легко. Подключаете репозитарии и будет Вам само.

Link to post
Share on other sites

ну по вашим ответам я понял, что gambas это устаревшее ПО. Тогда вопрос: что на данный момент самое как сказать новое в сфере визуального ПО похожее желательно на visual studio?

Link to post
Share on other sites

Я сказал, что могу предположить, что gambas может и не быть в репозиториях Ubuntu. К счастью, я ошибался.

Смотрим список пакетов для Ubuntu 10.04:

Цитата:

gambas2 (2.19.0-2) [universe]

Complete visual development environment for Gambas

gambas2-dev (2.19.0-2) [universe]

Gambas compilation tools

gambas2-ide (2.19.0-2) [universe]

Visual development environment for the Gambas programming language

Так что всё, что вам надо, это открыть Synaptic, ввести туда слово gambas в поле поиска и установить необходимое. Вот и всё. Smile

На будущее - сред разработки и просто средств для программирования существует под Linux очень много. От монструозных Eclipse до всевозможных QT Designer и Qt Creator.

Link to post
Share on other sites

Цитата:

новое в сфере визуального ПО

Например, свежие гном, кде, компиз ))) гимп тоже вполне себе визуальный)

Но если вы имели ввиду IDE, то, пожалуй, Eclipse сейчас наиболее сильная штука. К ней куча плагинов под разные цели - от JavaScript до Qt. Хотя для Qt лучше родной криейтор использовать.

Link to post
Share on other sites

Kreol писал(а) Wed, 28 July 2010 22:46

gambas2-2.21.0 скачан с оф сайта
Smile
Можно тогда риторический вопрос
Smile
почему все так сложно?. Ну неужели нельзя все сделать чтоб распаковывалось само?

Если ещё не решил, могу написать простой способ, но в теримнале.

Link to post
Share on other sites

Спс всем.

r0g3r особое.

AccessD спс за подробный ответ.

rootallilua за описание в терминале, буду очень благодарен. Так как учиться всегда есть желание. Лишних знаний не бывает Smile

Link to post
Share on other sites

Ребята подскажите при загрузке любого файла примера. Відается ошибка про неподключение того или иного файла. Как єто исправить? Что-то, где-то нужно прописать?

Link to post
Share on other sites

Kreol писал(а) Mon, 02 August 2010 00:21

rootallilua
за описание в терминале, буду очень благодарен. Так как учиться всегда есть желание.
Лишних знаний не бывает
Smile

Для установки из терминала делай так.

Для начала войди как root. Если ещё нет такого пользователя, набери вот так, "user@localhost~$" не пиши, это пример у тебя будет своё, наверняка другое приглашение!!!

user@localhost~$sudo passwd root (появится приглашение на ввод пароля user, после появится приглашение на ввод и подтверждения пароля root)

user@localhost~$su - (войти в режим пользователя root, если вошёл, в приглашении измениться знак доллара на знак решётка )

root@localhost~#apt-get install gambas или gambas2 (если у тебя в репозиториях он есть, будет вопрос о подтверждении установки "Y" или "NO", если не передумал устанавливать нажимай "Y", всё установиться само. Если потом в меню значка не найдешь, можешь запустить из терминала написав gambas или gambas2)

Если у тебя в репозиториях gambas нет, тогда так - открой редактором файл "/etc/apt/sources.list" внизу текста напиши новую строку, вот эту:

deb http://ftp.es.debian.org/debian sid main

дальше обнови репозитории вот так

root@localhost~#apt-get update

И снова устанавливай вот так:

root@localhost~#apt-get install gambas или gambas2

Но. Я так делал на ubuntu 8.10, сейчас у меня Debian Lenny - превосходит Uduntu во всём!!!

Link to post
Share on other sites

Kreol писал(а) Wed, 04 August 2010 15:30

Ребята подскажите при загрузке любого файла примера. Відается ошибка про неподключение того или иного файла. Как єто исправить? Что-то, где-то нужно прописать?

Если бы подробнее описал проблему и ошибку, может и помог бы кто!!!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...