Jump to content
Sign in to follow this  
Beta

resolv.conf

Recommended Posts

Здраствуйте.

Открываю файл /etc/resolv.conf

Нахожу строку(хотя у меня она там всего одна):

nameserver 192.168.1.1

Меняю ее на строки:

nameserver 91.196.207.62
nameserver 91.196.206.2

Сохраняю, меняю права на первоначальные. Интернет работает. НО после перегрузагрузки системы файл resolv.conf заменяется на дефолтный. То есть все строки которые я вводил заменились на первую.

Подскажите что не так делаю?

Share this post


Link to post
Share on other sites

У вас используется DHCP для присвоения ip-адреса сетевому интерфейсу? Если да, то вероятнее всего, dhcpd и переписывает этот файл.

Share this post


Link to post
Share on other sites

Честно говоря, с Debian я практически не знаком. Пользуюсь Ubuntu. В ней можно назначить DNS сервер в настройках сети в графическом интерфейсе. В скриптах, запускающих сетевую подсистему я не копался. Сейчас навскидку не нашел, где что поправить.

В качестве временной меры (пока не разберетесь и не найдете правильное решение) можно пользоваться следующим вариантом:

Добавьте в файл /etc/rc.local (непосредственно перед строкой exit 0 (если она есть) такую строку:

echo "nameserver XXX.XXX.XXX.XXX" > /etc/resolv.conf

где XXX.XXX.XXX.XXX - ip адрес вашего DNS-сервера.

В этом случае содержимое /etc/resolv.conf при каждом запуске системы (уже после старта сетевой подсистемы) будет заменяться вашей записью.

Это "кривое" решение, но рабочее. Поищите как правильно, если интересно.

Удачи.

Share this post


Link to post
Share on other sites

Цитата:

Честно говоря, с Debian я практически не знаком. Пользуюсь Ubuntu. В ней можно назначить DNS сервер в настройках сети в графическом интерфейсе. В скриптах, запускающих сетевую подсистему я не копался. Сейчас навскидку не нашел, где что поправить.

А можно узнать как называется эта утилита? Может в дебиане она тоже есть.

Share this post


Link to post
Share on other sites

В Gnome меню Система -> Администрирование -> Сеть.

Что за программа, я не в курсе. Не было смысла разбираться, т.к. все просто работает.

Share this post


Link to post
Share on other sites

Хмм... в гноме я тоже делал так же.. и все равно инет не работает.. точнее работает до перезагрузки системы

Share this post


Link to post
Share on other sites

Harold писал(а) Thu, 21 August 2008 09:40

Да, я использую DHCP.

И как же устранить эту проблемку?

не использовать DHCP

Share this post


Link to post
Share on other sites

Настроил инет отредактировав /etc/network/interfaces следующим образом:

allow-hotplug eth0
iface eth0 inet static
    address мой ИП
    netmask маска сети
    gateway адрес модема

    dns-nameservers ДНС сервера.. вписал 2 адреса

Цитата:

не использовать DHCP

Расскажите вашу версию настройки инета не используя DHCP?

Share this post


Link to post
Share on other sites

1. Если у вас параметры сети получаются по DHCP - то ничего в resolv.conf менять не надо - DNS-сервера по DHCP отдаются клиенту.

2. Если у вас локальная сеть - DHCP не надо.

Share this post


Link to post
Share on other sites

Привет всем !!!

Сильно не казните новичка,только недавно заинтересовался линуксом

поэтому плохо разбираюсь в нём.

Проблема точно такая же , всё перепробовал ,что здесь написано

и всё равно нормально работать не хочет.

DNS после перезагрузки слетают на 192.168.1.1 если просто поставить в настройках DHCP.

Если resolv.conf выставить вручную DNS то интернет работает ,но после ребута слетает на 192.168.1.1.Причём пока не дезактивируешь

сетевое устройство компьютер невозможно выключить или презагрузить,

зависает сама кнопка при нажатии на неё(презагрузка или выключения)

Если в /etc/network/interfaces выставить net static и прописать

IP ,маску сети , шлюз модема и DNS, как описано выше ,то браузер даже не

пытается загружать страницу,а при загрузке Debian проскакиевает

такая ошибка или пометка с красным,что какой-то if-не помню файл

не может прочитать /etc/network/interfaces файл.

Всё это происходит независимо от того установлен Network Manager или нет.

Извиняюсь за наглёшь,но может кто помогет разобраться где сабаку зарыли.

Debian 4 Etch

2.6.18-4-K7

amd64 4200

Share this post


Link to post
Share on other sites

Цитата:

проскакиевает

такая ошибка или пометка с красным,что какой-то if-не помню файл

не может прочитать /etc/network/interfaces файл.

Ошибки надо цитировать, а не пересказывать.

Покажите файл /etc/network/interfaces

Ну и плюс, может стоит выключить DHCP на модеме, если у вас один-два компьютера. В таких случаях DHCP - это только лишние проблемы.

Share this post


Link to post
Share on other sites

cppmm

Спасибо оза внимание!

Ошибка при загрузке такая-"Ifup-could't read interfaces file /etc/

network/interfaces"

/etc/resolf.conf

nameserver 85.28.195.130

/etc/network/interfsces

# The loopback network interface

auto lo

iface lo inet loopback

# The primary network interface

allow-hotplug eth1

iface eth1 inet static

address XX.XX.XXX.XX

netmask 255.255.255.0

gateway 192.168.1.1

auto eth1

dns-nameservers 85.28.195.130

dns-nameservers 85.28.195.129

Share this post


Link to post
Share on other sites

Amaroid писал(а) Fri, 21 November 2008 11:27

cppmm

Спасибо оза внимание!

Ошибка при загрузке такая-"Ifup-could't read interfaces file /etc/

network/interfaces"

/etc/resolf.conf

nameserver 85.28.195.130

/etc/network/interfsces

# The loopback network interface

auto lo

iface lo inet loopback

# The primary network interface

allow-hotplug eth1

iface eth1 inet static

address XX.XX.XXX.XX

netmask 255.255.255.0

gateway 192.168.1.1

auto eth1

dns-nameservers 85.28.195.130

dns-nameservers 85.28.195.129

Что-то у вас настройки сети не соответствуют тому, что вы описываете.

При чём, даже с ошибкой идут.

Я так понимаю, что интерфейс eth1 должен по dhcp подключаться?

Тогда попробуйте вместо

iface eth1 inet static

прописать

iface eth1 inet dhcp

Строчки address, netmask и gateway либо закомментируйте, либо совсем уберите.

И проверьте, чтобы dns-nameservers были указаны именно те, которые вам нужны.

Share this post


Link to post
Share on other sites

cppmm

В винде у меня работает и с dhcp (с указанием dns) и если прописываю вручную IP,маску подсети,шлюз(IP модема -192.168.1.1) и

dns.

В Debian пытаюсь сделать примерно также или прописывать всё или

получить IP автоматически.

Сейчас интернет работает,но после ребута resolv.conf переписывает

dns.

сейчас настройка interfaces такая :

-----------------------

# The primary network interface

allow-hotplug eth1

iface eth1 inet dhcp

auto eth1

--------------

А при любых других изменениях вообще интернет не работает.

Может что не так делаю ?

Я так понимаю,что в утилите Network Tools 2.14.2 и происходит настройка resolv.conf и interfaces, и какие-только настройки я там не выставлял. Не получается запустить интернет прописав всё вручную.

Share this post


Link to post
Share on other sites

Цитата:

# The primary network interface

allow-hotplug eth1

iface eth1 inet dhcp

auto eth1

Вот, если оставить такую настройку и дополнительно в этом же файле дописать

dns-nameservers xx.xx.xx.xx

, где xx.xx.xx.xx - ваш dns-server

что-то меняется?

В идеале должно заработать.

Что касается утилиты Network Tools 2.14.2, ничего сказать не могу. Я привык всё настраивать руками. И быстрее и надёжнее.

Share this post


Link to post
Share on other sites

cppmm

Это настройка interfaces сейчас

-------------------------------

# The primary network interface

allow-hotplug eth1

iface eth1 inet dhcp

dns-nameservers 85.28.195.130

dns-nameservers 85.28.195.129

auto eth1

-------------------------------

Инет щас есть и после ребута настройки остаются,но

чтобы выключить комп нужно деактивировать сетевое устройство и

во время загрузки проскакивает ошибка о которой я говорил -

"Ifup-could't read interfaces file /etc/

network/interfaces"

Share this post


Link to post
Share on other sites

Какая-то строка повторяется. До этого вы показывали, что у вас отдельно указано auto lo, а чуть ниже auto eth1.

Оставьте только одну строчку auto lo, eth1

После изменения снова проверьте командой ifup -a.

Число, которое выводится через двоеточие(в последнем примере - это 12) указывает на строку, в которой ошибка. Еслиснова будут ошибки, смотрите и сверяйтесь с man interfaces, что не так.

Если же я не угадал с auto, покажите вывод cat /etc/network/interfaces

Share this post


Link to post
Share on other sites

Всётаки через некоторое время dns и без рубута перезаписался.

Удалил строку auto lo,но ошибка всё равно появляется.

Хотя даже в старом варианте 11 строк,а в новом стало 10 - откуда

ошибка в 12 строке ?

А как показать вывод cat cat /etc/network/interfaces ?

Это полностью файл interfaces

-----------------------------------------------------------

# This file describes the network interfaces available on your system

# and how to activate them. For more information, see interfaces(5).

# The loopback network interface

iface lo inet loopback

# The primary network interface

allow-hotplug eth1

iface eth1 inet dhcp

dns-nameservers 85.28.195.130

dns-nameservers 85.28.195.129

auto eth1

------------------------------------------------------------

Share this post


Link to post
Share on other sites

Цитата:

Удалил строку auto lo,но ошибка всё равно появляется.

Удалять совсем не надо было.

Попробуйте привести файл к такому виду:

auto lo eth1
iface lo inet loopback
allow-hotplug eth1
iface eth1 inet dhcp
dns-nameservers 85.28.195.130
dns-nameservers 85.28.195.129

И снова скомандовать ifup -a

Share this post


Link to post
Share on other sites

ifup -a

/etc/network/interfaces:6: duplicate option

ifup: couldn't read interfaces file "/etc/network/interfaces"

Удалить нижний dns ?

Хотя на винде проверял оба рабочие.

А вот и тут в debian пингом проверил 129-й работает

Share this post


Link to post
Share on other sites

хм... Сейчас сам посмотрел ман и примеры... Что-то не могу найти опцию dns-nameservers.

Возможно, ошибка в этом.

В таком случае можно попробовать вместо этих строк прописать

post-up echo "nameserver 85.28.195.130" > /etc/resolv.conf

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...