Jump to content
Sign in to follow this  
Beta

resolv.conf

Recommended Posts

interfaces получился такой

------------------------------------------------------------ --

auto lo

iface lo inet loopback

allow-hotplug eth1

iface eth1 inet dhcp

post-up echo "nameserver 85.28.195.130" > /etc/resolv.conf

post-up echo "nameserver 85.28.195.129" > /etc/resolv.conf

auto eth1

------------------------------------------------------------ --

А это выдал ifup

------------------------------------------------------------ --

ifup -a

There is already a pid file /var/run/dhclient.eth1.pid with pid 14164

killed old client process, removed PID file

Internet Systems Consortium DHCP Client V3.0.4

Copyright 2004-2006 Internet Systems Consortium.

All rights reserved.

For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth1/00:14:85:31:1a:ae

Sending on LPF/eth1/00:14:85:31:1a:ae

Sending on Socket/fallback

DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 3

DHCPOFFER from 192.168.1.1

DHCPREQUEST on eth1 to 255.255.255.255 port 67

DHCPACK from 192.168.1.1

bound to 192.168.1.2 -- renewal in 1514 seconds.

------------------------------------------------------------ ----

Share this post


Link to post
Share on other sites

cppmm

Огроменное спасиба - всё работает Very Happy

С меня ведро пельменей Smile

Это самое первое ,что я настроил после установки Debian.

Завтра буду пытаться настроить видяху ATI,чует моё сердце будут

пляски с бубном.

Share this post


Link to post
Share on other sites

Цитата:

auto lo

iface lo inet loopback

allow-hotplug eth1

iface eth1 inet dhcp

post-up echo "nameserver 85.28.195.130" > /etc/resolv.conf

post-up echo "nameserver 85.28.195.129" > /etc/resolv.conf

auto eth1

Параметр auto нужно указывать только один раз, как я писал выше. Т.е. auto lo eth1

Что касается строчки post-up, бессмысленно писать её дважды, потому как одна "затрёт" другую, поэтому оставьте только одну.

В идеале всё должно заработать.

Share this post


Link to post
Share on other sites

cppmm

Подкорректировал interfaces

--------------------------------

auto lo eth1

iface lo inet loopback

allow-hotplug eth1

iface eth1 inet dhcp

post-up echo "nameserver 85.28.195.130" > /etc/resolv.conf

--------------------------------

ifup -a больше ничего не выдаёт

Почемуж так тяжко у меня настроился интернет,а ведь ещё потом настраивать локалку и wifi.

Share this post


Link to post
Share on other sites

На мой взгляд это не тяжко. Smile)

Обычно достаточно прочтения минимума манов(в данном случае только man interfaces).

Почему проблемы возникли, сложно сказать. Может быть как раз из-за той утилиты, которой вы первоначально пробовали воспользоваться. Может сразу что-то не доглядели. Каждую ситуацию надо рассматривать отдельно. Ну и плюс главное правило - сначала чтение документации и только потом попытка что-либо настроить. Linux - это не венда. Здесь метод научного тыка зачастую не работает.

Share this post


Link to post
Share on other sites

cppmm

Рано я радовался,dns слетает в resolv.conf .

Отличие только в том ,что это происходит во время работы в интернете,а перезагрузка на это не влияет и ошибок в загрузке нет.

Share this post


Link to post
Share on other sites

Amaroid писал(а) Sat, 22 November 2008 11:54

cppmm

Рано я радовался,dns слетает в resolv.conf .

Отличие только в том ,что это происходит во время работы в интернете,а перезагрузка на это не влияет и ошибок в загрузке нет.

Подробнее.

Слетает сам по сее или после каких-либо действий(запуска программ, рестарта сети и т.д.).

Каким образом слетает? Просто в resolv.conf появляется неправильный адрес?

Через какое-то определённое время слетает или совершенно "случайно"?

А так же, пробовалили вариант "Удалить нижний dns"?

Share this post


Link to post
Share on other sites

Похоже, мы шли немного не по тому пути. Тут, на досуге покопался, и кое-что выкопал.

Есть такой файлик /etc/dhcp3/dhclient.conf

Вот там надо добавить строку:

prepend domain-name-servers xx.xx.xx.xx

где иксы - нужный нам dns-сервер.

А в строке, начинающейся с request, наоборот убрать пункт domain-name-servers.

Вот теперь всё точно должно работать.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...