Jump to content

Не знаю как установить программы


Recommended Posts

Для установки программ Вам необходимо изучить как устанавливаются rpm (man rpm) и как работает yum. Большую часть необходимого вы сможете установить из пакетов, не собирая ничего.

Если всё же таки вам действительно нужно что-то собрать, то в тарболле, как правило, всегда идёт файл README или INSTALL. Нередко и то и другое, где описывается всё необходимое и список зависимостей для сборки. Обязательно наличие установленного компилятора и билиотек для сборки. Как правило, они содержат в названии пакета -dev или -devel.

Link to post
Share on other sites

Процесс устаеновки в простеших слчаях выглядит так:

rpm -i имя_пакета.rpm

yum install имя_пакета

Сборка:

./configure && make && make install clean

Но это простейшие случаи. Могут быть различные нюансы вроде отсутствующих зависимостей, недостающих библиотек и ошибок компиляции Smile

Link to post
Share on other sites

я сделал как вначале было написано мейк отсутсвовали библотеки а мейк инстал вобше не поешл я уставналиваю креатив х-фи может сталкивался подскажи какие бибилиотеки надо доставить?

Link to post
Share on other sites

Насколько я помню, для сборки этих драйверов требуются gcc 4-х версий, а также пакет linux-headers-версия-вашего-ядра, а также минимальный для сборки набор пакетов куда должен входить automake, autotools и libс.Не знаю насчёт 10й федоры, но во всяких Убунтах он этот пакет зовётся как build-essential. Но за наличие такого пакета вас не ручаюсь.

Link to post
Share on other sites

всеранвно не помогает пишет следуйшие

make -C /lib/modules/2.6.27.5-117.fc10.i686/build M=/home/XLBaron/Загрузки/XFiDrv_Linux_Public_US_1.00

make: *** /lib/modules/2.6.27.5-117.fc10.i686/build: Нет такого файла или каталога. Останов.

make: *** [all] Ошибка 2

[XLBaron@XLBaron XFiDrv_Linux_Public_US_1.00]$

Link to post
Share on other sites

теперь написал такое

make -C /lib/modules/2.6.27.5-117.fc10.i686/build M=/home/XLBaron/Загрузки/XFiDrv_Linux_Public_US_1.00

make: *** /lib/modules/2.6.27.5-117.fc10.i686/build: Нет такого файла или каталога. Останов.

make: *** [all] Ошибка 2

[XLBaron@XLBaron XFiDrv_Linux_Public_US_1.00]$

а систему н7адо перезагружать после установки пакетов?

Link to post
Share on other sites

To вопрошающий:

А, позвольте поинтересоваться, какова причина использования дистрибутива 2х летней давности? Может, имеет смысл для начала поставить Russian Fedora 13?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...