Jump to content
Sign in to follow this  
$oft

Реанимация сетевой карты...

Recommended Posts

За несколько дней до того сетевая карта упала, я ее настроил, она работала как надо, инет тырила у большого компа, с виндой связывалась - вобщем делала то что я хотел.

на днях решил снова выйти в инет через свой маленький бук (MSI wind U120) через линукс (Linux Mint 7 universal) через сетевой кабель через большой комп (windows xp)... цепочка действий думаю понятна (раньше настраивал и выходил уже таким образом).

включаю бук, и тут линукс ПАХ Shocked мне! и нет сети (даже то что в него кабель воткнут не пишет)... Surprised смотрю все настройки проводных линий отсутствуют! смотрю в сетевые инструменты: хорошо хоть видит сетевое устройство eth0... но от этого eth0 остался только мак адрес (00:24:21:6d:96:13) и МТУ (1500)... ipV6, IPv4, ip адреса, маска подсети и все остальное по нулям... состояние неактивен!

как реанимировать сетевуху на линуксе?

Share this post


Link to post
Share on other sites

во-первых, читать до просветления: http://segfault.kiev.ua/smart-questions-ru.html

Во-вторых, после просветления более внятно рассказать, как у вас сеть организована, как и что вы настраивали, какие сообщения об ошибках получали...

Share this post


Link to post
Share on other sites

Сеть организована следующим образом:

есть 2 компьютера (Обычный с системным блоком, монитором,и тд И маленький нэтбук MSI wind U120)

компьютеры соеденены между собой сетевым кабелем (комп-комп).

к большому компьютеру подключен инет (билайн модем ZTE MF 626 или говно-модем 56к)..

предполагается (было настроено до "комы" сетевой карты на MSI), что большой комп раздает инет маленькому по сетевому кабелю.

исходя из этого на большом компе (windows xp)

ip: 192.168.0.1

маска подсети: 255.255.255.0

основной шлюз: пусто ( . . . )

DNS - пусто.

На маленьком я настраивал ручками (по другому как-то не хотел он настраиваться) в

/etc/network/interfaces

Цитата:

auto lo

iface lo inet loopback

iface eth0 inet dhsp

netmask 255.255.255.0

gateway 192.168.0.1

эта настройка работала.

попробовал убрать настройки внешнего соединения

Цитата:

auto lo

iface lo inet loopback

это ничего не дало.

В сетевых соединениях (на некоторых networkmanager) изначально исчезли все проводные соединения. Я создал новое проводное соединение со всеми настройками как было - это ничего не дало.

При нажатии кнопки "Сведения о соединении" в контекстном меню значка в трее вылезает ошибка:

"Не найдено новых доступных активных соединений!"

При этом винда большого компа на этот счет думает "Подключение по локальной сети подключено".

Сетевая карта на MSI 100% рабочая, так как винда на этом MSI работает с сетью исправно.

На большом компе так же есть линукс (Ubuntu 8.10). Пробовал списать настройки сети оттуда - безуспешно. В интернете не нашел подобных траблов с сетевухой на лине.

Думаю что настройки сети здесь вообще не причем. Тут нужны настройки сетевой карты. В линуксе я отношусь к категории: неуверенный пользователь, поэтому не знаю какой файл отвечает за настройки сетевой карты и какие команды набирать что бы посмотреть состояние карты, менять ее параметры.

На мой взгляд если тупо заменить текущие файлы, относящиеся к сетевой карте, файлами с дистрибутива, это приведет к стандартным настройкам и конфигурации. Знать бы где эти файлы и папки.

Что привело к такой реакции линя не могу сказать...

Share this post


Link to post
Share on other sites

$oft писал(а) Thu, 05 November 2009 03:27

Сеть организована следующим образом:

есть 2 компьютера (Обычный с системным блоком, монитором,и тд И маленький нэтбук MSI wind U120)

компьютеры соеденены между собой сетевым кабелем (комп-комп).

к большому компьютеру подключен инет (билайн модем ZTE MF 626 или говно-модем 56к)..

предполагается (было настроено до "комы" сетевой карты на MSI), что большой комп раздает инет маленькому по сетевому кабелю.

исходя из этого на большом компе (windows xp)

ip: 192.168.0.1

маска подсети: 255.255.255.0

основной шлюз: пусто ( . . . )

DNS - пусто.

На маленьком я настраивал ручками (по другому как-то не хотел он настраиваться) в

/etc/network/interfaces

Цитата:

auto lo

iface lo inet loopback

iface eth0 inet dhsp

netmask 255.255.255.0

gateway 192.168.0.1

эта настройка работала.

попробовал убрать настройки внешнего соединения

Цитата:

auto lo

iface lo inet loopback

это ничего не дало.

В сетевых соединениях (на некоторых networkmanager) изначально исчезли все проводные соединения. Я создал новое проводное соединение со всеми настройками как было - это ничего не дало.

При нажатии кнопки "Сведения о соединении" в контекстном меню значка в трее вылезает ошибка:

"Не найдено новых доступных активных соединений!"

При этом винда большого компа на этот счет думает "Подключение по локальной сети подключено".

Сетевая карта на MSI 100% рабочая, так как винда на этом MSI работает с сетью исправно.

На большом компе так же есть линукс (Ubuntu 8.10). Пробовал списать настройки сети оттуда - безуспешно. В интернете не нашел подобных траблов с сетевухой на лине.

Думаю что настройки сети здесь вообще не причем. Тут нужны настройки сетевой карты. В линуксе я отношусь к категории: неуверенный пользователь, поэтому не знаю какой файл отвечает за настройки сетевой карты и какие команды набирать что бы посмотреть состояние карты, менять ее параметры.

На мой взгляд если тупо заменить текущие файлы, относящиеся к сетевой карте, файлами с дистрибутива, это приведет к стандартным настройкам и конфигурации. Знать бы где эти файлы и папки.

Что привело к такой реакции линя не могу сказать...

ip li ls что выдаёт?

Share this post


Link to post
Share on other sites

$oft писал(а) Thu, 05 November 2009 01:27

auto lo

1. Добавляем

auto eth0

чтобы и этот интерфейс также поднимался при загрузке

Цитата:

iface lo inet loopback

Всё верно.

Цитата:

iface eth0 inet dhsp

netmask 255.255.255.0

gateway 192.168.0.1

Полная билеберда. Это работать НЕ_МОГЛО.

Определяемся, каким образом eth0 получает настройки: вручную или по dhcp (но никак не dhsp).

В первом случае пишем

iface eth0 inet static

address 192.168.0.2

netmask 255.255.255.0

gateway 192.168.0.1

Во втором -

iface eth0 inet dhcp

а адрес, маску и гейтвей прописываем на dhcp сервере (в Вашем случае на Венде, может они там уже прописаны).

Цитата:

попробовал убрать настройки внешнего соединения

Цитата:

auto lo

iface lo inet loopback

это ничего не дало.

Нужно знать, что делаете. Метод "тыка" даже в венде далеко не всегда приводит к нужным результатам.

Цитата:

Думаю что настройки сети здесь вообще не причем. Тут нужны настройки сетевой карты. В линуксе я отношусь к категории: неуверенный пользователь, поэтому не знаю какой файл отвечает за настройки сетевой карты и какие команды набирать что бы посмотреть состояние карты, менять ее параметры.

На мой взгляд если тупо заменить текущие файлы, относящиеся к сетевой карте, файлами с дистрибутива, это приведет к стандартным настройкам и конфигурации. Знать бы где эти файлы и папки.

Если Вы читали замечательную статью, рекомендованую AccessD, то стоило обратить внимание на рекомендацию засорять форум своими предположениями, тем более они совершенно необоснованы.

Share this post


Link to post
Share on other sites

2 $oft

Для начала я бы попробовал грузануться с какого нибудь Live CD и убедился что проблема не в сетевухе или кабеле. Если вы неуверенно чувствуете себя в линукс то есть и виндовые сборки работающие с CD или flash, там настройка сети не вызывает затруднений. И еще, может стоит попробовать указать IP явным образом и посмотреть проходит ли пинг, попробовать на время проверки остановить виндовый брэндмауэр.

Share this post


Link to post
Share on other sites

Спасибо за помощь... есть над чем подумать но по неизвестной причине все вернулось в нормальное положение. Возможно проблема была с кривыми interfaces, хотя я его писал по аналогии с большим компом.

С большим компом (убунту) возникала подобная проблема, когда после настройки и перезагрузки он не хотел грузится до гонца, т.к. eth0 автоматом запускалось при загрузке в то время как маленький бук отключен от сети... и загрузка продолжалась только после того как подключался маленький бук с виндой, дающий айпи пинг.

Вобщем огромное спасибо! +1 всем) Тема закрыта...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...