Jump to content
Sign in to follow this  
VarLam

aticonfig -неработает

Recommended Posts

Всем доброго времени суток! У меня возникла небольшая проблема при установке драйвера ATI. В общем сам драйвер ставится нормально, без ошибок, но вот при запуске aticonfig --initial выдаётся следуюющее:

SERGEYCOMP:~# aticonfig --initial

Uninitialised file found, configuring.

Using /etc/X11/xorg.conf

Saved back-up to /etc/X11/xorg.conf.fglrx-0

Как с этим бороться? Я пробовал ставить различные версии драйвера, различными способами, эффект тот же, даже при установке из репозитария результат не меняется( не могу запустить aticonfig)

Share this post


Link to post
Share on other sites

Вы пробовали перевести на русский язык сообщение, которое вы получаете?

А ЧТО вы хотите чтобы произошло?

Share this post


Link to post
Share on other sites

С английским у меня слабовато, т.к. учил только французский) Но как я понял он не может найти конфигурационный файл, предлагает использовать xorg.conf , который распологается /etc/X11/. Задача: после установки драйвера сконфигугрировать новый xorg.conf чтобы система работала с новым драйвером, т.к. родной драйвер меня неустраивает( драйвер Mesa). Редактировать в ручную xorg.conf я пока немогу, знания ещё непозволяют, именно поэтому пытаюсь применить aticonfig. Дистрибутив Debian/etch.

Share this post


Link to post
Share on other sites

Насколько я понимаю, aticonfig успешно внес изменения в ваш конфигурационный файл (/etc/X11/xorg.conf), то есть все нормально...

Что у вас конкретно не работает-то, расскажите. Попробуйте запустить glxgears (это нужно делать из графической оболочки) для проверки.

Share this post


Link to post
Share on other sites

SERGEYCOMP:~# fglrxinfo

display: :0.0 screen: 0

OpenGL vendor string: Tungsten Graphics, Inc.

OpenGL renderer string: Mesa DRI R300 20060815 AGP 1x TCL

OpenGL version string: 1.2 (1.3 Mesa 6.5.1)

ERGEYCOMP:~# fgl_glxgears

Using GLX_SGIX_pbuffer

X Error of failed request: BadMatch (invalid parameter attributes)

Major opcode of failed request: 143 (GLX)

Minor opcode of failed request: 5 (X_GLXMakeCurrent)

Serial number of failed request: 35

Current serial number in output stream: 35

Как видим OpenGL неработает, присутсвие драйвера тоже не видно.

Ставил драйвер так:

SERGEYCOMP:~/Desktop# ./ati-driver-installer-8.35.5-x86.x86_64.run --buildpkg Debuian/etch

сознано было 4 пакета:fglrx-amdcccle_8.35.5-1_i386.deb , fglrx-driver_8.35.5-1_i386.deb , fglrx-driver-dev_8.35.5-1_i386.deb , fglrx-kernel-src_8.35.5-1_i386.deb

затем ставлю полученные пакеты:

dpkg -i fglrx-................_i386.deb

после этого:

SERGEYCOMP:~/Desktop# module-assistant prepare,update

SERGEYCOMP:~/Desktop# module-assistant build,install fglrx

и затем уже делаю aticonfig

кстати xorg.conf действительно изменяется, но как уже говорил выше больше неизменяется ничего

Кстати почему aticonfig изменяет xorg.conf незадавая мне никаких вопросов? Насколько я знаю должен открываться диалог с пользователем.

Share this post


Link to post
Share on other sites

Ок. Давайте разбираться.

Можете приложить файлы /etc/X11/xorg.conf и /var/log/Xorg.0.log к вашему сообщению?

И еще покажите, пожалуйста, вывод команды lsmod после запуска Х-сервера.

Share this post


Link to post
Share on other sites

Уф, совсем намудрил с этими драйверами. Решил начать всё заново и переустановил систему. Поставил пакеты необходимые для установки драйвера, обновил систему, установил драйвера заново.

И вот что получил в результате:

varlam@SERGEYCOMP:~$ fglrxinfo

display: :0.0 screen: 0

OpenGL vendor string: ATI Technologies Inc.

OpenGL renderer string: RADEON 9800 SE

OpenGL version string: 2.0.6400 (8.35.5)

varlam@SERGEYCOMP:~$ fgl_glxgears

Using GLX_SGIX_pbuffer

2474 frames in 5.0 seconds = 494.800 FPS

2979 frames in 5.0 seconds = 595.800 FPS

2962 frames in 5.0 seconds = 592.400 FPS

2975 frames in 5.0 seconds = 595.000 FPS

2972 frames in 5.0 seconds = 594.400 FPS

2981 frames in 5.0 seconds = 596.200 FPS

2983 frames in 5.0 seconds = 596.600 FPS

2976 frames in 5.0 seconds = 595.200 FPS

НО, после установки этого драйвера и при запуске Х-ов, разрешение 1600*1200. Естественно меняю разрешение и ставлю 1024*768. Пытаюсь перезапустить Х-ы, но они теперь незапускаются( это всё проделывал под рутом). Далее делаю ребут( у меня поставлен графический вход, и логин с паролем обычного пользователя я ввожу уже в графической оболочке), как ни странно но Х-ы запускаются и предлагается ввести логин,пароль обычного пользователя, что я и делаю( разрешение опять же 1600*1200). Вхожу под обычным пользователем, меняю разрешение на 1024*768, перезагружаюсь. Опять предлогается ввести пароль обычного пользователя при разрешении 1600*1200, вхожу, разрешение снова 1024*768. Вобшем не пойму в чём дело, так понял что после установки драйвера разрешения все сбились, Как это можно исправить? Установил Cedega и решил провести тесты, которые в ней прилогаются, выяснил что 3D у меня неробит.

Вот файлы которые вы просили выложить:

1)xorg.conf

# /etc/X11/xorg.conf (xorg X Window System server configuration file)

#

# This file was generated by dexconf, the Debian X Configuration tool, using

# values from the debconf database.

#

# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.

# (Type "man /etc/X11/xorg.conf" at the shell prompt.)

#

# This file is automatically updated on xserver-xorg package upgrades *only*

# if it has not been modified since the last upgrade of the xserver-xorg

# package.

#

# If you have edited this file but would like it to be automatically updated

# again, run the following command:

# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"

Identifier "Default Layout"

Screen 0 "aticonfig-Screen[0]" 0 0

InputDevice "Generic Keyboard"

InputDevice "Configured Mouse"

EndSection

Section "Files"

# path to defoma fonts

FontPath "/usr/share/fonts/X11/misc"

FontPath "/usr/X11R6/lib/X11/fonts/misc"

FontPath "/usr/share/fonts/X11/cyrillic"

FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"

FontPath "/usr/share/fonts/X11/100dpi/:unscaled"

FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"

FontPath "/usr/share/fonts/X11/75dpi/:unscaled"

FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"

FontPath "/usr/share/fonts/X11/Type1"

FontPath "/usr/X11R6/lib/X11/fonts/Type1"

FontPath "/usr/share/fonts/X11/100dpi"

FontPath "/usr/X11R6/lib/X11/fonts/100dpi"

FontPath "/usr/share/fonts/X11/75dpi"

FontPath "/usr/X11R6/lib/X11/fonts/75dpi"

FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"

EndSection

Section "Module"

Load "i2c"

Load "bitmap"

Load "ddc"

Load "dri"

Load "extmod"

Load "freetype"

Load "glx"

Load "int10"

Load "vbe"

EndSection

Section "InputDevice"

Identifier "Generic Keyboard"

Driver "kbd"

Option "CoreKeyboard"

Option "XkbRules" "xorg"

Option "XkbModel" "pc104"

Option "XkbLayout" "us,ru"

Option "XkbVariant" ",winkeys"

Option "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll"

EndSection

Section "InputDevice"

Identifier "Configured Mouse"

Driver "mouse"

Option "CorePointer"

Option "Device" "/dev/input/mice"

Option "Protocol" "ImPS/2"

Option "Emulate3Buttons" "true"

EndSection

Section "Monitor"

Identifier "DELL P780"

Option "DPMS"

EndSection

Section "Monitor"

Identifier "aticonfig-Monitor[0]"

Option "VendorName" "ATI Proprietary Driver"

Option "ModelName" "Generic Autodetecting Monitor"

Option "DPMS" "true"

EndSection

Section "Device"

Identifier "ATI Technologies Inc R350 AH [Radeon 9800]"

Driver "ati"

BusID "PCI:1:0:0"

EndSection

Section "Device"

Identifier "aticonfig-Device[0]"

Driver "fglrx"

EndSection

Section "Screen"

Identifier "Default Screen"

Device "ATI Technologies Inc R350 AH [Radeon 9800]"

Monitor "DELL P780"

DefaultDepth 24

SubSection "Display"

Depth 1

Modes "1024x768" "800x600" "640x480"

EndSubSection

SubSection "Display"

Depth 4

Modes "1024x768" "800x600" "640x480"

EndSubSection

SubSection "Display"

Depth 8

Modes "1024x768" "800x600" "640x480"

EndSubSection

SubSection "Display"

Depth 15

Modes "1024x768" "800x600" "640x480"

EndSubSection

SubSection "Display"

Depth 16

Modes "1024x768" "800x600" "640x480"

EndSubSection

SubSection "Display"

Depth 24

Modes "1024x768" "800x600" "640x480"

EndSubSection

EndSection

Section "Screen"

Identifier "aticonfig-Screen[0]"

Device "aticonfig-Device[0]"

Monitor "aticonfig-Monitor[0]"

DefaultDepth 24

SubSection "Display"

Viewport 0 0

Depth 24

EndSubSection

EndSection

Section "DRI"

Mode 0666

EndSection

Команда lsmod:

Module Size Used by

fglrx 654044 11

button 6800 0

ac 5252 0

battery 9732 0

ipv6 213856 8

nls_utf8 2304 1

nls_cp866 5504 1

vfat 11648 1

fat 45980 1 vfat

dm_snapshot 15644 0

dm_mirror 18000 0

dm_mod 48952 2 dm_snapshot,dm_mirror

loop 14216 0

tsdev 7616 0

sd_mod 19088 0

snd_emu10k1_synth 6656 0

snd_emux_synth 29952 1 snd_emu10k1_synth

snd_seq_virmidi 6528 1 snd_emux_synth

snd_seq_midi_emul 6016 1 snd_emux_synth

snd_seq_dummy 3972 0

snd_seq_oss 27648 0

snd_seq_midi 8352 0

snd_seq_midi_event 6784 3 snd_seq_virmidi,snd_seq_oss,snd_seq_midi

snd_seq 42192 9 snd_emux_synth,snd_seq_virmidi,snd_seq_midi_emul,snd_seq_dum my,snd_seq_oss,snd_seq_midi,snd_seq_midi_event

floppy 52004 0

serio_raw 6532 0

snd_via82xx 25368 0

snd_emu10k1 100544 1 snd_emu10k1_synth

snd_mpu401 7528 0

snd_mpu401_uart 7552 2 snd_via82xx,snd_mpu401

psmouse 34568 0

analog 10528 0

rtc 11572 0

snd_rawmidi 22048 4 snd_seq_virmidi,snd_seq_midi,snd_emu10k1,snd_mpu401_uart

snd_ac97_codec 82848 2 snd_via82xx,snd_emu10k1

snd_ac97_bus 2432 1 snd_ac97_codec

snd_pcm_oss 38048 0

snd_mixer_oss 15232 1 snd_pcm_oss

parport_pc 31524 0

parport 32200 1 parport_pc

i2c_viapro 8340 0

snd_pcm 65928 4 snd_via82xx,snd_emu10k1,snd_ac97_codec,snd_pcm_oss

snd_seq_device 7820 8 snd_emu10k1_synth,snd_emux_synth,snd_seq_dummy,snd_seq_oss,s nd_seq_midi,snd_seq,snd_emu10k1,snd_rawmidi

snd_timer 19972 3 snd_seq,snd_emu10k1,snd_pcm

snd_page_alloc 9736 3 snd_via82xx,snd_emu10k1,snd_pcm

snd_util_mem 4736 2 snd_emux_synth,snd_emu10k1

snd_hwdep 8836 2 snd_emux_synth,snd_emu10k1

snd 45412 16 snd_emux_synth,snd_seq_virmidi,snd_seq_oss,snd_seq,snd_via82 xx,snd_emu10k1,snd_mpu401,snd_mpu401_uart,snd_rawmidi,snd_ac 97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_device,sn d_timer,snd_hwdep

i2c_core 19472 1 i2c_viapro

pcspkr 2816 0

emu10k1_gp 3968 0

gameport 13832 4 snd_via82xx,analog,emu10k1_gp

soundcore 8928 1 snd

shpchp 32796 0

pci_hotplug 28088 1 shpchp

via_agp 9728 1

agpgart 29360 2 fglrx,via_agp

evdev 9088 1

ext3 116488 3

jbd 47272 1 ext3

usb_storage 71360 0

scsi_mod 121992 2 sd_mod,usb_storage

8139too 24192 0

ide_cd 35616 0

cdrom 32416 1 ide_cd

ide_disk 14848 6

8139cp 20736 0

via_rhine 21768 0

mii 5376 3 8139too,8139cp,via_rhine

ehci_hcd 27144 0

uhci_hcd 20236 0

usbcore 109444 4 usb_storage,ehci_hcd,uhci_hcd

via82cxxx 8452 0 [permanent]

generic 5508 0 [permanent]

ide_core 107760 5 usb_storage,ide_cd,ide_disk,via82cxxx,generic

thermal 13576 0

processor 23724 1 thermal

fan 4868 0

Файл Xorg.0.log сделал как вложение

Share this post


Link to post
Share on other sites

Цитата:

Установил Cedega и решил провести тесты, которые в ней прилогаются, выяснил что 3D у меня неробит.

как бы это помягче. Вобще за год мытарств и чтения мануалов я выяснил одну штуку - по идее это от дистрибутива зависит, но фактически - 3D НОРМАЛЬНО работать и не будет. Вернее когда нибудь да. Но не сейчас.

fxgrl - это на самом деле очень кривая бяка.

У меня лично так и не вышло поставить все и сразу. Под проприаритаркой не работает beryl и компиз, очень медленно работает сам менеджер окон, но зато идут нативные 3D приложения (еще бы - opengl то есть Smile ) То есть игры типа Postal 2 и так далее.

НО под wine результат с winehq совпал тока один раз - Warcraft III с опцией запуска -opengl Smile

Все. Отрубая проприаритарки, получаю рабочий 3D интерфейс, шустрый и красивый, но при этом емкие 3D приложения просто не идут.

Про эмуляцию в таком случае вообще лучше забыть.

Share this post


Link to post
Share on other sites

Цитата:

Вобще за год мытарств и чтения мануалов я выяснил одну штуку - по идее это от дистрибутива зависит, но фактически - 3D НОРМАЛЬНО работать и не будет.

ересь.

карты Nvidia производителем поддерживаются замечательно, 3Д работает отлично. проблемы есть у АТИ, хотя в Кноппикс даже радеон 9250 заработал в 3Д.

Share this post


Link to post
Share on other sites

извиняюсь заранее если не сюда пишу.

такая проблема после установки драйвера ati-driver-installer-8.42.3-x86.x86_64, перестал работать opengl. как быть что делать??

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...