Jump to content
Sign in to follow this  
CMaPT

Помогите пингвинёнку с установкой двух драйверов

Recommended Posts

С Виндовса на Линукс (Mandriva 2006 FREE) я перешёл резко и пол месяца назад, так что вопросов у меня куча, но задам только два самых необходимых. Smile

Первый, самый важный: у меня где то три года уже есть антенка, Microsoft Wireless USB 2.0 Adapter mn710 . Есть и оригиналбный диск с драйверам под неё. Они, естественно, сделаны под Винду и никто и не собирается их делать под Линукс. Выискал информацию про Ndiswrapper, успешно его установил. Стал устанавливать драйвера через Центр управления, Сеть и Интернет, Настройка нового сетевого интерфейса, Беспроводное соединение, Использовать драйвер Виндовс (с Ndiswrapper), выбрал драйвер с диска mn710-51.sys (я читал в нете - это единственный подходящий), жму далее, а он мне выдаёт - Не обнаружено устройств, поддерживающих mn710-51.sys Ndiswrapper драйвер! . Действителбно, светодиод Питание на антенке не горит, а пытался я уже её подключить ко всем восьми USB выходам. В чём проблема? Confused

Второй, если лень - можно не отвечать: в компе у меня стоит AGP VideoCard Ati Radeon 9800Pro 128mb . Драйвера под Линукс к счастью у них на сайте были, но опять же не смог с ним разобраться, т.к. нигде не нашёл инструкций по установке. Название драйвера изначально выглядит так: ati-driver-installer-8.32.5-x86.x86_64.run.txt . Расскажите, пожалуйста, что мне и как надо сделать с этим драйвером? Confused

Заранее благодарен, ваш Чайник! Cool

Share this post


Link to post
Share on other sites

CMaPT писал(а) Thu, 04 January 2007 22:57

Название драйвера изначально выглядит так: ati-driver-installer-8.32.5-x86.x86_64.run.txt . Расскажите, пожалуйста, что мне и как надо сделать с этим драйвером? Confused

Если txt, то читать, если run, то запускать Smile

Из каталога, где лежит этот файл:

chmod +x ati-driver*

./ati-driver-installer-8.32.5-x86.x86_64.run.txt

Share this post


Link to post
Share on other sites

Да, спасибо. Только после ввода этой команды не должно появляться каково нибудь хоть бы ответа или окна инсталяции?

Confused

Share this post


Link to post
Share on other sites

С первым ничем помочь не могу. По второму - откройте окно терминала, перейдите в каталог, где лежит Ваш файл, выполните указанные команды и скопируйте сюда вывод этих команд. Для копирования выделите текст левым кнопом, при этом он автоматически заносится в буфер, после этого просто нажимаете здесь в форме ввода третью кнопку мыши, содержимое буфера вставляется. В окне терминала стандартные виндозные Ctrl+C, Ctrl+V не помогут.

Share this post


Link to post
Share on other sites

К сожаленью, копировать совершенно нечего - после ввода команды ( chmod +x ati-driver-installer-8.32.5-x86.x86_64.run.txt )ничего не происходит и сразу же выдвигается новая строка для ввода команд и всё. Даже нет эррора или ругни БАША. Да и если бы что то и было, всё равно я скопировать не смог бы - я сейчас пишу с Нотбука. Confused

Share this post


Link to post
Share on other sites

CMaPT писал(а) Fri, 05 January 2007 15:58

К сожаленью, копировать совершенно нечего - после ввода команды ( chmod +x ati-driver-installer-8.32.5-x86.x86_64.run.txt )ничего не происходит и сразу же выдвигается новая строка для ввода команд и всё. Даже нет эррора или ругни БАША. Да и если бы что то и было, всё равно я скопировать не смог бы - я сейчас пишу с Нотбука. Confused

./ati-driver-installer-8.32.5-x86.x86_64.run.txt

А эту команду Вы давали?

Интересен вывод именно этой команды.

Share this post


Link to post
Share on other sites

во-первых - на сайте АТИ все инструкции есть, читайте внимательнее.

во-вторых - вы уверены,что скачали именно пакет?

сколько я их скачивал, они все были .run, весили около 50 метров

Share this post


Link to post
Share on other sites

(..Простите, что припозднился с ответом..)

Да, и вправду, я просто не обратил внимания на эту команду. Вот что он вывел -

Creating directory fglrx-install

Verifying archive integrity... All good.

Uncompressing ATI Proprietary Linux Driver-8.32.5...............................................

............................................................

............................................................

............................................................

............................................................

............................................................

............................................................

............................................................

............................................................

.........................................................

==================================================

ATI Technologies Linux Driver Installer/Packager

==================================================

Detected configuration:

Architecture: i686 (32-bit)

X Server: X.Org 6.9.x

А потом появилось окно для установки драйвера. Я прошол весь путь установки -

1. Install Driver 8.32.5 on X.Org 6.9.x -> Continue

2. License -> Agree

3. Automatic -> Continue

4. Installing...

5. Installation Completed

В появившемся окне идёт -

Installation is complete.

The log file has been stored to /usr/share/ati.

Далее он говорит, что нада сохранить X Window configuration file ( что это за фаил и где он лежит? ) и запусти aticonfig (в консольном окне) для завершения конфигурации настроек дисплея. Объясните, как мне это осуществить? Как делать настройки далее?

A reboot of the system is recommended after running aticonfig.

6. -> EXIT <-

Что здесь к чему? Confused

P.S. После того, что я проделал даже тетрис всё равно лагует на максимальных графических настройках... Crying or Very Sad

Share this post


Link to post
Share on other sites

Цитата:

Первый, самый важный: у меня где то три года уже есть антенка, Microsoft Wireless USB 2.0 Adapter mn710 . Есть и оригиналбный диск с драйверам под неё. Они, естественно, сделаны под Винду и никто и не собирается их делать под Линукс. Выискал информацию про Ndiswrapper, успешно его установил. Стал устанавливать драйвера через Центр управления, Сеть и Интернет, Настройка нового сетевого интерфейса, Беспроводное соединение, Использовать драйвер Виндовс (с Ndiswrapper), выбрал драйвер с диска mn710-51.sys (я читал в нете - это единственный подходящий), жму далее, а он мне выдаёт - Не обнаружено устройств, поддерживающих mn710-51.sys Ndiswrapper драйвер!

Подозреваю, что проблема в USB.

Система видит какой-нить юсб-девайс?

Share this post


Link to post
Share on other sites

Я знаю, у меня стоит ЮСБ версии 1.10 . Но точно такая же антенка у меня стоит на Нотбуке. А здесь у меня эти Порты старой версии, 2.0 они точно не поддерживают, но интернет прекрасно работает. Иначе бы я щас не писал бы этого. Кстати, Линукс вообще в ЮСБ замечает только Флэшку и мышь. Остальное для него воздух (ВЕБ камера, интернет, принтер и т.д.) Какие препятствия? Sad

Share this post


Link to post
Share on other sites

Цитата:

Кстати, Линукс вообще в ЮСБ замечает только Флэшку и мышь.

Значит сама поддержка usb уже работает.

Цитата:

Остальное для него воздух (ВЕБ камера, интернет, принтер и т.д.)

Воздух или нет должен ответить lsusb с включённым девайсом разумеется.

Share this post


Link to post
Share on other sites

CMaPT писал(а) Fri, 05 January 2007 23:46

lsusb - это команда?

Да, это команда. Перед тем как спрашивать, могли бы попробовать ее выполнить на своей машине, ато получается медленный чат, лишенный содержания.

Цитата:

( Простите, если это глупый вопрос. Я менее чем ноль в Линуксе Embarassed )

И вы, видимо, более чем удовлетворены этим положением вещей.

Драйверы для видео установить не можете, несмотря на то, что к ним прилагается ИСЧЕРПЫВАЮЩАЯ пошаговая инструкция.

Поискать в Google.com ответ на свой вопрос не хотите. То есть, по большому счету демонстрируете полное нежелание чему-нибудь учиться, но хотите при этом, чтоб вам все сделали Smile

Мне кажется, вам стоит ознакомиться вот с этим документом:

http://www.ln.com.ua/~openxs/articles/smart-questions-ru.htm l

Если бы вы хотя бы параллельно книгу какую-нибудь умную читали, это одно дело, а так...

P.S. Не мог бы добренький дяинька модератор чуть-чуть подрезать лишние точечки в сообщении вопрошающего выше, а то как-то форматируется странно страничка.

Share this post


Link to post
Share on other sites

Да, не ожидал... Sad

Ааа, вы ко всем такого мнения, кто спрашивает лёгкие вопросы по Линуксу?

Share this post


Link to post
Share on other sites

Нет, только к тем, кто злоупотребляет.

2 W_M - какие точечки??? Что именно съезжает?

Share this post


Link to post
Share on other sites

Интересно, чем я здесь злоупотребляю?.. Да, ссылку которую мне дали ( как задавать вопросы ) я почитал. Немного с опоздпнием, но скажу - искал решение проблемы любыми путями - не удалось. Вот прибегнул к Вашему форуму. Надеюсь, доказательств, что я не бездельник и тратильщик чужого времени предъявлять не надо? Confused

Share this post


Link to post
Share on other sites

2 CMaPT

Зря вы обижаетесь. Я просто вам прозрачно намекнул, что вы просите помощи с очевидными, лежащими на поверхности вещами. Причем одна из них (про драйвер) ТОЧНО исчерпывающе описана в документации от разработчика. Что стоило ее прочитать и делать как там написано? Подозреваю, что в том же может быть проблема и с вашим WiFi адаптером. Я конечно и не предполагаю, что родной всем нам Микрософт вдруг сделал драйверы под Linux, однако велика вероятность того, что кто-то уже эту железку заставил работать под Linux, если это вообще возможно. Более того, один из первой сотни сделавших это наверняка написал для вас инструкцию, как повторить его подвиг.

Если вы говорите, что пользуетесь поиском, что же вы интересно спрашиваете у поисковой машины и, самое главное, у какой?

2 Aceler

См. Скриншот.

Может быть дело просто в Опере? Чего-то она мудрит Sad

Share this post


Link to post
Share on other sites

У меня предложение продолжить тему с её места обрывания - (CMaPT писал(а) Fri, 05 January 2007 23:46

lsusb - это команда?

Да, это команда. Перед тем как спрашивать, могли бы попробовать ее выполнить на своей машине, ато получается медленный чат, лишенный содержания.)

Я эту команду ввёл в консоли, но БАШ ругнулся - bash: lsusb: command not found. Может, это ls usb? Я её тоже пробовал, но результат почти тот же, только он сказал - ls: usb: No such file or directory .

Share this post


Link to post
Share on other sites

С WiFi адаптером у меня с установкой драйверов и настроек нет. Здесь вопрос, почему я его не могу подключить нормально к компьютеру ( ЮСБ его не распознаёт ). А на сайте АТИ описание установки драйвера идёт до кнопки Екзит в последнем окне установки. А как где и что настраивать ни одного слова. То что я это под десятками видов запросов искал в Гугле можете не сомневаться. Дажет сейчас приведу несколько из них -

[usb 2 0 driver linux]

[mn 710 driver linux]

[ati driver aticonfig]

[mn710 linux driver]

Это самые плодородные варианты.

Share this post


Link to post
Share on other sites

Да, кстати, я всё таки решил посмотреть АТИшные рекомендации ещё раз и всё что там описано, как я говорил, уже делал. Единственное, могу показать, что он мне вывел на /usr/X11R6/bin/aticonfig --initial -

Uninitialised file found, configuring.

Using /etc/X11/xorg.conf

Saved back-up to /etc/X11/xorg.conf.original-0

/usr/X11R6/bin/aticonfig: Writing to '/etc/X11/xorg.conf' failed. Bad file descriptor.

Почему запись в '/etc/X11/xorg.conf' сорвалась?

Продолжение ---

Из РУТА вроде получилось. Только я не понимаю всё же, что такое конфиги в таком случае, если я ввожу выше упомянутую команду, получаю в ответ что он чтото кудато сохранил и просит сделать Ребуут ? Допустим это чтото меняет. Но верный способ это проверить - тетрис АРМАГЕТРОН говорит с разрешением 1280 на 1024 что такая графа не по силам моей капточке? Не понятно как то... Confused

Share this post


Link to post
Share on other sites
Вопрос, относящийся к WiFi - какой командой мне запустить установку патча для кёрнела patch-2.6.20-rc3 ? Пишут, что он устраняет множество проблем и делает кучу обновлений, в том числе и ЮСБ 2.0 .

Share this post


Link to post
Share on other sites

CMaPT писал(а) Sat, 06 January 2007 00:45

Вопрос, относящийся к WiFi - какой командой мне запустить установку патча для кёрнела patch-2.6.20-rc3 ?

Командой patch, конечно. Только патчи не устанавливают, а накладывают на исходники, это ж не Винда.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...